fix fetch for mbone/speak-freely
PR: ports/46087 Submitted by: Mark Linimon <linimon@lonesome.com>
This commit is contained in:
parent
bdfda9025b
commit
9f6a6f0bb9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=71572
12 changed files with 108 additions and 176 deletions
|
@ -6,9 +6,9 @@
|
|||
#
|
||||
|
||||
PORTNAME= speak_freely
|
||||
PORTVERSION= 7.1
|
||||
PORTVERSION= 7.5
|
||||
CATEGORIES= mbone audio security
|
||||
MASTER_SITES= http://www.fourmilab.ch/speakfree/unix/
|
||||
MASTER_SITES= http://www.fourmilab.ch/speakfree/unix/download/${PORTVERSION}/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (speak_freely-7.1.tar.gz) = f06e4115c7139f7e30ea57064b324558
|
||||
MD5 (speak_freely-7.5.tar.gz) = fd315f8fd9996b7f34e83d8249ecd89f
|
||||
|
|
|
@ -1,28 +1,33 @@
|
|||
--- Makefile.orig Sat Sep 18 18:29:44 1999
|
||||
+++ Makefile Wed Jan 5 20:23:52 2000
|
||||
@@ -3,7 +3,7 @@
|
||||
|
||||
# Debugging options
|
||||
|
||||
-DEBUG = -g -DHEXDUMP
|
||||
+#DEBUG = -g -DHEXDUMP
|
||||
#DEBUG = -g -DHEXDUMP -DNOCRYPTO
|
||||
--- Makefile.orig Fri Oct 19 07:01:35 2001
|
||||
+++ Makefile Thu Dec 12 02:44:56 2002
|
||||
@@ -6,7 +6,7 @@
|
||||
#DEBUG = -O
|
||||
#DEBUG = -g -DHEXDUMP
|
||||
#DEBUG = -g -DHEXDUMP -DNOCRYPTO
|
||||
-DEBUG = -O3 -DHEXDUMP
|
||||
+#DEBUG = -O3 -DHEXDUMP
|
||||
|
||||
@@ -38,9 +38,9 @@
|
||||
# functionality is working. Please see the detailed description
|
||||
# Installation
|
||||
|
||||
@@ -43,13 +43,13 @@
|
||||
# of the available flags which follows these declarations.
|
||||
#
|
||||
-CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN
|
||||
-CC = gcc -O3 # for GNU's gcc compiler
|
||||
#CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN
|
||||
-CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN -DNEEDED_LINEAR -DLINUX_DSP_SMALL_BUFFER
|
||||
-CC = gcc -Wall # for GNU's gcc compiler
|
||||
+#CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN -DNEEDED_LINEAR -DLINUX_DSP_SMALL_BUFFER
|
||||
+#CC = gcc -Wall # for GNU's gcc compiler
|
||||
# CELPFLAGS below are tweaked for GCC 2.96 on Intel Pentium
|
||||
# Comment out if you are using a compiler which doesn't
|
||||
# understand these options.
|
||||
-CELPFLAGS = -fomit-frame-pointer -ffast-math -funroll-loops
|
||||
-LFLAGS = -lncurses -lm
|
||||
+#CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN
|
||||
+#CC = gcc -O3 # for GNU's gcc compiler
|
||||
+#CELPFLAGS = -fomit-frame-pointer -ffast-math -funroll-loops
|
||||
+#LFLAGS = -lncurses -lm
|
||||
#
|
||||
# If the above LFLAGS doesn't work, try the one below.
|
||||
#LFLAGS = -lcurses -lm
|
||||
@@ -220,8 +220,8 @@
|
||||
@@ -237,8 +237,8 @@
|
||||
# Depending on how your driver handles non-blocking I/O,
|
||||
# you may also have to add -DAUDIO_BLOCKING to the
|
||||
# CCFLAGS line.
|
||||
|
@ -33,31 +38,31 @@
|
|||
|
||||
# Hewlett-Packard
|
||||
# (courtesy of Marc Kilian)
|
||||
@@ -269,7 +269,7 @@
|
||||
@@ -286,7 +286,7 @@
|
||||
|
||||
# Compiler flags
|
||||
|
||||
-CFLAGS = $(DEBUG) -Iadpcm -Ilpc -Igsm/inc -Imd5 -Iidea -Ilibdes -Iblowfish $(CARGS) $(DUPLEX) $(CCFLAGS) $(DOMAIN)
|
||||
+CFLAGS = $(OPTFLAGS) $(DEBUG) -Iadpcm -Ilpc -I$(LOCALBASE)/include -Iidea -Ilibdes -Iblowfish $(CARGS) $(DUPLEX) $(CCFLAGS) $(DOMAIN)
|
||||
-CFLAGS = $(DEBUG) -Iadpcm -Icelp -Ilpc -Igsm/inc -Ilpc10 -Imd5 -Ides -Iidea -Ilibdes -Iblowfish $(CARGS) $(DUPLEX) $(CCFLAGS) $(DOMAIN)
|
||||
+CFLAGS = $(OPTFLAGS) $(DEBUG) -Iadpcm -Icelp -Ilpc -I$(LOCALBASE)/include -Ilpc10 -Imd5 -Ides -Iidea -Ilibdes -Iblowfish $(CARGS) $(DUPLEX) $(CCFLAGS) $(DOMAIN)
|
||||
|
||||
PROGRAMS = sfspeaker sfmike sflaunch sflwld sflwl sfecho sfreflect sfvod
|
||||
BINARIES = sfspeaker sfmike sflaunch sflwld sflwl sfecho sfreflect
|
||||
|
||||
@@ -278,12 +278,12 @@
|
||||
@@ -301,12 +301,12 @@
|
||||
SPKROBJS = speaker.o codecs.o deskey.o g711.o rate.o rtpacket.o soundbyte.o ulaw.o usleep.o vatpkt.o vox.o audio_hp.o audio_sgi.o common.o
|
||||
|
||||
sfspeaker: $(SPKROBJS) adpcmlib.o libblowfish.o lpclib.o lpc10lib.o gsmlib.o deslib.o md5lib.o idealib.o libdes.o xdsub.o
|
||||
- $(CC) $(SPKROBJS) adpcm/adpcm-u.o blowfish/libblowfish.a des/des.a md5/md5.o idea/idea.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o xdsub.o libdes/libdes.a $(LFLAGS) -o sfspeaker
|
||||
+ $(CC) $(SPKROBJS) adpcm/adpcm-u.o blowfish/libblowfish.a des/des.a -lmd idea/idea.a lpc10/liblpc10.a -L/usr/local/lib -lgsm lpc/lpc.o xdsub.o libdes/libdes.a $(LFLAGS) -o sfspeaker
|
||||
sfspeaker: $(SPKROBJS) adpcmlib.o celplib.o libblowfish.o lpclib.o lpc10lib.o gsmlib.o deslib.o md5lib.o idealib.o libdes.o xdsub.o
|
||||
- $(CC) $(SPKROBJS) adpcm/adpcm-u.o blowfish/libblowfish.a celp/celp.o des/des.a md5/md5.o idea/idea.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o xdsub.o libdes/libdes.a $(LFLAGS) -o sfspeaker
|
||||
+ $(CC) $(SPKROBJS) adpcm/adpcm-u.o blowfish/libblowfish.a celp/celp.o des/des.a -lmd idea/idea.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o xdsub.o libdes/libdes.a $(LFLAGS) -o sfspeaker
|
||||
|
||||
MIKEOBJS = mike.o codecs.o deskey.o g711.o rate.o rtpacket.o soundbyte.o ulaw.o usleep.o vatpkt.o xdsub.o audio_hp.o audio_sgi.o
|
||||
|
||||
sfmike: $(MIKEOBJS) adpcmlib.o libblowfish.o lpclib.o lpc10lib.o gsmlib.o deslib.o md5lib.o idealib.o libdes.o
|
||||
- $(CC) $(MIKEOBJS) adpcm/adpcm-u.o des/des.a md5/md5.o idea/idea.a -lm blowfish/libblowfish.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o libdes/libdes.a $(LFLAGS) -o sfmike
|
||||
+ $(CC) $(MIKEOBJS) adpcm/adpcm-u.o des/des.a -lmd idea/idea.a -lm blowfish/libblowfish.a lpc10/liblpc10.a -L/usr/local/lib -lgsm lpc/lpc.o libdes/libdes.a $(LFLAGS) -o sfmike
|
||||
sfmike: $(MIKEOBJS) adpcmlib.o celplib.o libblowfish.o lpclib.o lpc10lib.o gsmlib.o deslib.o md5lib.o idealib.o libdes.o
|
||||
- $(CC) $(MIKEOBJS) adpcm/adpcm-u.o celp/celp.o des/des.a md5/md5.o idea/idea.a -lm blowfish/libblowfish.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o libdes/libdes.a $(LFLAGS) -o sfmike
|
||||
+ $(CC) $(MIKEOBJS) adpcm/adpcm-u.o celp/celp.o des/des.a -lmd idea/idea.a -lm blowfish/libblowfish.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o libdes/libdes.a $(LFLAGS) -o sfmike
|
||||
|
||||
LAUNCHOBJS = launch.o soundbyte.o usleep.o g711.o
|
||||
|
||||
@@ -303,12 +303,12 @@
|
||||
@@ -326,12 +326,12 @@
|
||||
ECHOOBJS = echo.o codecs.o g711.o rtpacket.o ulaw.o xdsub.o
|
||||
|
||||
sfecho: $(ECHOOBJS) md5lib.o
|
||||
|
@ -72,16 +77,7 @@
|
|||
|
||||
# Configure the voice on demand server for the platform's
|
||||
# location of Perl and network constant definitions.
|
||||
@@ -337,7 +337,7 @@
|
||||
# in make not necessarily available on all platforms.
|
||||
|
||||
adpcmlib.o:
|
||||
- ( echo "Building ADPCM library."; cd adpcm ; make CC="$(CC)" )
|
||||
+ ( echo "Building ADPCM library."; cd adpcm ; make CC="$(CC) $(CCFLAGS)" )
|
||||
echo "ADPCM" >adpcmlib.o
|
||||
|
||||
deslib.o:
|
||||
@@ -349,11 +349,11 @@
|
||||
@@ -376,11 +376,11 @@
|
||||
echo "BLOWFISH" >libblowfish.o
|
||||
|
||||
libdes.o:
|
||||
|
@ -95,22 +91,3 @@
|
|||
echo "LPC" >lpclib.o
|
||||
|
||||
lpc10lib.o:
|
||||
@@ -361,15 +361,15 @@
|
||||
echo "LPC" >lpc10lib.o
|
||||
|
||||
gsmlib.o:
|
||||
- ( echo "Building GSM library."; cd gsm ; make CC="$(CC)" )
|
||||
+# ( echo "Building GSM library."; cd gsm ; make CC="$(CC) $(CCFLAGS)" )
|
||||
echo "GSM" >gsmlib.o
|
||||
|
||||
md5lib.o:
|
||||
- ( echo "Building MD5 library."; cd md5 ; make CC="$(CC)" )
|
||||
+# ( echo "Building MD5 library."; cd md5 ; make CC="$(CC) $(CCFLAGS)" )
|
||||
echo "MD5" >md5lib.o
|
||||
|
||||
idealib.o:
|
||||
- ( echo "Building IDEA library."; cd idea ; make CC="$(CC)" )
|
||||
+ ( echo "Building IDEA library."; cd idea ; make CC="$(CC) $(CCFLAGS)" )
|
||||
echo "IDEA" >idealib.o
|
||||
|
||||
# Object file dependencies
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- mike.c.orig Tue Sep 14 08:27:51 1999
|
||||
+++ mike.c Fri Dec 31 15:29:10 1999
|
||||
@@ -132,8 +132,8 @@
|
||||
--- mike.c.orig Mon Aug 19 17:20:52 2002
|
||||
+++ mike.c Thu Dec 12 02:46:38 2002
|
||||
@@ -130,8 +130,8 @@
|
||||
#endif /* UNIX420 */
|
||||
|
||||
#ifdef UNIX5
|
||||
|
@ -11,7 +11,7 @@
|
|||
#endif /* UNIX5 */
|
||||
|
||||
/* Set raw mode on terminal file. Basically, get the terminal into a
|
||||
@@ -152,16 +152,16 @@
|
||||
@@ -150,16 +150,16 @@
|
||||
#endif /* UNIX420 */
|
||||
|
||||
#ifdef UNIX5
|
||||
|
@ -31,7 +31,7 @@
|
|||
#endif /* UNIX5 */
|
||||
/*printf("\n(raw)\n");*/
|
||||
}
|
||||
@@ -180,7 +180,7 @@
|
||||
@@ -178,7 +178,7 @@
|
||||
#endif /* UNIX420 */
|
||||
|
||||
#ifdef UNIX5
|
||||
|
@ -40,15 +40,15 @@
|
|||
#endif /* UNIX5 */
|
||||
/*printf("\n(cooked)\n");*/
|
||||
}
|
||||
@@ -1144,7 +1144,7 @@
|
||||
@@ -1135,7 +1135,7 @@
|
||||
/* SENDFILE -- Send a file or, if the file name is NULL or a
|
||||
single period, send real-time sound input. */
|
||||
|
||||
-static int sendfile(f)
|
||||
+static int sfsendfile(f)
|
||||
char *f;
|
||||
-static int sendfile(char *f)
|
||||
+static int sfsendfile(char *f)
|
||||
{
|
||||
soundbuf netbuf;
|
||||
#define buf netbuf.buffer.buffer_val
|
||||
@@ -2306,7 +2306,7 @@
|
||||
return 1;
|
||||
}
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- adpcm/Makefile.orig Fri Dec 31 15:34:54 1999
|
||||
+++ adpcm/Makefile Fri Dec 31 15:35:09 1999
|
||||
@@ -1,7 +1,7 @@
|
||||
#
|
||||
--- adpcm/Makefile.orig Sat Oct 13 15:00:05 2001
|
||||
+++ adpcm/Makefile Thu Dec 12 02:47:59 2002
|
||||
@@ -2,7 +2,7 @@
|
||||
# Makefile for adpcm and test programs
|
||||
# -------------------
|
||||
-CFLAGS=-O -I..
|
||||
+CFLAGS+= -I..
|
||||
# May need this on a sun:
|
||||
#CFLAGS=-O -I/usr/demo/SOUND
|
||||
|
||||
-CFLAGS = -I..
|
||||
+CFLAGS += -I..
|
||||
|
||||
all: adpcm-u.o
|
||||
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- idea/Makefile.orig Wed Jan 5 20:20:55 2000
|
||||
+++ idea/Makefile Wed Jan 5 20:21:08 2000
|
||||
@@ -7,7 +7,7 @@
|
||||
# Compiler flags
|
||||
|
||||
CC = cc
|
||||
-CFLAGS = -O
|
||||
+CFLAGS = $(OPTFLAGS)
|
||||
|
||||
all: idea.a
|
||||
|
|
@ -6,9 +6,9 @@
|
|||
#
|
||||
|
||||
PORTNAME= speak_freely
|
||||
PORTVERSION= 7.1
|
||||
PORTVERSION= 7.5
|
||||
CATEGORIES= mbone audio security
|
||||
MASTER_SITES= http://www.fourmilab.ch/speakfree/unix/
|
||||
MASTER_SITES= http://www.fourmilab.ch/speakfree/unix/download/${PORTVERSION}/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (speak_freely-7.1.tar.gz) = f06e4115c7139f7e30ea57064b324558
|
||||
MD5 (speak_freely-7.5.tar.gz) = fd315f8fd9996b7f34e83d8249ecd89f
|
||||
|
|
|
@ -1,28 +1,33 @@
|
|||
--- Makefile.orig Sat Sep 18 18:29:44 1999
|
||||
+++ Makefile Wed Jan 5 20:23:52 2000
|
||||
@@ -3,7 +3,7 @@
|
||||
|
||||
# Debugging options
|
||||
|
||||
-DEBUG = -g -DHEXDUMP
|
||||
+#DEBUG = -g -DHEXDUMP
|
||||
#DEBUG = -g -DHEXDUMP -DNOCRYPTO
|
||||
--- Makefile.orig Fri Oct 19 07:01:35 2001
|
||||
+++ Makefile Thu Dec 12 02:44:56 2002
|
||||
@@ -6,7 +6,7 @@
|
||||
#DEBUG = -O
|
||||
#DEBUG = -g -DHEXDUMP
|
||||
#DEBUG = -g -DHEXDUMP -DNOCRYPTO
|
||||
-DEBUG = -O3 -DHEXDUMP
|
||||
+#DEBUG = -O3 -DHEXDUMP
|
||||
|
||||
@@ -38,9 +38,9 @@
|
||||
# functionality is working. Please see the detailed description
|
||||
# Installation
|
||||
|
||||
@@ -43,13 +43,13 @@
|
||||
# of the available flags which follows these declarations.
|
||||
#
|
||||
-CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN
|
||||
-CC = gcc -O3 # for GNU's gcc compiler
|
||||
#CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN
|
||||
-CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN -DNEEDED_LINEAR -DLINUX_DSP_SMALL_BUFFER
|
||||
-CC = gcc -Wall # for GNU's gcc compiler
|
||||
+#CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN -DNEEDED_LINEAR -DLINUX_DSP_SMALL_BUFFER
|
||||
+#CC = gcc -Wall # for GNU's gcc compiler
|
||||
# CELPFLAGS below are tweaked for GCC 2.96 on Intel Pentium
|
||||
# Comment out if you are using a compiler which doesn't
|
||||
# understand these options.
|
||||
-CELPFLAGS = -fomit-frame-pointer -ffast-math -funroll-loops
|
||||
-LFLAGS = -lncurses -lm
|
||||
+#CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN
|
||||
+#CC = gcc -O3 # for GNU's gcc compiler
|
||||
+#CELPFLAGS = -fomit-frame-pointer -ffast-math -funroll-loops
|
||||
+#LFLAGS = -lncurses -lm
|
||||
#
|
||||
# If the above LFLAGS doesn't work, try the one below.
|
||||
#LFLAGS = -lcurses -lm
|
||||
@@ -220,8 +220,8 @@
|
||||
@@ -237,8 +237,8 @@
|
||||
# Depending on how your driver handles non-blocking I/O,
|
||||
# you may also have to add -DAUDIO_BLOCKING to the
|
||||
# CCFLAGS line.
|
||||
|
@ -33,31 +38,31 @@
|
|||
|
||||
# Hewlett-Packard
|
||||
# (courtesy of Marc Kilian)
|
||||
@@ -269,7 +269,7 @@
|
||||
@@ -286,7 +286,7 @@
|
||||
|
||||
# Compiler flags
|
||||
|
||||
-CFLAGS = $(DEBUG) -Iadpcm -Ilpc -Igsm/inc -Imd5 -Iidea -Ilibdes -Iblowfish $(CARGS) $(DUPLEX) $(CCFLAGS) $(DOMAIN)
|
||||
+CFLAGS = $(OPTFLAGS) $(DEBUG) -Iadpcm -Ilpc -I$(LOCALBASE)/include -Iidea -Ilibdes -Iblowfish $(CARGS) $(DUPLEX) $(CCFLAGS) $(DOMAIN)
|
||||
-CFLAGS = $(DEBUG) -Iadpcm -Icelp -Ilpc -Igsm/inc -Ilpc10 -Imd5 -Ides -Iidea -Ilibdes -Iblowfish $(CARGS) $(DUPLEX) $(CCFLAGS) $(DOMAIN)
|
||||
+CFLAGS = $(OPTFLAGS) $(DEBUG) -Iadpcm -Icelp -Ilpc -I$(LOCALBASE)/include -Ilpc10 -Imd5 -Ides -Iidea -Ilibdes -Iblowfish $(CARGS) $(DUPLEX) $(CCFLAGS) $(DOMAIN)
|
||||
|
||||
PROGRAMS = sfspeaker sfmike sflaunch sflwld sflwl sfecho sfreflect sfvod
|
||||
BINARIES = sfspeaker sfmike sflaunch sflwld sflwl sfecho sfreflect
|
||||
|
||||
@@ -278,12 +278,12 @@
|
||||
@@ -301,12 +301,12 @@
|
||||
SPKROBJS = speaker.o codecs.o deskey.o g711.o rate.o rtpacket.o soundbyte.o ulaw.o usleep.o vatpkt.o vox.o audio_hp.o audio_sgi.o common.o
|
||||
|
||||
sfspeaker: $(SPKROBJS) adpcmlib.o libblowfish.o lpclib.o lpc10lib.o gsmlib.o deslib.o md5lib.o idealib.o libdes.o xdsub.o
|
||||
- $(CC) $(SPKROBJS) adpcm/adpcm-u.o blowfish/libblowfish.a des/des.a md5/md5.o idea/idea.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o xdsub.o libdes/libdes.a $(LFLAGS) -o sfspeaker
|
||||
+ $(CC) $(SPKROBJS) adpcm/adpcm-u.o blowfish/libblowfish.a des/des.a -lmd idea/idea.a lpc10/liblpc10.a -L/usr/local/lib -lgsm lpc/lpc.o xdsub.o libdes/libdes.a $(LFLAGS) -o sfspeaker
|
||||
sfspeaker: $(SPKROBJS) adpcmlib.o celplib.o libblowfish.o lpclib.o lpc10lib.o gsmlib.o deslib.o md5lib.o idealib.o libdes.o xdsub.o
|
||||
- $(CC) $(SPKROBJS) adpcm/adpcm-u.o blowfish/libblowfish.a celp/celp.o des/des.a md5/md5.o idea/idea.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o xdsub.o libdes/libdes.a $(LFLAGS) -o sfspeaker
|
||||
+ $(CC) $(SPKROBJS) adpcm/adpcm-u.o blowfish/libblowfish.a celp/celp.o des/des.a -lmd idea/idea.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o xdsub.o libdes/libdes.a $(LFLAGS) -o sfspeaker
|
||||
|
||||
MIKEOBJS = mike.o codecs.o deskey.o g711.o rate.o rtpacket.o soundbyte.o ulaw.o usleep.o vatpkt.o xdsub.o audio_hp.o audio_sgi.o
|
||||
|
||||
sfmike: $(MIKEOBJS) adpcmlib.o libblowfish.o lpclib.o lpc10lib.o gsmlib.o deslib.o md5lib.o idealib.o libdes.o
|
||||
- $(CC) $(MIKEOBJS) adpcm/adpcm-u.o des/des.a md5/md5.o idea/idea.a -lm blowfish/libblowfish.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o libdes/libdes.a $(LFLAGS) -o sfmike
|
||||
+ $(CC) $(MIKEOBJS) adpcm/adpcm-u.o des/des.a -lmd idea/idea.a -lm blowfish/libblowfish.a lpc10/liblpc10.a -L/usr/local/lib -lgsm lpc/lpc.o libdes/libdes.a $(LFLAGS) -o sfmike
|
||||
sfmike: $(MIKEOBJS) adpcmlib.o celplib.o libblowfish.o lpclib.o lpc10lib.o gsmlib.o deslib.o md5lib.o idealib.o libdes.o
|
||||
- $(CC) $(MIKEOBJS) adpcm/adpcm-u.o celp/celp.o des/des.a md5/md5.o idea/idea.a -lm blowfish/libblowfish.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o libdes/libdes.a $(LFLAGS) -o sfmike
|
||||
+ $(CC) $(MIKEOBJS) adpcm/adpcm-u.o celp/celp.o des/des.a -lmd idea/idea.a -lm blowfish/libblowfish.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o libdes/libdes.a $(LFLAGS) -o sfmike
|
||||
|
||||
LAUNCHOBJS = launch.o soundbyte.o usleep.o g711.o
|
||||
|
||||
@@ -303,12 +303,12 @@
|
||||
@@ -326,12 +326,12 @@
|
||||
ECHOOBJS = echo.o codecs.o g711.o rtpacket.o ulaw.o xdsub.o
|
||||
|
||||
sfecho: $(ECHOOBJS) md5lib.o
|
||||
|
@ -72,16 +77,7 @@
|
|||
|
||||
# Configure the voice on demand server for the platform's
|
||||
# location of Perl and network constant definitions.
|
||||
@@ -337,7 +337,7 @@
|
||||
# in make not necessarily available on all platforms.
|
||||
|
||||
adpcmlib.o:
|
||||
- ( echo "Building ADPCM library."; cd adpcm ; make CC="$(CC)" )
|
||||
+ ( echo "Building ADPCM library."; cd adpcm ; make CC="$(CC) $(CCFLAGS)" )
|
||||
echo "ADPCM" >adpcmlib.o
|
||||
|
||||
deslib.o:
|
||||
@@ -349,11 +349,11 @@
|
||||
@@ -376,11 +376,11 @@
|
||||
echo "BLOWFISH" >libblowfish.o
|
||||
|
||||
libdes.o:
|
||||
|
@ -95,22 +91,3 @@
|
|||
echo "LPC" >lpclib.o
|
||||
|
||||
lpc10lib.o:
|
||||
@@ -361,15 +361,15 @@
|
||||
echo "LPC" >lpc10lib.o
|
||||
|
||||
gsmlib.o:
|
||||
- ( echo "Building GSM library."; cd gsm ; make CC="$(CC)" )
|
||||
+# ( echo "Building GSM library."; cd gsm ; make CC="$(CC) $(CCFLAGS)" )
|
||||
echo "GSM" >gsmlib.o
|
||||
|
||||
md5lib.o:
|
||||
- ( echo "Building MD5 library."; cd md5 ; make CC="$(CC)" )
|
||||
+# ( echo "Building MD5 library."; cd md5 ; make CC="$(CC) $(CCFLAGS)" )
|
||||
echo "MD5" >md5lib.o
|
||||
|
||||
idealib.o:
|
||||
- ( echo "Building IDEA library."; cd idea ; make CC="$(CC)" )
|
||||
+ ( echo "Building IDEA library."; cd idea ; make CC="$(CC) $(CCFLAGS)" )
|
||||
echo "IDEA" >idealib.o
|
||||
|
||||
# Object file dependencies
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- mike.c.orig Tue Sep 14 08:27:51 1999
|
||||
+++ mike.c Fri Dec 31 15:29:10 1999
|
||||
@@ -132,8 +132,8 @@
|
||||
--- mike.c.orig Mon Aug 19 17:20:52 2002
|
||||
+++ mike.c Thu Dec 12 02:46:38 2002
|
||||
@@ -130,8 +130,8 @@
|
||||
#endif /* UNIX420 */
|
||||
|
||||
#ifdef UNIX5
|
||||
|
@ -11,7 +11,7 @@
|
|||
#endif /* UNIX5 */
|
||||
|
||||
/* Set raw mode on terminal file. Basically, get the terminal into a
|
||||
@@ -152,16 +152,16 @@
|
||||
@@ -150,16 +150,16 @@
|
||||
#endif /* UNIX420 */
|
||||
|
||||
#ifdef UNIX5
|
||||
|
@ -31,7 +31,7 @@
|
|||
#endif /* UNIX5 */
|
||||
/*printf("\n(raw)\n");*/
|
||||
}
|
||||
@@ -180,7 +180,7 @@
|
||||
@@ -178,7 +178,7 @@
|
||||
#endif /* UNIX420 */
|
||||
|
||||
#ifdef UNIX5
|
||||
|
@ -40,15 +40,15 @@
|
|||
#endif /* UNIX5 */
|
||||
/*printf("\n(cooked)\n");*/
|
||||
}
|
||||
@@ -1144,7 +1144,7 @@
|
||||
@@ -1135,7 +1135,7 @@
|
||||
/* SENDFILE -- Send a file or, if the file name is NULL or a
|
||||
single period, send real-time sound input. */
|
||||
|
||||
-static int sendfile(f)
|
||||
+static int sfsendfile(f)
|
||||
char *f;
|
||||
-static int sendfile(char *f)
|
||||
+static int sfsendfile(char *f)
|
||||
{
|
||||
soundbuf netbuf;
|
||||
#define buf netbuf.buffer.buffer_val
|
||||
@@ -2306,7 +2306,7 @@
|
||||
return 1;
|
||||
}
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- adpcm/Makefile.orig Fri Dec 31 15:34:54 1999
|
||||
+++ adpcm/Makefile Fri Dec 31 15:35:09 1999
|
||||
@@ -1,7 +1,7 @@
|
||||
#
|
||||
--- adpcm/Makefile.orig Sat Oct 13 15:00:05 2001
|
||||
+++ adpcm/Makefile Thu Dec 12 02:47:59 2002
|
||||
@@ -2,7 +2,7 @@
|
||||
# Makefile for adpcm and test programs
|
||||
# -------------------
|
||||
-CFLAGS=-O -I..
|
||||
+CFLAGS+= -I..
|
||||
# May need this on a sun:
|
||||
#CFLAGS=-O -I/usr/demo/SOUND
|
||||
|
||||
-CFLAGS = -I..
|
||||
+CFLAGS += -I..
|
||||
|
||||
all: adpcm-u.o
|
||||
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- idea/Makefile.orig Wed Jan 5 20:20:55 2000
|
||||
+++ idea/Makefile Wed Jan 5 20:21:08 2000
|
||||
@@ -7,7 +7,7 @@
|
||||
# Compiler flags
|
||||
|
||||
CC = cc
|
||||
-CFLAGS = -O
|
||||
+CFLAGS = $(OPTFLAGS)
|
||||
|
||||
all: idea.a
|
||||
|
Loading…
Reference in a new issue