- Bump PORTREVISION.
- Take maintainership. - Remove USE_XLIB (it only requires SDL). - Build 2 binaries, one for the full game and other for the shareware version. - Expand pkg-descr and pkg-message to reflect the previous change. - Replace -O2 and higher in CFLAGS by -O1 (crashes otherwise). - Convert a line-specific REINPLACE_CMD into a patch.
This commit is contained in:
parent
30709a3f59
commit
9f96b49b63
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=205026
7 changed files with 52 additions and 26 deletions
|
@ -7,35 +7,37 @@
|
|||
|
||||
PORTNAME= rottdc
|
||||
DISTVERSION= 1.0-2
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= sdl-dc
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= alepulver@FreeBSD.org
|
||||
COMMENT= Apogee's Rise Of The Triad source port
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_SDL= sdl mixer
|
||||
USE_XLIB= yes
|
||||
PATCH_WRKSRC= ${WRKSRC}/rott
|
||||
# Crashes when compiling with -O2 or greater, so downgrade to -O1.
|
||||
CFLAGS:= ${CFLAGS:C/-O[2-9]/-O1/}
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/rott
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '433s,^static ,,' ${WRKSRC}/rt_actor.c
|
||||
post-extract:
|
||||
@${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/rott ${PREFIX}/bin
|
||||
.for f in rott rott-sw
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${f}/rott ${PREFIX}/bin/${f}
|
||||
.endfor
|
||||
.ifndef (NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
.for i in cheats cmdline
|
||||
${INSTALL_DATA} ${WRKSRC}/${i}.txt ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/rott/${i}.txt ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
13
games/rottdc/files/Makefile
Normal file
13
games/rottdc/files/Makefile
Normal file
|
@ -0,0 +1,13 @@
|
|||
# Makefile wrapper for building both full and shareware versions.
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
all: rott rott-sw
|
||||
$(MAKE) -C rott
|
||||
$(MAKE) -C rott-sw
|
||||
|
||||
rott-sw:
|
||||
cp -r rott rott-sw
|
||||
sed -i '' -Ee 's|(SHAREWARE) *0|\1 1|' rott-sw/develop.h
|
||||
sed -i '' -Ee 's|(SUPERROTT) *1|\1 1|' rott/develop.h
|
|
@ -1,11 +0,0 @@
|
|||
--- develop.h.orig Wed Feb 18 09:00:17 2004
|
||||
+++ develop.h Wed Feb 18 09:01:08 2004
|
||||
@@ -41,7 +41,7 @@
|
||||
|
||||
// Make sure only one of the following are on at one time
|
||||
#define SHAREWARE 0
|
||||
-#define SUPERROTT 0
|
||||
+#define SUPERROTT 1
|
||||
#define SITELICENSE 0
|
||||
|
||||
// cute little dopefish thing, only works with special patch?
|
11
games/rottdc/files/patch-rt__actor.c
Normal file
11
games/rottdc/files/patch-rt__actor.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- rt_actor.c.bak Tue Jan 7 03:31:51 2003
|
||||
+++ rt_actor.c Fri Jan 4 19:07:08 2008
|
||||
@@ -430,7 +430,7 @@
|
||||
void AvoidPlayerMissile(objtype*ob);
|
||||
int EnvironmentDamage(objtype *ob);
|
||||
|
||||
-static int STOPSPEED = 0x200;
|
||||
+int STOPSPEED = 0x200;
|
||||
static int PLAYERFRICTION = 0xe000;
|
||||
static int ACTORFRICTION = 0xf000;
|
||||
static int DIAGADJUST = 0xb504;
|
|
@ -1,6 +1,8 @@
|
|||
This is a port of Apogee's 3D action title Rise of the Triad, originally
|
||||
released in 1994. This port duplicates the functionality of the original
|
||||
game on modern operating systems, including Linux, Win32, OSX and now FreeBSD.
|
||||
In order to run game you'll need original game data.
|
||||
|
||||
In order to run game you'll need either the original game data or a shareware
|
||||
version (see pkg-message).
|
||||
|
||||
WWW: http://sdl-dc.sourceforge.net/
|
||||
|
|
|
@ -1,3 +1,11 @@
|
|||
******************************************************************
|
||||
* Note: Run 'rott' from directory, containing original game data *
|
||||
******************************************************************
|
||||
==============================================================================
|
||||
|
||||
Rise of the Triad DC has been installed.
|
||||
|
||||
There are two binaries: "rott" and "rott-sw", to play the full and shareware
|
||||
versions respectively. The game data must reside in the current directory.
|
||||
|
||||
The shareware game data is available here:
|
||||
http://filesingularity.timedoctor.org/swdata.zip
|
||||
|
||||
==============================================================================
|
||||
|
|
|
@ -1,4 +1,5 @@
|
|||
bin/rott
|
||||
bin/rott-sw
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cheats.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cmdline.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
|
|
Loading…
Reference in a new issue