Import of xmp.

Xmp is the "eXtended Module Player".  It supports many of the
Amiga and PC module formats -- currently 47 of them and runs with
little system load.

PR:		13805
Submitted by:	Anders Nordby <anders@fix.no>
This commit is contained in:
Chris Piazza 1999-09-18 20:46:21 +00:00
parent ae8e0c1678
commit 9fa8d14cc8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=21725
8 changed files with 108 additions and 0 deletions

28
audio/xmp/Makefile Normal file
View file

@ -0,0 +1,28 @@
# New ports collection makefile for: xmp
# Version required: xmp-2.0.0-pre
# Date created: 18 September 1999
# Whom: Anders Nordby <anders@fix.no>
#
# $FreeBSD$
#
DISTNAME= xmp-2.0.0-pre
PKGNAME= xmp-2.0.0
CATEGORIES= audio
MASTER_SITES= http://xmp.helllabs.org/pkg/2.0.0/ \
http://xmp.linuxbox.com/pkg/2.0.0/
MAINTAINER= anders@fix.no
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-alsa
USE_XLIB= yes
USE_GMAKE= yes
USE_BZIP2= yes
CFLAGS+= -DHAVE_SYS_RTPRIO_H
MAN1= xmp.1 xxmp.1
.include <bsd.port.mk>

1
audio/xmp/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (xmp-2.0.0-pre.tar.bz2) = df88e2802bbbea98f26e38524c84bd87

20
audio/xmp/files/patch-aa Normal file
View file

@ -0,0 +1,20 @@
--- src/player/readrc.c.orig Sat Jul 3 17:13:04 1999
+++ src/player/readrc.c Sat Sep 18 13:11:48 1999
@@ -49,7 +49,7 @@
if ((rc = fopen (myrc2, "r")) == NULL) {
if ((rc = fopen (myrc, "r")) == NULL) {
- if ((rc = fopen ("/etc/xmp.conf", "r")) == NULL) {
+ if ((rc = fopen ("/usr/local/etc/xmp.conf", "r")) == NULL) {
free (myrc);
return -1;
}
@@ -191,7 +191,7 @@
myrc = malloc ((home ? strlen (home) : 0) + 20);
sprintf (myrc, "%s/.xmp/modules.conf", home);
- parse_modconf (ctl, "/etc/xmp-modules.conf", crc, size);
+ parse_modconf (ctl, "/usr/local/etc/xmp-modules.conf", crc, size);
parse_modconf (ctl, myrc, crc, size);
free (myrc);
}

19
audio/xmp/files/patch-ab Normal file
View file

@ -0,0 +1,19 @@
*** etc/Makefile.orig Sat Sep 18 14:29:28 1999
--- etc/Makefile Sat Sep 18 14:29:39 1999
***************
*** 21,27 ****
@if [ -f /etc/xmp-modules.conf]; then \
mv -f /etc/xmp-modules.conf /etc/xmp-modules.conf.old; \
fi
! $(INSTALL) -m644 xmp.conf xmp-modules.conf /etc
xmp.spec: xmp.spec.in ../Makefile.rules
cat $@.in | sed 's/@VERSION@/$(VERSION)/g' > $@
--- 21,27 ----
@if [ -f /etc/xmp-modules.conf]; then \
mv -f /etc/xmp-modules.conf /etc/xmp-modules.conf.old; \
fi
! $(INSTALL) -m644 xmp.conf xmp-modules.conf $(PREFIX)/etc
xmp.spec: xmp.spec.in ../Makefile.rules
cat $@.in | sed 's/@VERSION@/$(VERSION)/g' > $@

21
audio/xmp/files/patch-ac Normal file
View file

@ -0,0 +1,21 @@
*** Makefile.orig Sat Sep 18 15:34:54 1999
--- Makefile Sat Sep 18 15:35:29 1999
***************
*** 39,46 ****
install::
@echo
! @echo " Installation complete. To customize, copy /etc/xmp.conf to"
! @echo " \$$HOME/.xmp/xmp.conf and /etc/xmp-modules.conf to \$$HOME/.xmp/modules.conf"
@echo
uninstall:
--- 39,46 ----
install::
@echo
! @echo " Installation complete. To customize, copy ${PREFIX}/etc/xmp.conf to"
! @echo " \$$HOME/.xmp/xmp.conf and ${PREFIX}/etc/xmp-modules.conf to \$$HOME/.xmp/modules.conf"
@echo
uninstall:

1
audio/xmp/pkg-comment Normal file
View file

@ -0,0 +1 @@
A player for many different Amiga and PC module formats

14
audio/xmp/pkg-descr Normal file
View file

@ -0,0 +1,14 @@
This is the Extended Module Player, an open source module player for UNIX
distributed under the terms of the GNU GPL. xmp currently runs on several
platforms, including ALSA, OSS (for Linux on i386 and Alpha and FreeBSD),
BSD, SunOS, Solaris, S/Linux and HP-UX. On PC class machines with GUS or
AWE cards xmp takes advantage of the OSS sequencer to play modules with
virtually no system load. Using software mixing, xmp plays at rates up to
48 kHz in mono or stereo, 8 or 16 bits, signed or unsigned, little or big
endian samples with 32 bit linear interpolation.
The current version of xmp supports many Amiga and PC module formats
(including packed, Powerpacked and SQSHed modules) -- currently 47 known
formats.
WWW: http://xmp.helllabs.org

4
audio/xmp/pkg-plist Normal file
View file

@ -0,0 +1,4 @@
bin/xmp
bin/xxmp
etc/xmp.conf
etc/xmp-modules.conf