- First import since repocopy from libdixdecore:
1) Enable port in CATEGORY Makefile 2) Add port into CVSROOT/modules 3) This a port of the developer version of libdivxdecore 4) Fix typo: port created on year 2001, not 20001. 5) Update port to developer Version 4.0 alpha48 2001-02-22. PORTVERSION=0.4.0.48 6) This port downloads a source only CVS tag developer version. Therefore, it comes without the tools necessary to build it (makefile, configure, ...) 7) Inherit (copy) from the non-developer version distfile the structure necessary to build it. Patch it to suit this port specific needs. More specifically, add new source code files to makefile(s): yuv2rgb.c (Changelog #13). 8) Since it is a developer version of another port, it can use some of its structure such as DESCR, PLIST. Therefore local copies are not necessary. - Library changes in new version: o Changelog: 1) Added VO and VOL header in the MPEG-4 bitstream to encore 2) Added YUV input in encore 3) Provided a sample test code for encore 4) Rewrote the bitstream handling in the encore 5) Some cleanup and minor optimize in the modules in encore 6) Fade/Cross Fade Improved 7) Added VO and VOL header parser in decore 8) Added various functions to support the YUV output formats 9) Splitted the YUV to RGB 16 bit conversion routine in 2 different routines (555 and 565 16 bit color mode) in decore 10) Modified the interface to take care of the new characteristics (more output format supported, possibility to change the output format at run-time). These changes are backward compatible (previous API call are still valid) 11) Modified the parser to be able to decode the stream with/without the VOL at the same time 12) Removed all the boring warnings until Level 3 of Visual C++ 13) ANSI C Implementation of the yuv2rgb.c added (2001-01-23, 00:00:00 GMT) o Bugs Corrected: 1) Some bug has been fixed in the post processing algorithm (chrominance deblocking and vertical deblocking) 2) Bug fixed in YUV to RGB 16 bit conversion routine
This commit is contained in:
parent
cce76a6de3
commit
9fd9f89fb0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=39793
13 changed files with 83 additions and 50 deletions
|
@ -104,6 +104,7 @@
|
|||
SUBDIR += lfview
|
||||
SUBDIR += lib3ds
|
||||
SUBDIR += libdivxdecore
|
||||
SUBDIR += libdivxdecore-devel
|
||||
SUBDIR += libdjvu++
|
||||
SUBDIR += libflash
|
||||
SUBDIR += libfpx
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# New ports collection makefile for: libdivxdecore
|
||||
# New ports collection makefile for: libdivxdecore developer version
|
||||
# Date created: 03 Feb 20001
|
||||
# Whom: Mario S F Ferreira <lioux@FreeBSD.org>
|
||||
#
|
||||
|
@ -6,12 +6,20 @@
|
|||
#
|
||||
|
||||
PORTNAME= libdivxdecore
|
||||
PORTVERSION= 0.4.7
|
||||
PORTVERSION= 0.4.0.48
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://download.projectmayo.com/dnload/divx4linux/xmps/
|
||||
MASTER_SITES= http://download.projectmayo.com/dnload/divxcore/
|
||||
PKGNAMESUFFIX= -devel
|
||||
DISTNAME= decore48src
|
||||
|
||||
MAINTAINER= lioux@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= ${NONEXISTENT}:${LIBDIVXDECORE_PORT}:patch
|
||||
|
||||
WRKSRC= ${WRKDIR}/${LIBDIVXDECORE_PORT_WRKSRC:C/.+\///}
|
||||
|
||||
USE_ZIP= yes
|
||||
EXTRACT_BEFORE_ARGS= -a
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL= yes
|
||||
|
@ -20,7 +28,24 @@ PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
|
|||
|
||||
LIB_VERSION= 0
|
||||
|
||||
post-extract:
|
||||
@${CP} -Rp ${LIBDIVXDECORE_PORT_WRKSRC} ${WRKDIR}
|
||||
@${MV} ${WRKSRC}/src ${WRKSRC}/src.old
|
||||
@${MV} ${WRKDIR}/decore/src ${WRKSRC}/src
|
||||
@${CP} ${WRKSRC}/src.old/Makefile.* ${WRKSRC}/src
|
||||
|
||||
post-install:
|
||||
@${LN} -sf ${PORTNAME}.so ${PREFIX}/lib/${PORTNAME}.so.${LIB_VERSION}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
#LIBDIVXDECORE_PORT= ${PORTSDIR}/graphics/libdivxdecore
|
||||
LIBDIVXDECORE_PORT= ${.CURDIR}/../libdivxdecore
|
||||
LIBDIVXDECORE_PORT_WRKSRC!= cd ${LIBDIVXDECORE_PORT} && ${MAKE} -V WRKSRC
|
||||
|
||||
# We will inherit most of the comment files from the non-devel
|
||||
# version
|
||||
PLIST= ${LIBDIVXDECORE_PORT}/pkg-plist
|
||||
DESCR= ${LIBDIVXDECORE_PORT}/pkg-descr
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (libdivxdecore-0.4.7.tar.gz) = 0defab7d519308aacfb1a0c1448341a1
|
||||
MD5 (decore48src.zip) = fa9b964823c5e14a0907c62a2d791ef7
|
||||
|
|
10
graphics/libdivxdecore-devel/files/patch-src::Makefile.am
Normal file
10
graphics/libdivxdecore-devel/files/patch-src::Makefile.am
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/Makefile.am.orig Fri Mar 9 23:38:01 2001
|
||||
+++ src/Makefile.am Fri Mar 9 23:38:08 2001
|
||||
@@ -30,6 +30,7 @@
|
||||
postprocess.h \
|
||||
transferIDCT.c \
|
||||
transferIDCT.h \
|
||||
+yuv2rgb.c \
|
||||
yuv2rgb.h
|
||||
|
||||
libdivxdecoreincludedir = $(includedir)/divx
|
|
@ -1 +1 @@
|
|||
OpenDivX decoding engine from Project Mayo
|
||||
OpenDivX decoding engine from Project Mayo (development version)
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
Decore [excerpt from OpenDivX Project Mayo site]
|
||||
|
||||
"Decore" is our decoder core - that part of the codec that decodes
|
||||
video from DivX video bitstream into uncompressed RGB bitmaps. Its
|
||||
API is defined in decore.h. The API is another frame-in, frame-out
|
||||
scheme, you give it a chunk of OpenDivX bitstream and it comes back
|
||||
to you with an uncompressed RGB frame. Like "encore", "decore" is
|
||||
truly independent of any other code, making no system calls.
|
||||
|
||||
"Decore" is a decoder compliant with MPEG-4 natural video, simple
|
||||
profile. It also incorporates a video postprocessor which postprocessor,
|
||||
which hides many of the artifacts inherent in low bit-rate video.
|
||||
|
||||
|
||||
WWW: http://www.projectmayo.com/linux/divx4linux/
|
|
@ -1,4 +0,0 @@
|
|||
include/divx/decore.h
|
||||
lib/libdivxdecore.so
|
||||
lib/libdivxdecore.so.%%LIB_VERSION%%
|
||||
@dirrm include/divx
|
|
@ -1,4 +1,4 @@
|
|||
# New ports collection makefile for: libdivxdecore
|
||||
# New ports collection makefile for: libdivxdecore developer version
|
||||
# Date created: 03 Feb 20001
|
||||
# Whom: Mario S F Ferreira <lioux@FreeBSD.org>
|
||||
#
|
||||
|
@ -6,12 +6,20 @@
|
|||
#
|
||||
|
||||
PORTNAME= libdivxdecore
|
||||
PORTVERSION= 0.4.7
|
||||
PORTVERSION= 0.4.0.48
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://download.projectmayo.com/dnload/divx4linux/xmps/
|
||||
MASTER_SITES= http://download.projectmayo.com/dnload/divxcore/
|
||||
PKGNAMESUFFIX= -devel
|
||||
DISTNAME= decore48src
|
||||
|
||||
MAINTAINER= lioux@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= ${NONEXISTENT}:${LIBDIVXDECORE_PORT}:patch
|
||||
|
||||
WRKSRC= ${WRKDIR}/${LIBDIVXDECORE_PORT_WRKSRC:C/.+\///}
|
||||
|
||||
USE_ZIP= yes
|
||||
EXTRACT_BEFORE_ARGS= -a
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL= yes
|
||||
|
@ -20,7 +28,24 @@ PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
|
|||
|
||||
LIB_VERSION= 0
|
||||
|
||||
post-extract:
|
||||
@${CP} -Rp ${LIBDIVXDECORE_PORT_WRKSRC} ${WRKDIR}
|
||||
@${MV} ${WRKSRC}/src ${WRKSRC}/src.old
|
||||
@${MV} ${WRKDIR}/decore/src ${WRKSRC}/src
|
||||
@${CP} ${WRKSRC}/src.old/Makefile.* ${WRKSRC}/src
|
||||
|
||||
post-install:
|
||||
@${LN} -sf ${PORTNAME}.so ${PREFIX}/lib/${PORTNAME}.so.${LIB_VERSION}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
#LIBDIVXDECORE_PORT= ${PORTSDIR}/graphics/libdivxdecore
|
||||
LIBDIVXDECORE_PORT= ${.CURDIR}/../libdivxdecore
|
||||
LIBDIVXDECORE_PORT_WRKSRC!= cd ${LIBDIVXDECORE_PORT} && ${MAKE} -V WRKSRC
|
||||
|
||||
# We will inherit most of the comment files from the non-devel
|
||||
# version
|
||||
PLIST= ${LIBDIVXDECORE_PORT}/pkg-plist
|
||||
DESCR= ${LIBDIVXDECORE_PORT}/pkg-descr
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (libdivxdecore-0.4.7.tar.gz) = 0defab7d519308aacfb1a0c1448341a1
|
||||
MD5 (decore48src.zip) = fa9b964823c5e14a0907c62a2d791ef7
|
||||
|
|
10
multimedia/libdivxdecore-devel/files/patch-src::Makefile.am
Normal file
10
multimedia/libdivxdecore-devel/files/patch-src::Makefile.am
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/Makefile.am.orig Fri Mar 9 23:38:01 2001
|
||||
+++ src/Makefile.am Fri Mar 9 23:38:08 2001
|
||||
@@ -30,6 +30,7 @@
|
||||
postprocess.h \
|
||||
transferIDCT.c \
|
||||
transferIDCT.h \
|
||||
+yuv2rgb.c \
|
||||
yuv2rgb.h
|
||||
|
||||
libdivxdecoreincludedir = $(includedir)/divx
|
|
@ -1 +1 @@
|
|||
OpenDivX decoding engine from Project Mayo
|
||||
OpenDivX decoding engine from Project Mayo (development version)
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
Decore [excerpt from OpenDivX Project Mayo site]
|
||||
|
||||
"Decore" is our decoder core - that part of the codec that decodes
|
||||
video from DivX video bitstream into uncompressed RGB bitmaps. Its
|
||||
API is defined in decore.h. The API is another frame-in, frame-out
|
||||
scheme, you give it a chunk of OpenDivX bitstream and it comes back
|
||||
to you with an uncompressed RGB frame. Like "encore", "decore" is
|
||||
truly independent of any other code, making no system calls.
|
||||
|
||||
"Decore" is a decoder compliant with MPEG-4 natural video, simple
|
||||
profile. It also incorporates a video postprocessor which postprocessor,
|
||||
which hides many of the artifacts inherent in low bit-rate video.
|
||||
|
||||
|
||||
WWW: http://www.projectmayo.com/linux/divx4linux/
|
|
@ -1,4 +0,0 @@
|
|||
include/divx/decore.h
|
||||
lib/libdivxdecore.so
|
||||
lib/libdivxdecore.so.%%LIB_VERSION%%
|
||||
@dirrm include/divx
|
Loading…
Reference in a new issue