Add agave 37, trueType monospaced font designed for X environments.

This commit is contained in:
Emanuel Haupt 2021-01-18 21:21:21 +00:00
parent 7e48447ca1
commit 9fe5569c59
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=561971
7 changed files with 69 additions and 0 deletions

View file

@ -5,6 +5,7 @@
SUBDIR += 3270font
SUBDIR += Hasklig
SUBDIR += agave
SUBDIR += alef
SUBDIR += alegreya
SUBDIR += alegreya-sans

29
x11-fonts/agave/Makefile Normal file
View file

@ -0,0 +1,29 @@
# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
PORTNAME= agave
PORTVERSION= 37
DISTVERSIONPREFIX= v
CATEGORIES= x11-fonts
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= TrueType monospaced font designed for X environments
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/../LICENSE
BUILD_DEPENDS= fontforge:print/fontforge \
ttfautohint:print/ttfautohint
USES= fonts
USE_GITHUB= yes
GH_ACCOUNT= blobject
NO_ARCH= yes
WRKSRC_SUBDIR= src
do-install:
${MKDIR} ${STAGEDIR}${FONTSDIR}
${INSTALL_DATA} ${WRKSRC}/*.ttf ${STAGEDIR}${FONTSDIR}
.include <bsd.port.mk>

3
x11-fonts/agave/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1610979627
SHA256 (blobject-agave-v37_GH0.tar.gz) = 12af3b8cb7d645f7aa60b8680d1eae95f409affef921aac15ff3e05906e9e9d3
SIZE (blobject-agave-v37_GH0.tar.gz) = 1651434

View file

@ -0,0 +1,5 @@
--- Makefile.orig 2021-01-18 14:49:17 UTC
+++ Makefile
@@ -0,0 +1,2 @@
+all:
+ -sh ./build

View file

@ -0,0 +1,11 @@
--- build.orig 2021-01-18 21:14:37 UTC
+++ build
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+for a in *.sfd; do
+ fontfile=$(basename $a .sfd)
+ fontforge -lang=ff -c 'Open($1); Generate($2)' ${fontfile}.sfd ${fontfile}.ttf
+ ttfautohint -v -t ${fontfile}.ttf ${fontfile}-autohinted.ttf
+ mv ${fontfile}-autohinted.ttf ${fontfile}.ttf
+done

16
x11-fonts/agave/pkg-descr Normal file
View file

@ -0,0 +1,16 @@
Agave was an attempt at making a small, monospaced, outline font that would be
geometrically regular and simple. The endeavor was motivated by a deep adoration
of old-school console bitmap fonts, of Consolas, of Pragmata Pro, as well as a
novice's curiosity for typographical design.
When it came to establishing a "simple" design scheme, the natural inclination
was to separate the glyph design concerns into that of "frame" and "trait". By
frame, we refer to the naive geometric extent of a glyph and its parts. And by
trait, we mean, for example, the "way" in which a stroke curves, or the
relationship between one part of a glyph and another.
Adhering to personal tastes, bone-deep laziness, and the quirky spirit of old
computer terminal fonts, the delineations of frame and trait amounted to two
mathematical patterns: the power of two and the golden ratio.
WWW: https://b.agaric.net/page/agave

View file

@ -0,0 +1,4 @@
%%FONTSDIR%%/agave-b.ttf
%%FONTSDIR%%/agave-i.ttf
%%FONTSDIR%%/agave-r.ttf
%%FONTSDIR%%/agave-z.ttf