Remove expired ports:

2017-02-15 www/rt40: Upstream support EoL, please migrate to rt44
2017-02-17 devel/m6811-binutils: multiple vulnerabilities, version is years behind upstream
This commit is contained in:
Rene Ladan 2017-02-18 22:07:37 +00:00
parent 6a49a8253d
commit 9ff3abfe7c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=434390
19 changed files with 2 additions and 2230 deletions

2
MOVED
View file

@ -9080,3 +9080,5 @@ devel/qmake5|devel/qt5-qmake|2017-02-18|Renamed to match other Qt ports
textproc/clucene-qt4|textproc/qt4-clucene|2017-02-18|Renamed to match other Qt ports
www/webkit-qt4|www/qt4-webkit|2017-02-18|Renamed to match other Qt ports
www/webkit-qt5|www/qt5-webkit|2017-02-18|Renamed to match other Qt ports
www/rt40|www/rt44|2017-02-18|Has expired: Upstream support EoL, please migrate to rt44
devel/m6811-binutils||2017-02-18|Has expired: multiple vulnerabilities, version is years behind upstream

View file

@ -1577,7 +1577,6 @@
SUBDIR += m17n-docs
SUBDIR += m17n-lib
SUBDIR += m4
SUBDIR += m6811-binutils
SUBDIR += magit
SUBDIR += make++
SUBDIR += makedepend

View file

@ -1,68 +0,0 @@
# Created by: jburkhol@home.com
# $FreeBSD$
PORTNAME= binutils
PORTVERSION= 2.15
CATEGORIES= devel
MASTER_SITES= GNU
PKGNAMEPREFIX= m6811-
PATCH_SITES= http://stephane.carrez.free.fr/snapshots/
PATCHFILES= ${PORTNAME}-${PORTVERSION}-m68hc1x-20040801.diffs.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= ports@FreeBSD.org
COMMENT= Binutils cross-toolchain for the 6811
FORBIDDEN= multiple vulnerabilities: CVE-2014-8503, CVE-2014-8502, CVE-2014-8501
DEPRECATED= multiple vulnerabilities, version is years behind upstream
EXPIRATION_DATE= 2017-02-17
ONLY_FOR_ARCHS= i386
USES= gmake
HAS_CONFIGURE= yes
M68_TARGET= m6811-elf
CONFIGURE_ARGS= --prefix=${PREFIX} \
--target=${M68_TARGET} \
--program-prefix=${M68_TARGET}- \
--disable-nls
INFO= ${M68_TARGET}-as \
${M68_TARGET}-bfd \
${M68_TARGET}-binutils \
${M68_TARGET}-ld \
post-patch:
# as.info -> ${M68_TARGET}-as.info
@${REINPLACE_CMD} -e 's|setfilename as.info|setfilename ${M68_TARGET}-as.info|' ${WRKSRC}/gas/doc/as.texinfo
@${REINPLACE_CMD} -e 's|(as)|(${M68_TARGET}-as)|' ${WRKSRC}/gas/doc/as.texinfo
@${REINPLACE_CMD} -e 's|@file{as}|@file{${M68_TARGET}-as}|' ${WRKSRC}/gas/doc/as.texinfo
@${REINPLACE_CMD} -e 's|as.info|${M68_TARGET}-as.info|' ${WRKSRC}/gas/doc/Makefile.in
@${REINPLACE_CMD} -e 's|as.texinfo|${M68_TARGET}-as.texinfo|' ${WRKSRC}/gas/doc/Makefile.in
@${MV} ${WRKSRC}/gas/doc/as.texinfo ${WRKSRC}/gas/doc/${M68_TARGET}-as.texinfo
# bfd.info -> ${M68_TARGET}-bfd.info
@${REINPLACE_CMD} -e 's|setfilename bfd.info|setfilename ${M68_TARGET}-bfd.info|' ${WRKSRC}/bfd/doc/bfd.texinfo
@${REINPLACE_CMD} -e 's|(bfd)|(${M68_TARGET}-bfd)|' ${WRKSRC}/bfd/doc/bfd.texinfo
@${REINPLACE_CMD} -e 's|@file{bfd}|@file{${M68_TARGET}-bfd}|' ${WRKSRC}/bfd/doc/bfd.texinfo
@${REINPLACE_CMD} -e 's|bfd.info|${M68_TARGET}-bfd.info|' ${WRKSRC}/bfd/doc/Makefile.in
@${REINPLACE_CMD} -e 's|bfd.texinfo|${M68_TARGET}-bfd.texinfo|' ${WRKSRC}/bfd/doc/Makefile.in
@${MV} ${WRKSRC}/bfd/doc/bfd.texinfo ${WRKSRC}/bfd/doc/${M68_TARGET}-bfd.texinfo
# binutils.info -> ${M68_TARGET}-binutils.info
@${REINPLACE_CMD} -e 's|setfilename binutils.info|setfilename ${M68_TARGET}-binutils.info|' ${WRKSRC}/binutils/doc/binutils.texi
@${REINPLACE_CMD} -e 's|(binutils)|(${M68_TARGET}-binutils)|' ${WRKSRC}/binutils/doc/binutils.texi
@${REINPLACE_CMD} -e 's|@file{binutils}|@file{${M68_TARGET}-binutils}|' ${WRKSRC}/binutils/doc/binutils.texi
@${REINPLACE_CMD} -e 's|binutils.info|${M68_TARGET}-binutils.info|' ${WRKSRC}/binutils/doc/Makefile.in
@${REINPLACE_CMD} -e 's|binutils.texi|${M68_TARGET}-binutils.texi|' ${WRKSRC}/binutils/doc/Makefile.in
@${MV} ${WRKSRC}/binutils/doc/binutils.texi ${WRKSRC}/binutils/doc/${M68_TARGET}-binutils.texi
# ld.info -> ${M68_TARGET}-ld.info
@${REINPLACE_CMD} -e 's|setfilename ld.info|setfilename ${M68_TARGET}-ld.info|' ${WRKSRC}/ld/ld.texinfo
@${REINPLACE_CMD} -e 's|(ld)|(${M68_TARGET}-ld)|' ${WRKSRC}/ld/ld.texinfo
@${REINPLACE_CMD} -e 's|@file{ld}|@file{${M68_TARGET}-ld}|' ${WRKSRC}/ld/ld.texinfo
@${REINPLACE_CMD} -e 's|ld.info|${M68_TARGET}-ld.info|' ${WRKSRC}/ld/Makefile.in
@${REINPLACE_CMD} -e 's|ld.texinfo|${M68_TARGET}-ld.texinfo|' ${WRKSRC}/ld/Makefile.in
@${MV} ${WRKSRC}/ld/ld.texinfo ${WRKSRC}/ld/${M68_TARGET}-ld.texinfo
.include <bsd.port.mk>

View file

@ -1,4 +0,0 @@
SHA256 (binutils-2.15.tar.gz) = 0a4be462aa8d10a85f7cfb60c85aed34d37de285799106f2015e6ae03d4d8c17
SIZE (binutils-2.15.tar.gz) = 15134701
SHA256 (binutils-2.15-m68hc1x-20040801.diffs.gz) = b1b5daca325ea8033b9f979026b35ac86856519de3a19254a8404a18f719dc58
SIZE (binutils-2.15-m68hc1x-20040801.diffs.gz) = 3748

View file

@ -1,11 +0,0 @@
--- etc/Makefile.in.orig Sat Nov 15 12:15:31 2003
+++ etc/Makefile.in Sat Nov 15 12:15:46 2003
@@ -52,7 +52,7 @@
all:
# We want install to imply install-info as per GNU standards.
-install: install-info
+install:
uninstall:

View file

@ -1,30 +0,0 @@
--- gas/as.h.orig Sun Nov 23 15:14:21 2003
+++ gas/as.h Mon Dec 18 11:25:54 2006
@@ -622,9 +622,6 @@
#include "expr.h" /* Before targ-*.h */
-/* this one starts the chain of target dependant headers */
-#include "targ-env.h"
-
#ifdef OBJ_MAYBE_ELF
#define IS_ELF (OUTPUT_FLAVOR == bfd_target_elf_flavour)
#else
@@ -639,10 +636,14 @@
#include "frags.h"
#include "hash.h"
#include "read.h"
-#include "symbols.h"
#include "tc.h"
#include "obj.h"
+
+/* this one starts the chain of target dependant headers */
+#include "targ-env.h"
+
+#include "symbols.h"
#ifdef USE_EMULATIONS
#include "emul.h"

View file

@ -1,11 +0,0 @@
--- libiberty/Makefile.in.orig Fri Jan 23 08:34:11 2004
+++ libiberty/Makefile.in Wed Jul 19 23:58:35 2006
@@ -266,7 +266,7 @@
@MAINT@ echo stamp > stamp-functions
INSTALL_DEST = @INSTALL_DEST@
-install: install_to_$(INSTALL_DEST) install-subdir
+install:
install_to_libdir: all
${mkinstalldirs} $(DESTDIR)$(libdir)$(MULTISUBDIR)

View file

@ -1,7 +0,0 @@
This is a 6811 cross toolchain for FreeBSD.
The GNU binutils contain: as, ld, ar, objcopy, objdump and many other
utilities. The format of object files is ELF-32. The GNU Binutils support
translation to other formats such as S-records, Intel HEX records, ...
WWW: http://savannah.gnu.org/projects/m68hc11/

View file

@ -1,55 +0,0 @@
bin/m6811-elf-addr2line
bin/m6811-elf-ar
bin/m6811-elf-as
bin/m6811-elf-c++filt
bin/m6811-elf-ld
bin/m6811-elf-nm
bin/m6811-elf-objcopy
bin/m6811-elf-objdump
bin/m6811-elf-ranlib
bin/m6811-elf-readelf
bin/m6811-elf-size
bin/m6811-elf-strings
bin/m6811-elf-strip
m6811-elf/bin/ar
m6811-elf/bin/as
m6811-elf/bin/ld
m6811-elf/bin/nm
m6811-elf/bin/ranlib
m6811-elf/bin/strip
m6811-elf/lib/ldscripts/m68hc11elf.x
m6811-elf/lib/ldscripts/m68hc11elf.xbn
m6811-elf/lib/ldscripts/m68hc11elf.xn
m6811-elf/lib/ldscripts/m68hc11elf.xr
m6811-elf/lib/ldscripts/m68hc11elf.xu
m6811-elf/lib/ldscripts/m68hc11elfb.x
m6811-elf/lib/ldscripts/m68hc11elfb.xbn
m6811-elf/lib/ldscripts/m68hc11elfb.xn
m6811-elf/lib/ldscripts/m68hc11elfb.xr
m6811-elf/lib/ldscripts/m68hc11elfb.xu
m6811-elf/lib/ldscripts/m68hc12elf.x
m6811-elf/lib/ldscripts/m68hc12elf.xbn
m6811-elf/lib/ldscripts/m68hc12elf.xn
m6811-elf/lib/ldscripts/m68hc12elf.xr
m6811-elf/lib/ldscripts/m68hc12elf.xu
m6811-elf/lib/ldscripts/m68hc12elfb.x
m6811-elf/lib/ldscripts/m68hc12elfb.xbn
m6811-elf/lib/ldscripts/m68hc12elfb.xn
m6811-elf/lib/ldscripts/m68hc12elfb.xr
m6811-elf/lib/ldscripts/m68hc12elfb.xu
man/man1/m6811-elf-addr2line.1.gz
man/man1/m6811-elf-ar.1.gz
man/man1/m6811-elf-as.1.gz
man/man1/m6811-elf-c++filt.1.gz
man/man1/m6811-elf-dlltool.1.gz
man/man1/m6811-elf-ld.1.gz
man/man1/m6811-elf-nlmconv.1.gz
man/man1/m6811-elf-nm.1.gz
man/man1/m6811-elf-objcopy.1.gz
man/man1/m6811-elf-objdump.1.gz
man/man1/m6811-elf-ranlib.1.gz
man/man1/m6811-elf-readelf.1.gz
man/man1/m6811-elf-size.1.gz
man/man1/m6811-elf-strings.1.gz
man/man1/m6811-elf-strip.1.gz
man/man1/m6811-elf-windres.1.gz

View file

@ -1910,7 +1910,6 @@
SUBDIR += rssroll
SUBDIR += rsstail
SUBDIR += rsstool
SUBDIR += rt40
SUBDIR += rt42
SUBDIR += rt44
SUBDIR += rtv

View file

@ -1,220 +0,0 @@
# $FreeBSD$
PORTNAME= rt
PORTVERSION= 4.0.24
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://download.bestpractical.com/pub/rt/release/
PKGNAMESUFFIX= 40
MAINTAINER= matthew@FreeBSD.org
COMMENT= RT is an industrial-grade ticketing system written in Perl
DEPRECATED= Upstream support EoL, please migrate to rt44
EXPIRATION_DATE= 2017-02-15
CONFLICTS_INSTALL= rt42-4.2* rt44-4.4* brlcad-[0-9]*
NO_ARCH= yes
# See doc/web_deployment.pod for info on the choices of webserver /
# webapp combinations. Note: if using apache, apache-2.2+ is
# recommended. For deployment with nginx, use the SPAWN_FCGI method
# or the builtin webserver with a FCGI handler.
#
# The builtin standalone PSGI based webserver is always available, no
# matter what choice of web deployment platform, or none, that you
# make. Best Practical state that this is really only suitable for
# development usage, although I have heard reports of people using it
# successfully for medium sized deployments. If you only want the
# builtin webserver, simply deselect all of the web options.
#
# See doc/full_text_indexing.pod if you need to set up full text
# indexes on your ticket database. PostgreSQL or Oracle are
# recommended in this case: the MYSQL / SphinxSearch combination
# mentioned in the docs is currently unsupported in the ports, but see
# http://www.infracaninophile.co.uk/articles/sphinxse.html
OPTIONS_DEFINE= DEV GD GPG GRAPHVIZ SSL_MAILGATE DOCS
OPTIONS_SINGLE= DB
OPTIONS_SINGLE_DB= MYSQL ORACLE PGSQL SQLITE
OPTIONS_RADIO= WEB
OPTIONS_RADIO_WEB= AP_MODFASTCGI AP_MODPERL LIGHTTPD SPAWN_FCGI
OPTIONS_DEFAULT= AP_MODFASTCGI GD GPG MYSQL
USERS?= www
GROUPS?= rt www
RUN_DEPENDS+= ${LOCALBASE}/bin/jsmin:devel/jsmin
.include "${.CURDIR}/Makefile.cpan"
RUN_DEPENDS+= ${CORE_DEPS} \
${MASON_DEPS} \
${PSGI_DEPS} \
${MAILGATE_DEPS} \
${CLI_DEPS} \
${ICAL_DEPS} \
${SMTP_DEPS} \
${DASHBOARDS_DEPS} \
${USERLOGO_DEPS} \
${HTML_DOC_DEPS}
USES= cpe perl5
CPE_VENDOR= bestpractical
RT_LAYOUT= FreeBSD
RT_ETC_DIR?= etc/${PORTNAME}${PKGNAMESUFFIX}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
RT_ETC_PATH= ${PREFIX}/${RT_ETC_DIR}
AP_MODPERL_DESC= Deploy with apache and mod_perl
AP_MODPERL_RUN_DEPENDS= ${MODPERL2_DEPS}
AP_MODPERL_CONFIGURE_ON= --with-apachectl=${LOCALBASE}/sbin/apachectl
AP_MODFASTCGI_DESC= Deploy with apache and mod_fastcgi
AP_MODFASTCGI_USE= APACHE_RUN=22+
AP_MODFASTCGI_RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:www/mod_fastcgi \
${FASTCGI_DEPS}
AP_MODFASTCGI_CONFIGURE_ON= --with-apachectl=${LOCALBASE}/sbin/apachectl
LIGHTTPD_DESC= Deploy with lighttpd and mod_fastcgi
LIGHTTPD_RUN_DEPENDS= ${LOCALBASE}/sbin/lighttpd:www/lighttpd
SPAWN_FCGI_DESC= Deploy with spawn_fcgi
SPAWN_FCGI_RUN_DEPENDS= ${LOCALBASE}/bin/spawn-fcgi:www/spawn-fcgi
MYSQL_USE= MYSQL=yes
MYSQL_RUN_DEPENDS= ${MYSQL_DEPS}
PGSQL_USES= pgsql
PGSQL_RUN_DEPENDS= ${PGSQL_DEPS}
ORACLE_RUN_DEPENDS= ${ORACLE_DEPS}
SQLITE_USES= sqlite
SQLITE_RUN_DEPENDS= ${SQLITE_DEPS}
DEV_DESC= Configure for Developers
DEV_RUN_DEPENDS= ${DEV_DEPS}
DEV_CONFIGURE_ON= --enable-developer-mode
SSL_MAILGATE_DESC= Enable HTTPS support for rt-mailgate
SSL_MAILGATE_RUN_DEPENDS= ${SSL_MAILGATE_DEPS}
SSL_MAILGATE_CONFIGURE_ENABLE= ssl-mailgate
GRAPHVIZ_RUN_DEPENDS= ${GRAPHVIZ_DEPS}
GRAPHVIZ_CONFIGURE_ENABLE= graphviz
GPG_DESC= Enable GnuPG support
GPG_RUN_DEPENDS= ${GPG_DEPS}
GPG_CONFIGURE_ENABLE= gpg
GD_DESC= Enable GD Graphs and Charts
GD_RUN_DEPENDS= ${GD_DEPS}
GD_CONFIGURE_ENABLE= gd
BUILD_DEPENDS+= ${RUN_DEPENDS}
.include <bsd.port.options.mk>
.if !${PORT_OPTIONS:MMYSQL} && !${PORT_OPTIONS:MPGSQL} && \
! ${PORT_OPTIONS:MORACLE} && !${PORT_OPTIONS:MSQLITE}
IGNORE= please select one of MYSQL, PGSQL, ORACLE or SQLITE
.endif
.if ${PORT_OPTIONS:MMYSQL}
DB_TYPE= mysql
.endif
.if ${PORT_OPTIONS:MPGSQL}
DB_TYPE= Pg
.endif
.if ${PORT_OPTIONS:MORACLE}
DB_TYPE= Oracle
.endif
.if ${PORT_OPTIONS:MSQLITE}
DB_TYPE= SQLite
.endif
.if ${PORT_OPTIONS:MPGSQL}
DB_DBA_USER?= pgsql
.else
DB_DBA_USER?= root
.endif
DB_DBA_PASSWORD?=
DB_USER?= rt_user
DB_PASSWORD?= rt_pass
DB_HOST?= localhost
DB_DATABASE?= rt4
WEB_USER?= ${WWWOWN}
WEB_GROUP?= ${WWWGRP}
LIBS_GROUP?= wheel
HAS_CONFIGURE= yes
NO_BUILD= yes
CONFIGURE_ARGS+= --enable-layout=${RT_LAYOUT} \
--with-web-user=${WEB_USER} \
--with-web-group=${WEB_GROUP} \
--with-libs-group=${LIBS_GROUP} \
--with-db-host=${DB_HOST} \
--with-db-port=${DB_PORT} \
--with-db-type=${DB_TYPE} \
--with-db-rt-user=${DB_USER} \
--with-db-rt-pass=${DB_PASSWORD} \
--with-db-database=${DB_DATABASE} \
--with-db-dba=${DB_DBA_USER}
CONFIGURE_ENV+= PERL=${LOCALBASE}/bin/perl
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
SUB_LIST= RT_ETC_PATH=${RT_ETC_PATH}
PLIST_SUB= RT_ETC_DIR=${RT_ETC_DIR}
pre-fetch:
@${ECHO} ""
@${ECHO} " DB_TYPE=type mysql, Oracle, Pg or SQLite (mysql)"
@${ECHO} " DB_HOST=hostname The database host (localhost)"
@${ECHO} " DB_PORT=port The database port"
@${ECHO} " DB_DATABASE=dbname The database name (rt4)"
@${ECHO} ""
@${ECHO} " DB_DBA_USER=username Name of database administrator (root)"
@${ECHO} " DB_DBA_PASSWORD=password Password of database administrator"
@${ECHO} " DB_USER=username Name of database user for RT (rt_user)"
@${ECHO} " DB_PASSWORD=password Name of database password for RT (rt_pass)"
.if ${PORT_OPTIONS:MSQLITE}
@${ECHO} ""
@${ECHO} "SQLITE is not recommended for production use"
.endif
post-patch:
@${RM} ${WRKSRC}/lib/RT.pm.in.orig
@${REINPLACE_CMD} -e 's!%%PREFIX%%!${PREFIX}!g' ${WRKSRC}/config.layout
@${REINPLACE_CMD} -e 's!%%SITE_PERL%%!${PREFIX}/${SITE_PERL_REL}!g' ${WRKSRC}/config.layout
@${REINPLACE_CMD} -e 's!/path/to/your/etc!${RT_ETC_PATH}!g' ${WRKSRC}/etc/RT_SiteConfig.pm
@${REINPLACE_CMD} -e 's!/bin:/usr/bin!/bin:/usr/bin:${LOCALBASE}/bin!' ${WRKSRC}/lib/RT/Interface/CLI.pm && \
${RM} ${WRKSRC}/lib/RT/Interface/CLI.pm.bak
pre-install:
@${RM} ${WRKSRC}/lib/RT.pm.in
post-install:
@${RM} -r ${STAGEDIR}/${WWWDIR}${PKGNAMESUFFIX}
${MKDIR} ${STAGEDIR}${DOCSDIR}/upgrade
(cd ${WRKSRC}/etc && \
${COPYTREE_SHARE} upgrade ${STAGEDIR}${DOCSDIR} "! -name *\.in")
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} >= 502200
CORE_DEPS+= p5-CGI>0:www/p5-CGI
.endif
.include <bsd.port.post.mk>

View file

@ -1,141 +0,0 @@
###############################################################################
### File::Find 1.10 core
### File::Glob 1.05 core
### File::Spec 3.12 0.08 core
### Pod::Usage 1.33 core
### Scalar::Util 1.18 core
### Text::ParseWords 3.24 core
### Term::ReadLine core
###
### Digest::base core
### Time::HiRes core
### Errno core
### CGI 3.38 core (perl<5.22)
### CGI::Cookie 1.20 core (perl<5.22)
### Storable 2.08 core
### Getopt::Long 2.24 core
### Pod::Usage core
### File::Find core
### Net::SMTP core
### Digest::MD5 2.39 core
### Digest::SHA 5.47 core
### File::Temp 0.22 core
### Sys::Syslog 0.27 core
CORE_DEPS= p5-CSS-Squish>=0.06:textproc/p5-CSS-Squish \
p5-Cache-Simple-TimedExpiry>0:devel/p5-Cache-Simple-TimedExpiry \
p5-Class-Accessor>=0.34:devel/p5-Class-Accessor \
p5-Class-ReturnValue>=0.40:devel/p5-Class-ReturnValue \
p5-DBI>=1.37:databases/p5-DBI \
p5-DBIx-SearchBuilder>=1.59:databases/p5-DBIx-SearchBuilder \
p5-DateTime-Locale>=0.40:devel/p5-DateTime-Locale \
p5-DateTime>=0.44:devel/p5-DateTime \
p5-Devel-GlobalDestruction>0:devel/p5-Devel-GlobalDestruction \
p5-Devel-StackTrace>=1.30:devel/p5-Devel-StackTrace \
p5-Email-Address>=1.89.5:mail/p5-Email-Address \
p5-Encode>=2.64:converters/p5-Encode \
p5-File-ShareDir>0:devel/p5-File-ShareDir \
p5-HTML-Format>0:textproc/p5-HTML-Format \
p5-HTML-Parser>0:www/p5-HTML-Parser \
p5-HTML-Quoted>0:textproc/p5-HTML-Quoted \
p5-HTML-Scrubber>=0.08:www/p5-HTML-Scrubber \
p5-HTML-Tree>0:www/p5-HTML-Tree \
p5-List-MoreUtils>0:lang/p5-List-MoreUtils \
p5-Locale-Maketext-Fuzzy>0:devel/p5-Locale-Maketext-Fuzzy \
p5-Locale-Maketext-Lexicon>=0.32:devel/p5-Locale-Maketext-Lexicon \
p5-Locale-Maketext>=1.06:devel/p5-Locale-Maketext \
p5-Log-Dispatch>=2.23:devel/p5-Log-Dispatch \
p5-MIME-Tools>=5.425,2:mail/p5-MIME-Tools \
p5-Mail-Tools>=1.57:mail/p5-Mail-Tools \
p5-Module-Versions-Report>=1.05:devel/p5-Module-Versions-Report \
p5-Net-CIDR>0:net-mgmt/p5-Net-CIDR \
p5-Regexp-Common-net-CIDR>0:textproc/p5-Regexp-Common-net-CIDR \
p5-Regexp-Common>0:textproc/p5-Regexp-Common \
p5-Regexp-IPv6>0:textproc/p5-Regexp-IPv6 \
p5-Text-Password-Pronounceable>0:security/p5-Text-Password-Pronounceable \
p5-Text-Quoted>=2.02:textproc/p5-Text-Quoted \
p5-Text-Template>=1.44:textproc/p5-Text-Template \
p5-Text-Wrapper>0:textproc/p5-Text-Wrapper \
p5-Time-modules>0:devel/p5-Time-modules \
p5-Tree-Simple>=1.04:devel/p5-Tree-Simple \
p5-UNIVERSAL-require>0:devel/p5-UNIVERSAL-require
MASON_DEPS= p5-Apache-Session>=1.53:www/p5-Apache-Session \
p5-HTML-Mason>=1.43:www/p5-HTML-Mason \
p5-IPC-Run3>0:devel/p5-IPC-Run3 \
p5-JSON>0:converters/p5-JSON \
p5-Text-WikiFormat>=0.76:textproc/p5-Text-WikiFormat \
p5-XML-RSS>=1.05:textproc/p5-XML-RSS
PSGI_DEPS= p5-CGI-Emulate-PSGI>0:www/p5-CGI-Emulate-PSGI \
p5-CGI-PSGI>=0.12:www/p5-CGI-PSGI \
p5-HTML-Mason-PSGIHandler>=0.52:www/p5-HTML-Mason-PSGIHandler \
p5-Plack>=0.9971:www/p5-Plack \
p5-Starlet>0:www/p5-Starlet
MAILGATE_DEPS= p5-libwww>6.0:www/p5-libwww
SSL_MAILGATE_DEPS= p5-Crypt-SSLeay>0:security/p5-Crypt-SSLeay \
p5-LWP-Protocol-https>0:www/p5-LWP-Protocol-https \
p5-Mozilla-CA>0:www/p5-Mozilla-CA
CLI_DEPS= p5-HTTP-Message>0:www/p5-HTTP-Message \
p5-libwww>0:www/p5-libwww \
p5-Term-ReadKey>0:devel/p5-Term-ReadKey
# ports to add:
# Test::Email
# Test::Builder >= 0.90
DEV_DEPS= p5-Email-Abstract>0:mail/p5-Email-Abstract \
p5-HTML-Form>0:www/p5-HTML-Form \
p5-HTML-Parser>0:www/p5-HTML-Parser \
p5-Log-Dispatch-Perl>0:devel/p5-Log-Dispatch-Perl \
p5-Module-Refresh>=0.03:devel/p5-Module-Refresh \
p5-String-ShellQuote>0:textproc/p5-String-ShellQuote \
p5-Test-Deep>0:devel/p5-Test-Deep \
p5-Test-Expect>=0.31:devel/p5-Test-Expect \
p5-Test-LongString>0:devel/p5-Test-LongString \
p5-Test-MockTime>0:devel/p5-Test-MockTime \
p5-Test-WWW-Mechanize-PSGI>0:devel/p5-Test-WWW-Mechanize-PSGI \
p5-Test-WWW-Mechanize>=1.30:devel/p5-Test-WWW-Mechanize \
p5-Test-Warn>0:devel/p5-Test-Warn \
p5-WWW-Mechanize>=1.52:www/p5-WWW-Mechanize \
p5-Plack-Middleware-Test-StashWarnings>=0.08:www/p5-Plack-Middleware-Test-StashWarnings \
p5-XML-Simple>0:textproc/p5-XML-Simple
FASTCGI_DEPS= p5-FCGI-ProcManager>0:www/p5-FCGI-ProcManager \
p5-FCGI>=0.74:www/p5-FCGI
MODPERL2_DEPS= p5-libapreq2>0:www/p5-libapreq2 \
p5-Apache-DBI>0:www/p5-Apache-DBI
MYSQL_DEPS= p5-DBD-mysql>=2.1018:databases/p5-DBD-mysql
ORACLE_DEPS= p5-DBD-Oracle>0:databases/p5-DBD-Oracle
PGSQL_DEPS= p5-DBD-Pg>=3.3.1:databases/p5-DBD-Pg
SQLITE_DEPS= p5-DBD-SQLite>=1.00:databases/p5-DBD-SQLite
GPG_DEPS= p5-GnuPG-Interface>0:security/p5-GnuPG-Interface \
p5-PerlIO-eol>0:devel/p5-PerlIO-eol
ICAL_DEPS= p5-Data-ICal>0:deskutils/p5-Data-ICal
SMTP_DEPS= ## -- only needs perl core modules
DASHBOARDS_DEPS= p5-HTML-RewriteAttributes>=0.05:textproc/p5-HTML-RewriteAttributes \
p5-MIME-Types>0:mail/p5-MIME-Types \
p5-URI>=1.59:net/p5-URI
GRAPHVIZ_DEPS= p5-GraphViz>0:graphics/p5-GraphViz \
p5-IPC-Run>=0.90:devel/p5-IPC-Run
GD_DEPS= p5-GD>0:graphics/p5-GD \
p5-GD-Graph>0:graphics/p5-GD-Graph \
p5-GD-TextUtil>0:graphics/p5-GD-TextUtil
USERLOGO_DEPS= p5-Convert-Color>0:graphics/p5-Convert-Color
HTML_DOC_DEPS= p5-HTML-Parser>0:www/p5-HTML-Parser \
p5-Pod-Simple>=3.24:textproc/p5-Pod-Simple

View file

@ -1,2 +0,0 @@
SHA256 (rt-4.0.24.tar.gz) = 5940ac6c49341cc45de91705025ebec9a764b519415cc133375c6b0d91b84967
SIZE (rt-4.0.24.tar.gz) = 6841891

View file

@ -1,102 +0,0 @@
--- ./Makefile.in.orig 2014-01-07 01:01:22.000000000 +0000
+++ ./Makefile.in 2014-01-14 07:32:18.716253042 +0000
@@ -59,7 +59,7 @@
CONFIG_FILE_PATH = @CONFIG_FILE_PATH_R@
CONFIG_FILE = $(CONFIG_FILE_PATH)/RT_Config.pm
-SITE_CONFIG_FILE = $(CONFIG_FILE_PATH)/RT_SiteConfig.pm
+SITE_CONFIG_FILE = $(CONFIG_FILE_PATH)/RT_SiteConfig.pm-dist
RT_VERSION_MAJOR = @RT_VERSION_MAJOR@
@@ -109,7 +109,7 @@
RT_FONT_PATH = @RT_FONT_PATH_R@
RT_LEXICON_PATH = @RT_LEXICON_PATH_R@
RT_LOCAL_PATH = @RT_LOCAL_PATH_R@
-LOCAL_PLUGIN_PATH = @RT_LOCAL_PATH_R@/plugins
+LOCAL_PLUGIN_PATH = @RT_LOCAL_PATH_R@/share/rt40/plugins
LOCAL_ETC_PATH = @LOCAL_ETC_PATH_R@
LOCAL_LIB_PATH = @LOCAL_LIB_PATH_R@
LOCAL_LEXICON_PATH = @LOCAL_LEXICON_PATH_R@
@@ -269,16 +269,13 @@
depends: fixdeps
fixdeps:
- $(PERL) ./sbin/rt-test-dependencies --verbose --install --with-$(DB_TYPE) $(my_with_web_handlers)
+ $(PERL) ./sbin/rt-test-dependencies --verbose --with-$(DB_TYPE) $(my_with_web_handlers)
#}}}
fixperms:
# Make the libraries readable
chmod $(RT_READABLE_DIR_MODE) $(DESTDIR)$(RT_PATH)
- chown -R $(LIBS_OWNER) $(DESTDIR)$(RT_LIB_PATH)
- chgrp -R $(LIBS_GROUP) $(DESTDIR)$(RT_LIB_PATH)
- chmod -R u+rwX,go-w,go+rX $(DESTDIR)$(RT_LIB_PATH)
chmod $(RT_READABLE_DIR_MODE) $(DESTDIR)$(RT_BIN_PATH)
@@ -300,14 +297,6 @@
# Make the system binaries executable also
cd $(DESTDIR)$(RT_SBIN_PATH) && ( chmod 0755 $(SYSTEM_BINARIES) ; chown $(BIN_OWNER) $(SYSTEM_BINARIES); chgrp $(RTGROUP) $(SYSTEM_BINARIES))
- # Make upgrade scripts executable if they are in the source.
- #
- # Note that we use the deprecated (by GNU/POSIX find) -perm +0NNN syntax
- # instead of -perm /0NNN since BSD find doesn't support the latter.
- ( cd etc/upgrade && find . -type f -not -name '*.in' -perm +0111 -print ) | while read file ; do \
- chmod a+x "$(DESTDIR)$(RT_ETC_PATH)/upgrade/$$file" ; \
- done
-
# Make the web ui readable by all.
chmod -R u+rwX,go-w,go+rX $(DESTDIR)$(MASON_HTML_PATH) \
$(DESTDIR)$(MASON_LOCAL_HTML_PATH) \
@@ -346,14 +335,14 @@
$(INSTALL) -m 0755 -d $(DESTDIR)$(LOCAL_PLUGIN_PATH)
$(INSTALL) -m 0755 -d $(DESTDIR)$(LOCAL_LEXICON_PATH)
-install: testdeps config-install dirs files-install fixperms instruct
+install: config-install dirs files-install
files-install: libs-install etc-install config-install bin-install sbin-install html-install doc-install font-install po-install
config-install:
-@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0755 -o $(BIN_OWNER) -g $(RTGROUP) -d $(DESTDIR)$(CONFIG_FILE_PATH)
-@COMMENT_INPLACE_LAYOUT@ -$(INSTALL) -m 0440 -o $(BIN_OWNER) -g $(RTGROUP) etc/RT_Config.pm $(DESTDIR)$(CONFIG_FILE)
-@COMMENT_INPLACE_LAYOUT@ [ -f $(DESTDIR)$(SITE_CONFIG_FILE) ] || $(INSTALL) -m 0640 -o $(BIN_OWNER) -g $(RTGROUP) etc/RT_SiteConfig.pm $(DESTDIR)$(SITE_CONFIG_FILE)
+@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0755 -d $(DESTDIR)$(CONFIG_FILE_PATH)
+@COMMENT_INPLACE_LAYOUT@ -$(INSTALL) -m 0440 etc/RT_Config.pm $(DESTDIR)$(CONFIG_FILE)
+@COMMENT_INPLACE_LAYOUT@ [ -f $(DESTDIR)$(SITE_CONFIG_FILE) ] || $(INSTALL) -m 0640 etc/RT_SiteConfig.pm $(DESTDIR)$(SITE_CONFIG_FILE)
@COMMENT_INPLACE_LAYOUT@ @echo "Installed configuration. About to install RT in $(RT_PATH)"
test:
@@ -435,19 +424,12 @@
@COMMENT_INPLACE_LAYOUT@ for file in $(ETC_FILES) ; do \
@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0644 "etc/$$file" "$(DESTDIR)$(RT_ETC_PATH)/" ; \
@COMMENT_INPLACE_LAYOUT@ done
-@COMMENT_INPLACE_LAYOUT@ [ -d $(DESTDIR)$(RT_ETC_PATH)/upgrade ] || $(INSTALL) -m 0755 -d $(DESTDIR)$(RT_ETC_PATH)/upgrade
-@COMMENT_INPLACE_LAYOUT@ -( cd etc/upgrade && find . -type d -print ) | while read dir ; do \
-@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0755 -d "$(DESTDIR)$(RT_ETC_PATH)/upgrade/$$dir" ; \
-@COMMENT_INPLACE_LAYOUT@ done
-@COMMENT_INPLACE_LAYOUT@ -( cd etc/upgrade && find . -type f -not -name '*.in' -print ) | while read file ; do \
-@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0644 "etc/upgrade/$$file" "$(DESTDIR)$(RT_ETC_PATH)/upgrade/$$file" ; \
-@COMMENT_INPLACE_LAYOUT@ done
sbin-install:
@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0755 -d $(DESTDIR)$(RT_SBIN_PATH)
@COMMENT_INPLACE_LAYOUT@ for file in $(SYSTEM_BINARIES) ; do \
-@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -o $(BIN_OWNER) -g $(RTGROUP) -m 0755 "sbin/$$file" "$(DESTDIR)$(RT_SBIN_PATH)/" ; \
+@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0755 "sbin/$$file" "$(DESTDIR)$(RT_SBIN_PATH)/" ; \
@COMMENT_INPLACE_LAYOUT@ done
@@ -455,7 +437,7 @@
bin-install:
@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0755 -d $(DESTDIR)$(RT_BIN_PATH)
@COMMENT_INPLACE_LAYOUT@ for file in $(BINARIES) ; do \
-@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -o $(BIN_OWNER) -g $(RTGROUP) -m 0755 "bin/$$file" "$(DESTDIR)$(RT_BIN_PATH)/" ; \
+@COMMENT_INPLACE_LAYOUT@ $(INSTALL) -m 0755 "bin/$$file" "$(DESTDIR)$(RT_BIN_PATH)/" ; \
@COMMENT_INPLACE_LAYOUT@ done

View file

@ -1,38 +0,0 @@
--- ./config.layout.orig 2014-01-07 01:01:22.000000000 +0000
+++ ./config.layout 2014-01-14 07:32:38.755253941 +0000
@@ -97,14 +97,14 @@
</Layout>
<Layout FreeBSD>
- prefix: /usr/local
+ prefix: %%PREFIX%%
exec_prefix: ${prefix}
bindir: ${exec_prefix}/bin
sbindir: ${exec_prefix}/sbin
sysconfdir: ${prefix}/etc+
mandir: ${prefix}/man
plugindir: ${prefix}/plugins
- libdir: ${prefix}/lib+
+ libdir: %%SITE_PERL%%
datadir: ${prefix}/share+
htmldir: ${datadir}/html
lexdir: ${datadir}/po
@@ -114,12 +114,12 @@
localstatedir: /var/run+
masonstatedir: ${localstatedir}/mason_data
sessionstatedir: ${localstatedir}/session_data
- customdir: ${prefix}/share+
- custometcdir: ${customdir}/local/etc
- customhtmldir: ${customdir}/local/html
- customlexdir: ${customdir}/local/po
- customlibdir: ${customdir}/local/lib
- customplugindir: ${customdir}/local/plugins
+ customdir: ${prefix}
+ custometcdir: ${datadir}/etc
+ customhtmldir: ${customdir}/www+
+ customlexdir: ${datadir}/po
+ customlibdir: ${datadir}/lib
+ customplugindir: ${datadir}/plugins
</Layout>
<Layout Win32>

View file

@ -1,11 +0,0 @@
--- configure.orig 2014-09-11 18:55:07 UTC
+++ configure
@@ -2082,7 +2082,7 @@
s/^#.*$//m;
s/^\s+//gim;
s/\s+$/\n/gim;
- s/\+$/\/rt3/gim;
+ s/\+$/\/rt40/gim;
# m4 will not let us just use $srcdir/config.layout, we need $1
s/^\s*((?:bin|sbin|libexec|data|sysconf|sharedstate|localstate|lib|include|oldinclude|info|man|html)dir)\s*:\s*(.*)$/$1=$2/gim;
s/^\s*(.*?)\s*:\s*(.*)$/\(test "x\$$1" = "xNONE" || test "x\$$1" = "x") && $1=$2/gim;

View file

@ -1,43 +0,0 @@
=====================================================================
To complete the installation of this port, please follow these steps:
1. Edit %%RT_ETC_PATH%%/RT_SiteConfig.pm, by referring to
the default config file (%%RT_ETC_PATH%%/RT_Config.pm).
2. Configure the email and web gateways. Please refer to
'SETTING UP THE MAIL GATEWAY' in %%DOCSDIR%%/README
3. Restart Apache.
4. Do remember to *CHANGE* the root's password for the web interface.
The default is "password" (without the quotes.)
5. Configure RT per the instructions at
http://www.bestpractical.com/rt/docs.html
If you're upgrading RT then it is worth reading the UPGRADING document
at this point. Some extension you're using may have been integrated
into core. It's recommended to use new clean directory when you're
upgrading to new major release (for example from 3.8.x to 4.0.x).
To upgrade your database schema, preserving ticket history:
1. Backup your RT database.
2. If upgrading to a new major release, create a new database named
rt4 with appropriate rights for the rt_user and reload your
database backup into it.
3. Run:
# /usr/local/sbin/rt-setup-database \
--datadir %%DOCSDIR%%/upgrade \
--action upgrade --prompt-for-dba-password
and answer the prompts.
RT does not work with perl taint mode (-T) you must disable it.
Note, some other ports like devel/bugzilla have you add this to your
httpd.conf. This isn't actually a flaw of RT, but of a subset of the
CPAN modules that RT uses.
$ sudo perl rt-setup-database --action init --dba dba --dba-password X
$ sudo perl rt-setup-database --action drop --dba dba --dba-password X
See the TODO section at the top of the port's Makefile
=====================================================================

View file

@ -1,13 +0,0 @@
RT is an industrial-grade ticketing system. It lets a group of people
intelligently and efficiently manage requests submitted by a community
of users. RT is used by systems administrators, customer support
staffs, NOCs, developers and even marketing departments at over a
thousand sites around the world.
RT3 significantly revamped the RT codebase, featuring standard-compliant
Web UI, approval-based workflow system, REST-powered RPC mail gateway,
recursive group membership with delegates, autoconf, custom field support,
I18N and L10N framework, web-editable scrips, better documentation and
regression test suite, and more.
WWW: http://www.bestpractical.com/rt/

File diff suppressed because it is too large Load diff