add libdsp, a C++ class library of common digital signal processing functions
PR: 24373 Approved by: clive (my mentor)
This commit is contained in:
parent
0ae3e3a342
commit
a08d7ea835
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=37448
7 changed files with 69 additions and 0 deletions
|
@ -144,6 +144,7 @@
|
|||
SUBDIR += libcii
|
||||
SUBDIR += libcoro
|
||||
SUBDIR += libdlmalloc
|
||||
SUBDIR += libdsp
|
||||
SUBDIR += libffi
|
||||
SUBDIR += libg++
|
||||
SUBDIR += libgetline
|
||||
|
|
30
devel/libdsp/Makefile
Normal file
30
devel/libdsp/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# ex:ts=8
|
||||
# New ports collection makefile for: libdsp
|
||||
# Date created: Jan 16, 2001
|
||||
# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libdsp
|
||||
PORTVERSION= 3.3.4
|
||||
CATEGORIES= devel audio
|
||||
MASTER_SITES= http://www.pp.clinet.fi/~visitor/dlbins/
|
||||
DISTNAME= libdsp-src
|
||||
|
||||
MAINTAINER= ijliao@FreeBSD.org
|
||||
|
||||
# dont use "USE_LIBTOOL=yes" because there's no configure script
|
||||
BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool
|
||||
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME:S/dsp/DSP/}-${PORTVERSION}
|
||||
MAKEFILE= Makefile.FreeBSD
|
||||
|
||||
USE_GMAKE= yes
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/${MAKEFILE}
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/libdsp/distinfo
Normal file
1
devel/libdsp/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (libdsp-src.tar.gz) = e844f463d7c15ff98746c3c316038a86
|
18
devel/libdsp/files/patch-Makefile_FreeBSD
Normal file
18
devel/libdsp/files/patch-Makefile_FreeBSD
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- Makefile.FreeBSD.orig Tue Jan 16 13:35:30 2001
|
||||
+++ Makefile.FreeBSD Tue Jan 16 13:38:31 2001
|
||||
@@ -18,12 +18,12 @@
|
||||
#
|
||||
|
||||
CXX = g++
|
||||
-CXXFLAGS = -mcpu=k6 -march=k6 -O6 -fomit-frame-pointer -ffast-math -funroll-loops -malign-loops=3 -malign-jumps=3 -malign-functions=3 -mpreferred-stack-boundary=3 -mfancy-math-387 -Wall
|
||||
+CXXFLAGS = -O6 -fomit-frame-pointer -ffast-math -funroll-loops -malign-loops=3 -malign-jumps=3 -malign-functions=3 -mpreferred-stack-boundary=3 -mfancy-math-387 -Wall
|
||||
DEFS = -D_REENTRANT -D_THREAD_SAFE -DFREEBSD
|
||||
-INCS = -I.
|
||||
+INCS = -I. -I../Inlines-1.0.0.3
|
||||
LIBS = -lm #-ldrfftw -ldfftw
|
||||
LIBTOOL = libtool
|
||||
-PREFIX = /usr/local
|
||||
+PREFIX = %%PREFIX%%
|
||||
|
||||
VERSION = 0:4:0
|
||||
|
1
devel/libdsp/pkg-comment
Normal file
1
devel/libdsp/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
C++ class library of common digital signal processing functions
|
6
devel/libdsp/pkg-descr
Normal file
6
devel/libdsp/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
libDSP is C++ class library of common digital signal processing functions.
|
||||
|
||||
WWW: http://www.pp.clinet.fi/~visitor/
|
||||
|
||||
-- Ying-Chieh Liao
|
||||
ijliao@FreeBSD.org
|
12
devel/libdsp/pkg-plist
Normal file
12
devel/libdsp/pkg-plist
Normal file
|
@ -0,0 +1,12 @@
|
|||
include/dsp/DSPConfig.hh
|
||||
include/dsp/DSPOp.hh
|
||||
include/dsp/Decimator.hh
|
||||
include/dsp/Filter.hh
|
||||
include/dsp/Transform4.hh
|
||||
include/dsp/Transform8.hh
|
||||
include/dsp/TransformS.hh
|
||||
@dirrm include/dsp
|
||||
lib/libdsp.a
|
||||
lib/libdsp.la
|
||||
lib/libdsp.so
|
||||
lib/libdsp.so.0
|
Loading…
Reference in a new issue