Update to 3.3.15

This commit is contained in:
Emanuel Haupt 2018-06-02 14:55:55 +00:00
parent a95fb73519
commit a096b6d541
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=471372
8 changed files with 106 additions and 85 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= watch
DISTVERSION= 3.3.12
DISTVERSION= 3.3.15
CATEGORIES= misc
MASTER_SITES= SF/procps-ng/Production \
LOCAL/ehaupt

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1485505846
SHA256 (procps-ng-3.3.12.tar.xz) = 6ed65ab86318f37904e8f9014415a098bec5bc53653e5d9ab404f95ca5e1a7d4
SIZE (procps-ng-3.3.12.tar.xz) = 845484
TIMESTAMP = 1527948968
SHA256 (procps-ng-3.3.15.tar.xz) = 10bd744ffcb3de2d591d2f6acf1a54a7ba070fdcc432a855931a5057149f0465
SIZE (procps-ng-3.3.15.tar.xz) = 904416

View file

@ -1,18 +1,28 @@
--- Makefile.am.orig 2016-07-09 22:40:44 UTC
--- Makefile.am.orig 2018-05-19 21:35:23 UTC
+++ Makefile.am
@@ -1,7 +1,4 @@
@@ -1,8 +1,6 @@
-CYGWINFLAGS =
-if CYGWIN
- CYGWINFLAGS += -lintl
-endif
-CYGWINFLAGS += -lintl
+CYGWINFLAGS = -lintl
+
usrbin_exec_PROGRAMS =
-endif
AM_CPPFLAGS = \
-include $(top_builddir)/config.h \
@@ -24,19 +21,9 @@ LDADD = ./proc/libprocps.la $(CYGWINFLAG
transform = s/pscommand/ps/; $(program_transform_name)
@@ -30,24 +28,7 @@ transform =
bin_PROGRAMS = \
if !CYGWIN
transform += s/pscommand/ps/; $(program_transform_name)
-sbin_PROGRAMS = \
- sysctl
-else
-transform += s/pscommand/procps/; $(program_transform_name)
-endif
-
-if !CYGWIN
-bin_PROGRAMS = \
- ps/pscommand \
- free \
- pgrep \
@ -23,20 +33,20 @@
- uptime \
- vmstat \
- w
+ ps/pscommand
-sbin_PROGRAMS = \
- sysctl
+sbin_PROGRAMS = #
lib_LTLIBRARIES = \
proc/libprocps.la
@@ -73,29 +60,10 @@ dist_procpsng_DATA = \
Documentation/bugs.md \
Documentation/FAQ
else
usrbin_exec_PROGRAMS += \
ps/pscommand \
@@ -104,38 +85,10 @@ EXTRA_DIST += \
sysctl.conf
endif
-if BUILD_PIDOF
-if !CYGWIN
-bin_PROGRAMS += pidof
-else
-usrbin_exec_PROGRAMS += pidof
-endif
-dist_man_MANS += pidof.1
-pidof_SOURCES = pidof.c lib/fileutils.c
-else
@ -44,7 +54,13 @@
-endif
-
-if BUILD_KILL
-if CYGWIN
-transform += ;s/^kill/prockill/; $(program_transform_name)
-usrbin_exec_PROGRAMS += kill
-else
-bin_PROGRAMS += kill
-endif
-
-dist_man_MANS += kill.1
-kill_SOURCES = skill.c lib/strutils.c lib/fileutils.c lib/nsutils.c
-else
@ -52,24 +68,40 @@
-endif
-
if WITH_NCURSES
bin_PROGRAMS += \
if !CYGWIN
-bin_PROGRAMS += \
- slabtop \
- watch \
- top/top
+bin_PROGRAMS = \
+ watch
else
usrbin_exec_PROGRAMS += \
watch \
@@ -143,8 +96,7 @@ usrbin_exec_PROGRAMS += \
endif
dist_man_MANS += \
- slabtop.1 \
watch.1 \
top/top.1
slabtop_SOURCES = slabtop.c lib/strutils.c lib/fileutils.c
@@ -115,21 +83,6 @@ endif
- watch.1 \
- top/top.1
+ watch.1
watch_SOURCES = watch.c lib/strutils.c lib/fileutils.c
watch_LDADD = @WATCH_NCURSES_LIBS@ $(CYGWINFLAGS)
watch_CFLAGS = @WATCH_NCURSES_CFLAGS@
@@ -167,27 +119,6 @@ endif
top_top_LDADD = $(LDADD) @NCURSES_LIBS@ $(DL_LIB)
endif
-if BUILD_SKILL
-if !CYGWIN
-bin_PROGRAMS += \
- skill \
- snice
-else
-usrbin_exec_PROGRAMS += \
- skill \
- snice
-endif
-skill_SOURCES = skill.c lib/strutils.c lib/fileutils.c lib/nsutils.c
-snice_SOURCES = skill.c lib/strutils.c lib/fileutils.c lib/nsutils.c
-dist_man_MANS += \
@ -84,10 +116,11 @@
free_SOURCES = free.c lib/strutils.c lib/fileutils.c
pgrep_SOURCES = pgrep.c lib/fileutils.c lib/nsutils.c
pkill_SOURCES = pgrep.c lib/fileutils.c lib/nsutils.c
@@ -182,9 +135,7 @@ proc_libprocps_la_SOURCES = \
@@ -250,10 +181,7 @@ proc_libprocps_la_SOURCES = \
proc/sysinfo.h \
proc/version.c \
proc/version.h \
proc/wchan.c \
- proc/wchan.c \
- proc/wchan.h \
- proc/whattime.c \
- proc/whattime.h

View file

@ -1,8 +1,8 @@
--- proc/sig.c.orig 2016-07-09 21:49:25 UTC
--- proc/sig.c.orig 2018-05-18 21:32:21 UTC
+++ proc/sig.c
@@ -82,7 +82,11 @@ static const mapstruct sigtable[] = {
{"INT", SIGINT},
{"KILL", SIGKILL},
@@ -87,7 +87,11 @@ static const mapstruct sigtable[] = {
{"LOST", SIGLOST}, /* Hurd-specific */
#endif
{"PIPE", SIGPIPE},
+#ifdef __FreeBSD__
+ {"POLL", SIGIO},
@ -10,9 +10,9 @@
{"POLL", SIGPOLL}, /* IO */
+#endif
{"PROF", SIGPROF},
#ifdef SIGPWR
{"PWR", SIGPWR},
{"QUIT", SIGQUIT},
@@ -121,7 +125,11 @@ int signal_name_to_number(const char *re
@@ -145,7 +149,11 @@ int signal_name_to_number(const char *re
if(!strncasecmp(name,"SIG",3)) name += 3;
if(!strcasecmp(name,"CLD")) return SIGCHLD;

View file

@ -0,0 +1,38 @@
--- proc/sysinfo.c.orig 2018-05-18 21:32:22 UTC
+++ proc/sysinfo.c
@@ -30,7 +30,7 @@
#include <unistd.h>
#include <fcntl.h>
-#ifdef __CYGWIN__
+#ifdef __FreeBSD__
#include <sys/param.h>
#endif
#include "alloc.h"
@@ -41,7 +41,7 @@
#include <netinet/in.h> /* htons */
#endif
-#ifndef __CYGWIN__
+#ifndef __FreeBSD__
#include <link.h>
#endif
#include <elf.h>
@@ -98,7 +98,7 @@ static char buf[8192];
#define SET_IF_DESIRED(x,y) do{ if(x) *(x) = (y); }while(0)
/* return minimum of two values */
-#ifndef __CYGWIN__
+#ifndef __FreeBSD__
#define MIN(x,y) ((x) < (y) ? (x) : (y))
#endif
@@ -264,7 +264,7 @@ extern char** environ;
static unsigned long find_elf_note(unsigned long type)
{
-#ifdef __CYGWIN__
+#ifdef __FreeBSD__
return NOTE_NOT_FOUND;
#else
ElfW(auxv_t) auxv_struct;

View file

@ -1,13 +0,0 @@
--- ps/display.c.orig 2016-07-09 21:49:25 UTC
+++ ps/display.c
@@ -26,7 +26,10 @@
#include <string.h>
#include <unistd.h>
+
+#ifndef __FreeBSD__
#include <sys/sysmacros.h>
+#endif
#include <sys/types.h>
#include "../proc/alloc.h"

View file

@ -1,12 +0,0 @@
--- ps/global.c.orig 2016-07-09 21:49:25 UTC
+++ ps/global.c
@@ -28,7 +28,9 @@
#include <sys/ioctl.h>
#include <sys/stat.h>
+#ifndef __FreeBSD__
#include <sys/sysmacros.h>
+#endif
#include <sys/types.h>
#include "../proc/wchan.h"

View file

@ -1,25 +0,0 @@
--- watch.c.orig 2016-07-09 21:49:25 UTC
+++ watch.c
@@ -52,7 +52,11 @@
# define _XOPEN_SOURCE_EXTENDED 1
# include <wchar.h>
# include <wctype.h>
+#ifdef __FreeBSD__
+# include <ncurses.h>
+#else
# include <ncursesw/ncurses.h>
+#endif
#else
# include <ncurses.h>
#endif /* WITH_WATCH8BIT */
@@ -72,6 +76,10 @@ static int flags;
#define WATCH_ERREXIT (1 << 6)
#define WATCH_CHGEXIT (1 << 7)
+#ifdef __FreeBSD__
+#define HOST_NAME_MAX 1024
+#endif
+
static int curses_started = 0;
static long height = 24, width = 80;
static int screen_size_changed = 0;