- Update to 0.3.1

This commit is contained in:
Cheng-Lung Sung 2011-04-07 09:12:37 +00:00
parent a2d58fb79b
commit a0af437a1a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=272331
4 changed files with 9 additions and 31 deletions

View file

@ -6,10 +6,9 @@
#
PORTNAME= glog
DISTVERSION= 0.2.1
PORTREVISION= 1
DISTVERSION= 0.3.1
CATEGORIES= devel
MASTER_SITES= http://google-glog.googlecode.com/files/
MASTER_SITES= GOOGLE_CODE
MAINTAINER= clsung@FreeBSD.org
COMMENT= A library of C++ classes for flexible logging
@ -20,14 +19,14 @@ GNU_CONFIGURE= yes
USE_GNOME= gnomehack
USE_LDCONFIG= yes
USE_GCC= 4.2+
PROJECTHOST= google-glog
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lexecinfo"
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" || ${ARCH} =="ia64" || ${ARCH} =="powerpc" || ${ARCH} =="sparc64"
EXTRA_PATCHES= ${FILESDIR}/extra-patch-src-logging.cc \
${FILESDIR}/extra-patch-src-utilities.cc
EXTRA_PATCHES= ${FILESDIR}/extra-patch-src-utilities.cc
.endif
.if ${ARCH} == "amd64"

View file

@ -1,3 +1,2 @@
MD5 (glog-0.2.1.tar.gz) = 8e2dd128f2f39200d9982f0e36f106ba
SHA256 (glog-0.2.1.tar.gz) = 572dae745aeaaaafcff5b9ba33462e56a910b504db07298337cfe6416dfb6dea
SIZE (glog-0.2.1.tar.gz) = 484026
SHA256 (glog-0.3.1.tar.gz) = eebc617a22a3f68594e74aed3c48a024f36c867b42324a79521259d6393bae24
SIZE (glog-0.3.1.tar.gz) = 490361

View file

@ -1,11 +0,0 @@
--- src/logging.cc.orig 2008-10-03 13:32:01.000000000 +0800
+++ src/logging.cc 2008-10-14 13:32:03.000000000 +0800
@@ -1566,7 +1566,7 @@
} else {
buf[0] = '\000';
#if defined(OS_MACOSX) || defined(OS_FREEBSD)
- if (reinterpret_cast<int>(rc) < sys_nerr) {
+ if (reinterpret_cast<long>(rc) < sys_nerr) {
// This means an error on MacOSX or FreeBSD.
return -1;
}

View file

@ -1,6 +1,6 @@
--- src/utilities.cc.orig 2009-01-23 09:37:14.000000000 +0800
+++ src/utilities.cc 2009-02-04 11:25:50.000000000 +0800
@@ -187,8 +187,6 @@
--- src/utilities.cc.orig 2010-06-15 14:28:09.000000000 +0800
+++ src/utilities.cc 2011-04-07 17:00:18.000000000 +0800
@@ -227,8 +227,6 @@
#ifndef __NR_gettid
#ifdef OS_MACOSX
#define __NR_gettid SYS_gettid
@ -9,12 +9,3 @@
#else
#define __NR_gettid 224
#endif
@@ -214,7 +212,7 @@
return GetCurrentThreadId();
#else
// If none of the techniques above worked, we use pthread_self().
- return (pid_t)pthread_self();
+ return reinterpret_cast<unsigned long>(pthread_self());
#endif
}