lang/rust-nightly: Update to 1.79.0.20240317

This commit is contained in:
Mikael Urankar 2024-03-18 13:52:55 +01:00
parent 88cc397f61
commit a0d1ab7edf
3 changed files with 21 additions and 23 deletions

View File

@ -1,5 +1,5 @@
# Run update.sh to update to the latest nightly
PORTVERSION= 1.76.0.${NIGHTLY_DATE:C,-,,g}
PORTVERSION= 1.79.0.${NIGHTLY_DATE:C,-,,g}
# Always set PORTREVISION explicitly as otherwise it is inherited from lang/rust
PORTREVISION= 0
PKGNAMESUFFIX= -nightly
@ -14,8 +14,8 @@ MASTERDIR= ${.CURDIR}/../rust
PATCHDIR= ${.CURDIR}/files
DISTINFO_FILE= ${.CURDIR}/distinfo
NIGHTLY_DATE= 2023-11-25
BOOTSTRAPS_DATE= 2023-11-13
NIGHTLY_DATE= 2024-03-17
BOOTSTRAPS_DATE= 2024-02-04
RUST_BOOTSTRAP_VERSION= beta
.include "${MASTERDIR}/Makefile"

View File

@ -1,9 +1,9 @@
TIMESTAMP = 1701007367
SHA256 (rust/2023-11-25/rustc-nightly-src.tar.xz) = 3538acb92c0497ae747cff254086572c1f57ee03e92ab8a12247cc162f6776d2
SIZE (rust/2023-11-25/rustc-nightly-src.tar.xz) = 162679888
SHA256 (rust/2023-11-13/rustc-beta-x86_64-unknown-freebsd.tar.xz) = c2094e3b40e602ab804e875ec1b1ab7e91f0ff499bc6c1e4b2a957ed4d136ab8
SIZE (rust/2023-11-13/rustc-beta-x86_64-unknown-freebsd.tar.xz) = 74020428
SHA256 (rust/2023-11-13/rust-std-beta-x86_64-unknown-freebsd.tar.xz) = 28c43fb5b7bf4c254ef61c5bc39da09e81881e01261a8a3346968170c8774581
SIZE (rust/2023-11-13/rust-std-beta-x86_64-unknown-freebsd.tar.xz) = 24136416
SHA256 (rust/2023-11-13/cargo-beta-x86_64-unknown-freebsd.tar.xz) = 67f1bb5008080c00f4f22be794b1fa63a88c1503187dc3396260aa73d52a1f7c
SIZE (rust/2023-11-13/cargo-beta-x86_64-unknown-freebsd.tar.xz) = 8519764
TIMESTAMP = 1710755050
SHA256 (rust/2024-03-17/rustc-nightly-src.tar.xz) = 6e6c230c757feb1374c656c8b078d2fd96e7cced020cecf8100ac04c7ea46503
SIZE (rust/2024-03-17/rustc-nightly-src.tar.xz) = 159212704
SHA256 (rust/2024-02-04/rustc-beta-x86_64-unknown-freebsd.tar.xz) = b5de56f1f686befd7d225c4fc0636132119a28e6ed22e56300347e8c8fd4388b
SIZE (rust/2024-02-04/rustc-beta-x86_64-unknown-freebsd.tar.xz) = 72836908
SHA256 (rust/2024-02-04/rust-std-beta-x86_64-unknown-freebsd.tar.xz) = a02a5962c65cbe60667a45d5ad5ec28f1dc86d18344c619fba00f9afd96519e1
SIZE (rust/2024-02-04/rust-std-beta-x86_64-unknown-freebsd.tar.xz) = 26887676
SHA256 (rust/2024-02-04/cargo-beta-x86_64-unknown-freebsd.tar.xz) = 46a7ce49382615f896276eb1966b7815353d19927a9e54feac902777fc7de10e
SIZE (rust/2024-02-04/cargo-beta-x86_64-unknown-freebsd.tar.xz) = 9010280

View File

@ -8,13 +8,12 @@ until LLVM can be updated to use libc++ by default.
https://reviews.llvm.org/D77776
--- vendor/cc/src/lib.rs.orig 2021-03-04 20:58:54 UTC
+++ vendor/cc/src/lib.rs
@@ -2659,24 +2659,7 @@ impl Tool {
}
--- vendor/cc/src/tool.rs.orig 2024-03-18 11:23:17 UTC
+++ vendor/cc/src/tool.rs
@@ -122,22 +122,7 @@ impl Tool {
};
fn with_features(path: PathBuf, clang_driver: Option<&str>, cuda: bool) -> Self {
- // Try to detect family of the tool from its name, falling back to Gnu.
// Try to detect family of the tool from its name, falling back to Gnu.
- let family = if let Some(fname) = path.file_name().and_then(|p| p.to_str()) {
- if fname.contains("clang-cl") {
- ToolFamily::Msvc { clang_cl: true }
@ -26,13 +25,12 @@ https://reviews.llvm.org/D77776
- _ => ToolFamily::Clang,
- }
- } else {
- ToolFamily::Gnu
- detect_family(&path)
- }
- } else {
- ToolFamily::Gnu
- detect_family(&path)
- };
-
+ let family = ToolFamily::Gnu;
Tool {
path: path,
cc_wrapper_path: None,
path,