net/netatalk3: Update to 3.1.13

See https://netatalk.sourceforge.io/3.1/ReleaseNotes3.1.13.html for the
changes in this release.

Security:	CVE-2021-31439
		CVE-2022-23121
		CVE-2022-23123
		CVE-2022-23122
		CVE-2022-23125
		CVE-2022-23124
		CVE-2022-0194
This commit is contained in:
Joe Marcus Clarke 2022-05-01 13:44:16 -04:00
parent bbe9080b6d
commit a104816328
8 changed files with 34 additions and 35 deletions

View file

@ -1,8 +1,7 @@
# Created by: stb
PORTNAME= netatalk
PORTVERSION= 3.1.12
PORTREVISION= 4
PORTVERSION= 3.1.13
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= SF

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1546280402
SHA256 (netatalk-3.1.12.tar.bz2) = 1560f83a3da41be97e0b70a96e2402159b8ddc631d38538360b14784beada5d1
SIZE (netatalk-3.1.12.tar.bz2) = 1918312
TIMESTAMP = 1651426342
SHA256 (netatalk-3.1.13.tar.bz2) = 89ada6bcfe1b39ad94f58c236654d1d944f2645c3e7de98b3374e0bd37d5e05d
SIZE (netatalk-3.1.13.tar.bz2) = 1218394

View file

@ -1,17 +1,17 @@
--- config/Makefile.in.orig 2016-09-12 09:54:34 UTC
--- config/Makefile.in.orig 2022-03-22 04:51:08 UTC
+++ config/Makefile.in
@@ -825,8 +825,8 @@ install-data-local: install-config-files
@@ -824,8 +824,8 @@ install-data-local: install-config-files
uninstall-local:
@for f in $(CONFFILES) $(GENFILES); do \
- echo rm -f $(DESTDIR)$(pkgconfdir)/$$f; \
- rm -f $(DESTDIR)$(pkgconfdir)/$$f; \
+ echo rm -f $(DESTDIR)$(pkgconfdir)/$$f.dist; \
+ rm -f $(DESTDIR)$(pkgconfdir)/$$f.dist; \
+ echo rm -f $(DESTDIR)$(pkgconfdir)/$$f.sample; \
+ rm -f $(DESTDIR)$(pkgconfdir)/$$f.sample; \
done
rm -f $(DESTDIR)$(pkgconfdir)/dbus-session.conf
rm -f $(DESTDIR)$(localstatedir)/netatalk/README
@@ -836,21 +836,16 @@ uninstall-local:
@@ -835,21 +835,16 @@ uninstall-local:
install-config-files: $(CONFFILES) $(GENFILES)
$(mkinstalldirs) $(DESTDIR)$(pkgconfdir)
@for f in $(CONFFILES) ; do \
@ -21,8 +21,8 @@
- else \
- echo "not overwriting $$f"; \
- fi; \
+ echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist"; \
+ $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist; \
+ echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.sample"; \
+ $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.sample; \
done
@for f in $(GENFILES); do \
- if test "x$(OVERWRITE_CONFIG)" = "xyes" -o ! -f $(DESTDIR)$(pkgconfdir)/$$f; then \
@ -32,8 +32,8 @@
- echo "not overwriting $$f"; \
- fi; \
+ if [ $$f != "dbus-session.conf" ]; then \
+ echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist"; \
+ $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist; \
+ echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.sample"; \
+ $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.sample; \
+ fi; \
done
+ $(INSTALL_DATA) dbus-session.conf $(DESTDIR)$(pkgconfdir)/dbus-session.conf.netatalk

View file

@ -1,15 +1,15 @@
--- etc/afpd/Makefile.in.orig 2016-09-12 09:54:35 UTC
--- etc/afpd/Makefile.in.orig 2022-03-22 04:51:08 UTC
+++ etc/afpd/Makefile.in
@@ -191,7 +191,7 @@ AM_V_at = $(am__v_at_@AM_V@)
@@ -186,7 +186,7 @@ AM_V_at = $(am__v_at_@AM_V@)
am__v_at_ = $(am__v_at_@AM_DEFAULT_V@)
am__v_at_0 = @
am__v_at_1 =
-DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
+DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir) -I$(top_builddir)/include
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
am__mv = mv -f
@@ -473,7 +473,7 @@ afpd_SOURCES = afp_config.c afp_dsi.c af
am__maybe_remake_depfiles = depfiles
am__depfiles_remade = ./$(DEPDIR)/afpd-acls.Po \
@@ -489,7 +489,7 @@ afpd_SOURCES = afp_config.c afp_dsi.c afp_options.c af
$(am__append_7)
afpd_LDADD = $(top_builddir)/libatalk/libatalk.la @LIBGCRYPT_LIBS@ \
@QUOTA_LIBS@ @WRAP_LIBS@ @LIBADD_DL@ @ACL_LIBS@ @PTHREAD_LIBS@ \

View file

@ -1,11 +0,0 @@
--- etc/afpd/directory.h.orig 2014-12-11 11:27:44 UTC
+++ etc/afpd/directory.h
@@ -91,7 +91,7 @@ struct maccess {
#define AR_UWRITE (1<<2)
#define AR_UOWN (1<<7)
-q_t *invalid_dircache_entries;
+extern q_t *invalid_dircache_entries;
typedef int (*dir_loop)(struct dirent *, char *, void *);

View file

@ -0,0 +1,11 @@
--- etc/netatalk/Makefile.in.orig 2022-05-01 17:38:31 UTC
+++ etc/netatalk/Makefile.in
@@ -433,7 +433,7 @@ netatalk_LDADD = \
@ZEROCONF_LIBS@ \
$(top_builddir)/libatalk/libatalk.la
-netatalk_LDFLAGS = @LIBEVENT_LDFLAGS@ -levent
+netatalk_LDFLAGS = @LIBEVENT_LIBS@
noinst_HEADERS = afp_zeroconf.h afp_avahi.h afp_mdns.h
all: all-am

View file

@ -1,6 +1,6 @@
--- etc/uams/openssl_compat.h.orig 2019-01-03 18:36:43.123024000 +0000
+++ etc/uams/openssl_compat.h 2019-01-03 18:37:02.918877000 +0000
@@ -11,7 +11,7 @@ http://www.gnu.org/licenses/old-licenses
--- etc/uams/openssl_compat.h.orig 2022-02-28 13:32:06 UTC
+++ etc/uams/openssl_compat.h
@@ -11,7 +11,7 @@ http://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
#ifndef OPENSSL_COMPAT_H
#define OPENSSL_COMPAT_H

View file

@ -1,5 +1,5 @@
--- libatalk/vfs/extattr.c 2020-11-17 04:20:13 UTC
+++ libatalk/vfs/extattr.c
--- libatalk/vfs/extattr.c.orig 2022-03-22 04:50:23 UTC
+++ libatalk/vfs/extattr.c
@@ -353,13 +353,13 @@ static ssize_t bsd_attr_list (int type, extattr_arg ar
}