Add vqregister 2.6, an extremely admin-configurable email user signup CGI.
vQregister is a CGI which allows new email users to signup on your system. It is extremely configurable, and has many methods of operation. * Configurable to allow random generation of passwords, which are emailed to users. * Redirect your users (ie, SqWebmail) after the signup process is complete. * Fully templacized HTML, and email output. WWW: http://www.inter7.com/vqregister.html PR: 59525 Submitted by: Dan Caescu <daniel@freebsd.ro>
This commit is contained in:
parent
8697f3d4a9
commit
a110ceccb6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=95665
6 changed files with 94 additions and 0 deletions
|
@ -369,6 +369,7 @@
|
|||
SUBDIR += vpopmail
|
||||
SUBDIR += vpopmail-stable
|
||||
SUBDIR += vqadmin
|
||||
SUBDIR += vqregister
|
||||
SUBDIR += vrfy
|
||||
SUBDIR += wanderlust
|
||||
SUBDIR += wanderlust-emacs20
|
||||
|
|
36
mail/vqregister/Makefile
Normal file
36
mail/vqregister/Makefile
Normal file
|
@ -0,0 +1,36 @@
|
|||
# New ports collection makefile for: vqregister
|
||||
# Date created: 2003-11-15
|
||||
# Whom: Dan Caescu <daniel@freebsd.ro>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= vqregister
|
||||
PORTVERSION= 2.6
|
||||
CATEGORIES= mail www
|
||||
MASTER_SITES= http://www.inter7.com/vqregister/
|
||||
|
||||
MAINTAINER= daniel@freebsd.ro
|
||||
COMMENT= An extremely admin-configurable email user signup CGI
|
||||
|
||||
BUILD_DEPENDS= ${VPOPMAIL_DIR}:${PORTSDIR}/mail/vpopmail
|
||||
RUN_DEPENDS= ${VPOPMAIL_DIR}:${PORTSDIR}/mail/vpopmail \
|
||||
${WWW_DIR}:${PORTSDIR}/www/apache13
|
||||
|
||||
VPOPMAIL_DIR?= ${LOCALBASE}/vpopmail
|
||||
WWW_DIR?= ${LOCALBASE}/www
|
||||
|
||||
USE_MYSQL= yes
|
||||
MAKE_ENV= VDIR=${VPOPMAIL_DIR} WWW_DIR=${WWW_DIR}
|
||||
PLIST_SUB= WWW_DIR=${WWW_DIR}
|
||||
|
||||
DOCS= CONFIG CONTRIBUTORS FORM HISTORY TEMPLATE
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
post-install:
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
1
mail/vqregister/distinfo
Normal file
1
mail/vqregister/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (vqregister-2.6.tar.gz) = 7f0f0808f03096ef5c7203693842f9c4
|
23
mail/vqregister/files/patch-Makefile
Normal file
23
mail/vqregister/files/patch-Makefile
Normal file
|
@ -0,0 +1,23 @@
|
|||
--- Makefile.orig Fri Dec 12 17:04:17 2003
|
||||
+++ Makefile Fri Dec 12 17:07:04 2003
|
||||
@@ -2,16 +2,16 @@
|
||||
# vol@inter7.com
|
||||
#
|
||||
|
||||
-VDIR = /home/vpopmail
|
||||
+VDIR?= /home/vpopmail
|
||||
CC = gcc
|
||||
BIN = vqregister
|
||||
-DEFS = -I$(VDIR)/include -I/usr/local/mysql/include
|
||||
+DEFS = -I$(VDIR)/include -I${LOCALBASE}/include/mysql
|
||||
LINKDEFS =
|
||||
-LIBS = -L$(VDIR)/lib -lvpopmail -lcrypt -L/usr/local/mysql/lib/mysql -lmysqlclient
|
||||
+LIBS = -L$(VDIR)/lib -lvpopmail -lcrypt -L${LOCALBASE}/lib/mysql -lmysqlclient
|
||||
OBJS = main.o cgi.o template.o global.o misc.o config.o register.o password.o \
|
||||
vpopmail.o db.o field.o badhosts.o
|
||||
|
||||
-INSTALL_DIR = /usr/local/apache/cgi-bin/vqregister
|
||||
+INSTALL_DIR = ${WWW_DIR}/cgi-bin/vqregister
|
||||
INSTALL_BIN = vqregister.cgi
|
||||
INSTALL_UID = vpopmail
|
||||
INSTALL_GID = vchkpw
|
13
mail/vqregister/pkg-descr
Normal file
13
mail/vqregister/pkg-descr
Normal file
|
@ -0,0 +1,13 @@
|
|||
vQregister is a CGI which allows new email users to signup on your system.
|
||||
It is extremely configurable, and has many methods of operation.
|
||||
* Configurable to allow random generation of passwords, which are
|
||||
emailed to users.
|
||||
* Redirect your users (ie, SqWebmail) after the signup process is
|
||||
complete.
|
||||
* Fully templacized HTML, and email output.
|
||||
|
||||
WWW: http://www.inter7.com/vqregister.html
|
||||
|
||||
- Dan Caescu
|
||||
daniel@freebsd.ro
|
||||
dan_c@pellin.ro
|
20
mail/vqregister/pkg-plist
Normal file
20
mail/vqregister/pkg-plist
Normal file
|
@ -0,0 +1,20 @@
|
|||
@comment $FreeBSD$
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CONFIG
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CONTRIBUTORS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/FORM
|
||||
%%PORTDOCS%%%%DOCSDIR%%/HISTORY
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TEMPLATE
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@cwd %%WWW_DIR%%
|
||||
cgi-bin/vqregister/vqregister.cgi
|
||||
cgi-bin/vqregister/vqregister.email
|
||||
cgi-bin/vqregister/vqregister.conf
|
||||
cgi-bin/vqregister/html/error.html
|
||||
cgi-bin/vqregister/html/failure.html
|
||||
cgi-bin/vqregister/html/init_error.html
|
||||
cgi-bin/vqregister/html/register.html
|
||||
cgi-bin/vqregister/html/register.with.password.html
|
||||
cgi-bin/vqregister/html/success.html
|
||||
cgi-bin/vqregister/html/success.with.password.html
|
||||
@dirrm cgi-bin/vqregister/html
|
||||
@dirrm cgi-bin/vqregister
|
Loading…
Reference in a new issue