Update to 5.5.5.
Requested by: many people
This commit is contained in:
parent
ebab40c1a9
commit
a12aeaa9f2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=195225
5 changed files with 7 additions and 47 deletions
|
@ -6,14 +6,14 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= DarwinStreamingServer
|
PORTNAME= DarwinStreamingServer
|
||||||
PORTVERSION= 5.5.4
|
PORTVERSION= 5.5.5
|
||||||
PORTREVISION= 1
|
PORTREVISION= 0
|
||||||
CATEGORIES= net
|
CATEGORIES= net
|
||||||
MASTER_SITES= #http://developer.apple.com/darwin/projects/streaming/source/
|
MASTER_SITES= #http://developer.apple.com/darwin/projects/streaming/source/
|
||||||
# You must accept APSL (Apple Public Source License), and get
|
# You must accept APSL (Apple Public Source License), and get
|
||||||
# DarwinStreamingSrvr5.5.4-Source.tar.
|
# DarwinStreamingSrvr5.5.5-Source.tar.gz.
|
||||||
DISTNAME= DarwinStreamingSrvr${PORTVERSION}-Source
|
DISTNAME= DarwinStreamingSrvr${PORTVERSION}-Source
|
||||||
EXTRACT_SUFX= .tar
|
#EXTRACT_SUFX= .tar
|
||||||
|
|
||||||
MAINTAINER= nork@FreeBSD.org
|
MAINTAINER= nork@FreeBSD.org
|
||||||
COMMENT= Darwin Streaming Server, a MP3, MPEG4 and QuickTime streaming server
|
COMMENT= Darwin Streaming Server, a MP3, MPEG4 and QuickTime streaming server
|
||||||
|
@ -97,7 +97,6 @@ post-patch:
|
||||||
${WRKSRC}/qtpasswd.tproj/Makefile.POSIX \
|
${WRKSRC}/qtpasswd.tproj/Makefile.POSIX \
|
||||||
${WRKSRC}/MP3Broadcaster/Makefile.POSIX \
|
${WRKSRC}/MP3Broadcaster/Makefile.POSIX \
|
||||||
${WRKSRC}/HTTPUtilitiesLib/Makefile.POSIX \
|
${WRKSRC}/HTTPUtilitiesLib/Makefile.POSIX \
|
||||||
${WRKSRC}/StreamingLoadTool/Makefile.POSIX \
|
|
||||||
${WRKSRC}/CommonUtilitiesLib/Makefile.POSIX \
|
${WRKSRC}/CommonUtilitiesLib/Makefile.POSIX \
|
||||||
${WRKSRC}/StreamingProxy.tproj/Makefile.POSIX \
|
${WRKSRC}/StreamingProxy.tproj/Makefile.POSIX \
|
||||||
${WRKSRC}/StreamingServer.xcode/project.pbxproj \
|
${WRKSRC}/StreamingServer.xcode/project.pbxproj \
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
MD5 (DarwinStreamingSrvr5.5.4-Source.tar) = 0a1b699cd2c3a91fc64d8582320d61a3
|
MD5 (DarwinStreamingSrvr5.5.5-Source.tar.gz) = 2ddc217ce0c8d823f4172f3bb4e6282d
|
||||||
SHA256 (DarwinStreamingSrvr5.5.4-Source.tar) = 26882e3306deeeba93e93a94c763c233770eaa744ac953d6d6b1d3c05c900fe3
|
SHA256 (DarwinStreamingSrvr5.5.5-Source.tar.gz) = 71ade02084bd1602582ccf11b3ce43b46eb7b0039ac593cc9f8a67371b7a16a3
|
||||||
SIZE (DarwinStreamingSrvr5.5.4-Source.tar) = 32829440
|
SIZE (DarwinStreamingSrvr5.5.5-Source.tar.gz) = 21468268
|
||||||
|
|
|
@ -1,25 +0,0 @@
|
||||||
--- APIModules/QTSSReflectorModule/ReflectorStream.cpp.orig Thu Sep 30 23:40:54 2004
|
|
||||||
+++ APIModules/QTSSReflectorModule/ReflectorStream.cpp Sun Jul 10 15:16:15 2005
|
|
||||||
@@ -381,11 +381,11 @@
|
|
||||||
// specified by the source info, we can use that to demultiplex separate broadcasts on
|
|
||||||
// the same port. If the src IP addr is 0, we cannot do this and must dedicate 1 port per
|
|
||||||
// broadcast
|
|
||||||
- fSockets = sSocketPool.GetUDPSocketPair(INADDR_ANY, fStreamInfo.fPort, fStreamInfo.fSrcIPAddr, 0);
|
|
||||||
+ fSockets = sSocketPool.GetUDPSocketPair(fStreamInfo.fDestIPAddr, fStreamInfo.fPort, fStreamInfo.fSrcIPAddr, 0);
|
|
||||||
if ((fSockets == NULL) && fStreamInfo.fSetupToReceive)
|
|
||||||
{
|
|
||||||
fStreamInfo.fPort = 0;
|
|
||||||
- fSockets = sSocketPool.GetUDPSocketPair(INADDR_ANY, fStreamInfo.fPort, fStreamInfo.fSrcIPAddr, 0);
|
|
||||||
+ fSockets = sSocketPool.GetUDPSocketPair(fStreamInfo.fDestIPAddr, fStreamInfo.fPort, fStreamInfo.fSrcIPAddr, 0);
|
|
||||||
}
|
|
||||||
if (fSockets == NULL)
|
|
||||||
return QTSSModuleUtils::SendErrorResponse(inRequest, qtssServerInternal,
|
|
||||||
@@ -1388,7 +1388,7 @@
|
|
||||||
{
|
|
||||||
// Check to see if we need to set the remote RTCP address
|
|
||||||
// for this stream. This will be necessary if the source is unicast.
|
|
||||||
- if ((theRemoteAddr != 0) && (theSender->fStream->fDestRTCPAddr == 0))
|
|
||||||
+ if ((theRemoteAddr != 0) && (theSender->fStream->fDestRTCPAddr == 0) && (thePacket->IsRTCP()))
|
|
||||||
{
|
|
||||||
// If the source is multicast, this shouldn't be necessary
|
|
||||||
Assert(!SocketUtils::IsMulticastIPAddr(theSender->fStream->fStreamInfo.fDestIPAddr));
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- StreamingLoadTool/StreamingLoadTool.cpp.orig Thu May 26 12:36:32 2005
|
|
||||||
+++ StreamingLoadTool/StreamingLoadTool.cpp Sat Feb 10 04:01:06 2007
|
|
||||||
@@ -191,7 +191,7 @@
|
|
||||||
UInt32* theURLIndexArray = NEW UInt32[theURLIndexArraySize];
|
|
||||||
UInt32 theNumURLs = 0;
|
|
||||||
char* controlID = NULL;
|
|
||||||
- char ch = 0;
|
|
||||||
+ int ch = 0;
|
|
||||||
//
|
|
||||||
// Read our command line options
|
|
||||||
while( (ch = getopt(argc, argv, "vf:c:i:d")) != -1 )
|
|
|
@ -148,9 +148,6 @@ etc/streaming/relayconfig.xml-dist
|
||||||
@unexec if cmp -s %D/etc/streaming/streamingserver.xml %D/etc/streaming/streamingserver.xml-dist; then rm -f %D/etc/streaming/streamingserver.xml; fi
|
@unexec if cmp -s %D/etc/streaming/streamingserver.xml %D/etc/streaming/streamingserver.xml-dist; then rm -f %D/etc/streaming/streamingserver.xml; fi
|
||||||
etc/streaming/streamingserver.xml-dist
|
etc/streaming/streamingserver.xml-dist
|
||||||
@exec [ ! -f %B/streamingserver.xml ] && cp %B/%f %B/streamingserver.xml
|
@exec [ ! -f %B/streamingserver.xml ] && cp %B/%f %B/streamingserver.xml
|
||||||
@unexec if cmp -s %D/etc/streaming/streamingloadtool.conf %D/etc/streaming/streamingloadtool.conf-dist; then rm -f %D/etc/streaming/streamingloadtool.conf; fi
|
|
||||||
etc/streaming/streamingloadtool.conf-dist
|
|
||||||
@exec [ ! -f %B/streamingloadtool.conf ] && cp %B/%f %B/streamingloadtool.conf
|
|
||||||
@dirrm %%DATADIR%%/AdminHtml/includes
|
@dirrm %%DATADIR%%/AdminHtml/includes
|
||||||
@dirrm %%DATADIR%%/AdminHtml/images
|
@dirrm %%DATADIR%%/AdminHtml/images
|
||||||
@dirrm %%DATADIR%%/AdminHtml/html_en
|
@dirrm %%DATADIR%%/AdminHtml/html_en
|
||||||
|
|
Loading…
Reference in a new issue