Update to 2008-07-27 snapshot
This commit is contained in:
parent
0f652148a6
commit
a1414ad0e5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=217718
6 changed files with 81 additions and 244 deletions
|
@ -3,11 +3,10 @@
|
|||
# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $Id: Makefile 66 2007-10-09 17:50:49Z buhnux $
|
||||
# $Id: Makefile 77 2008-07-27 21:50:37Z buhnux $
|
||||
|
||||
PORTNAME= ffmpeg
|
||||
DISTVERSION= 2007-10-04
|
||||
PORTREVISION= 4
|
||||
DISTVERSION= 2008-07-27
|
||||
CATEGORIES= multimedia audio ipv6 net
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= ahze
|
||||
|
@ -29,14 +28,9 @@ OPTIONS= AMR_NB "AMR narrowband encoder" off \
|
|||
IPV6 "IPV6 network support" on \
|
||||
LAME "lame MP3 codec" off \
|
||||
LIBA52 "liba52 support" on \
|
||||
OGG "OGG codec" on \
|
||||
OPTIMIZED_CFLAGS "Additional optimizations" off \
|
||||
SDL "SDL support (build ffplay)" off \
|
||||
SWSCALER "Software scaler support" off \
|
||||
THEORA "libtheora support (implies OGG)" on \
|
||||
VHOOK "video hooking" on \
|
||||
VHOOK_FREETYPE2 "drawtext support (implies VHOOK)" off \
|
||||
VHOOK_IMLIB2 "imlib2 support (implies VHOOK)" off \
|
||||
VORBIS "libvorbisenc support (implies OGG)" on \
|
||||
X264 "X.264 codec" on \
|
||||
XVID "XVID codec" off
|
||||
|
@ -44,11 +38,10 @@ OPTIONS= AMR_NB "AMR narrowband encoder" off \
|
|||
.include <bsd.port.pre.mk>
|
||||
|
||||
CONFIGURE_ARGS+=--cc="${CC}" --prefix="${PREFIX}" \
|
||||
--make="${GMAKE}" \
|
||||
--disable-debug \
|
||||
--enable-memalign-hack \
|
||||
--enable-shared \
|
||||
--enable-pp \
|
||||
--enable-postproc \
|
||||
--extra-cflags="${FFMPEG_CFLAGS} -I${LOCALBASE}/include" \
|
||||
--extra-ldflags="-L${LOCALBASE}/lib ${FFMPEG_LDFLAGS}" \
|
||||
--extra-libs="${PTHREAD_LIBS}" \
|
||||
|
@ -100,12 +93,6 @@ FFMPEG_LDFLAGS+= -la52
|
|||
.else
|
||||
CONFIGURE_ARGS+= --disable-liba52
|
||||
.endif
|
||||
## dts
|
||||
#.ifdef(WITH_DTS) || exists(${LOCALBASE}/lib/libdca.a)
|
||||
#LIB_DEPENDS+= dca.0:${PORTSDIR}/multimedia/libdca
|
||||
#CONFIGURE_ARGS+= --enable-libdts
|
||||
#.endif
|
||||
## faac
|
||||
|
||||
.ifdef(WITH_FAAC)
|
||||
LIB_DEPENDS+= faac.0:${PORTSDIR}/audio/faac
|
||||
|
@ -161,14 +148,6 @@ CONFIGURE_ARGS+= --enable-libmp3lame
|
|||
CONFIGURE_ARGS+= --disable-libmp3lame
|
||||
.endif
|
||||
|
||||
## ogg
|
||||
.if !defined(WITHOUT_OGG) || !defined(WITHOUT_VORBIS) || !defined(WITHOUT_THEORA)
|
||||
LIB_DEPENDS+= ogg.5:${PORTSDIR}/audio/libogg
|
||||
CONFIGURE_ARGS+= --enable-libogg
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-libogg
|
||||
.endif
|
||||
|
||||
## SDL
|
||||
.ifdef(WITH_SDL)
|
||||
USE_SDL+= sdl
|
||||
|
@ -180,15 +159,6 @@ MAN1+= ffplay.1
|
|||
CONFIGURE_ARGS+= --disable-ffplay
|
||||
.endif
|
||||
|
||||
## swscaler
|
||||
.if defined(WITH_SWSCALER)
|
||||
CONFIGURE_ARGS+= --enable-swscaler
|
||||
PLIST_SUB+= SWSCAL=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-swscaler
|
||||
PLIST_SUB+= SWSCAL="@comment "
|
||||
.endif
|
||||
|
||||
## theora
|
||||
.if !defined(WITHOUT_THEORA)
|
||||
LIB_DEPENDS+= theora.0:${PORTSDIR}/multimedia/libtheora
|
||||
|
@ -221,31 +191,6 @@ CONFIGURE_ARGS+= --disable-libx264
|
|||
FFMPEG_CFLAGS+= -msse
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_VHOOK) || defined(WITH_VHOOK_FREETYPE2) || defined(WITH_VHOOK_IMLIB2)
|
||||
. ifdef(WITH_VHOOK_FREETYPE2)
|
||||
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
|
||||
PLIST_FILES+= lib/vhook/drawtext.so
|
||||
CONFIGURE_ARGS+= --enable-freetype2
|
||||
. else
|
||||
CONFIGURE_ARGS+= --disable-freetype2
|
||||
. endif # freetype2
|
||||
. ifdef(WITH_VHOOK_IMLIB2)
|
||||
USE_EFL+= imlib2
|
||||
. if !exists(${LOCALBASE}/include/X11/Xlib.h)
|
||||
CFLAGS+= -DX_DISPLAY_MISSING
|
||||
. endif
|
||||
PLIST_FILES+= lib/vhook/imlib2.so
|
||||
CONFIGURE_ARGS+= --enable-imlib2
|
||||
. else
|
||||
CONFIGURE_ARGS+= --disable-imlib2
|
||||
. endif # imlib2
|
||||
CONFIGURE_ARGS+= --enable-vhook
|
||||
PLIST_SUB+= VHOOK=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-vhook
|
||||
PLIST_SUB+= VHOOK="@comment "
|
||||
. endif
|
||||
|
||||
## xvid
|
||||
.ifdef(WITH_XVID)
|
||||
LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
|
||||
|
@ -320,13 +265,6 @@ post-patch:
|
|||
${WRKSRC}/common.mak
|
||||
|
||||
post-configure:
|
||||
#.ifdef(WITH_DTS)
|
||||
# @${REINPLACE_CMD} -E \
|
||||
# -e 's|-ldts|${LOCALBASE}/lib/libdts_pic.a|' \
|
||||
# -e 's|(-lx264)|-L${LOCALBASE}/lib \1|' \
|
||||
# ${WRKSRC}/config.mak \
|
||||
# ${WRKSRC}/libavcodec/Makefile
|
||||
#.endif
|
||||
.ifdef(WITHOUT_THEORA)
|
||||
@${REINPLACE_CMD} -E \
|
||||
-e 's|^(CONFIG_LIBTHEORA).*$$|\1=no|' \
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (ffmpeg-2007-10-04.tar.bz2) = 9ec842daece6479cc92cbc421a008d53
|
||||
SHA256 (ffmpeg-2007-10-04.tar.bz2) = f8aa5a2b85c1ce27a91a4bb0415f01415dfc7e6110476da717ac835193679447
|
||||
SIZE (ffmpeg-2007-10-04.tar.bz2) = 2326718
|
||||
MD5 (ffmpeg-2008-07-27.tar.bz2) = 777351947a51778a165ec0559f827387
|
||||
SHA256 (ffmpeg-2008-07-27.tar.bz2) = 492a20be1a60910aa1fd1538a56f25ef5b0ecbbd588906d4eb28b3a0bcf004ba
|
||||
SIZE (ffmpeg-2008-07-27.tar.bz2) = 2581976
|
||||
|
|
|
@ -1,50 +1,6 @@
|
|||
--- configure.orig 2007-09-29 22:25:06.000000000 +0200
|
||||
+++ configure 2008-03-12 08:59:27.000000000 +0100
|
||||
@@ -211,11 +211,11 @@
|
||||
|
||||
# "tr '[a-z]' '[A-Z]'" is a workaround for Solaris tr not grokking "tr a-z A-Z"
|
||||
toupper(){
|
||||
- echo "$@" | tr '[a-z]' '[A-Z]'
|
||||
+ echo "$@" | tr '[:lower:]' '[:upper:]'
|
||||
}
|
||||
|
||||
tolower(){
|
||||
- echo "$@" | tr '[A-Z]' '[a-z]'
|
||||
+ echo "$@" | tr '[:upper:]' '[:lower:]'
|
||||
}
|
||||
|
||||
set_all(){
|
||||
@@ -604,9 +604,11 @@
|
||||
ffmpeg
|
||||
ffplay
|
||||
ffserver
|
||||
+ freetype2
|
||||
gpl
|
||||
gprof
|
||||
gray
|
||||
+ imlib2
|
||||
ipv6
|
||||
liba52
|
||||
liba52bin
|
||||
@@ -1033,15 +1035,9 @@
|
||||
enable fast_unaligned
|
||||
;;
|
||||
x86_64|amd64)
|
||||
- arch="x86_32"
|
||||
enable fast_unaligned
|
||||
- canon_arch="`$cc -dumpmachine | sed -e 's,\([^-]*\)-.*,\1,'`"
|
||||
- if [ x"$canon_arch" = x"x86_64" -o x"$canon_arch" = x"amd64" ]; then
|
||||
- if [ -z "`echo $CFLAGS | grep -- -m32`" ]; then
|
||||
- arch="x86_64"
|
||||
- enable fast_64bit
|
||||
- fi
|
||||
- fi
|
||||
+ arch="x86_64"
|
||||
+ enable fast_64bit
|
||||
;;
|
||||
# armv4l is a subset of armv[567]*l
|
||||
arm|armv[4567]*l)
|
||||
@@ -1491,8 +1487,8 @@
|
||||
--- configure.orig 2008-07-24 05:53:32.000000000 -0500
|
||||
+++ configure 2008-07-27 17:31:20.767081842 -0500
|
||||
@@ -1596,8 +1596,8 @@
|
||||
|
||||
if check_func dlopen; then
|
||||
ldl=
|
||||
|
@ -54,8 +10,8 @@
|
|||
+ ldl=
|
||||
fi
|
||||
|
||||
check_func fork
|
||||
@@ -1597,10 +1593,17 @@
|
||||
check_func fork
|
||||
@@ -1718,10 +1718,17 @@
|
||||
if enabled vhook; then
|
||||
check_ldflags -rdynamic
|
||||
check_ldflags -export-dynamic
|
||||
|
@ -75,42 +31,17 @@
|
|||
|
||||
##########################################
|
||||
# SDL check
|
||||
@@ -1705,12 +1708,6 @@
|
||||
check_cflags -Os # not all compilers support -Os
|
||||
optimize="small"
|
||||
elif enabled optimize; then
|
||||
- if test -n "`$cc -v 2>&1 | grep xlc`"; then
|
||||
- add_cflags "-O5"
|
||||
- add_ldflags "-O5"
|
||||
- else
|
||||
- add_cflags "-O3"
|
||||
- fi
|
||||
fi
|
||||
@@ -2072,7 +2079,7 @@
|
||||
eval ${name}_VERSION=\$${name}_VERSION_MAJOR.\$${name}_VERSION_MINOR.\$${name}_VERSION_MICRO
|
||||
lcname=$(tolower $name)
|
||||
eval echo "${lcname}_VERSION=\$${name}_VERSION" >> config.mak
|
||||
- eval echo "${lcname}_VERSION_MAJOR=\$${name}_VERSION_MAJOR" >> config.mak
|
||||
+ eval echo "${lcname}_VERSION_MAJOR=1" >> config.mak
|
||||
}
|
||||
|
||||
# PIC flags for shared library objects where they are needed
|
||||
@@ -1894,15 +1891,15 @@
|
||||
if enabled shared; then
|
||||
echo "BUILD_SHARED=yes" >> config.mak
|
||||
echo "PIC=-fPIC -DPIC" >> config.mak
|
||||
- echo "SPPMAJOR=${pp_version%%.*}" >> config.mak
|
||||
+ echo "SPPMAJOR=1" >> config.mak
|
||||
echo "SPPVERSION=$pp_version" >> config.mak
|
||||
- echo "LAVCMAJOR=${lavc_version%%.*}" >> config.mak
|
||||
+ echo "LAVCMAJOR=%%SHLIB_VER%%" >> config.mak
|
||||
echo "LAVCVERSION=$lavc_version" >> config.mak
|
||||
- echo "LAVFMAJOR=${lavf_version%%.*}" >> config.mak
|
||||
+ echo "LAVFMAJOR=%%SHLIB_VER%%" >> config.mak
|
||||
echo "LAVFVERSION=$lavf_version" >> config.mak
|
||||
- echo "LAVUMAJOR=${lavu_version%%.*}" >> config.mak
|
||||
+ echo "LAVUMAJOR=%%SHLIB_VER%%" >> config.mak
|
||||
echo "LAVUVERSION=$lavu_version" >> config.mak
|
||||
- echo "SWSMAJOR=${sws_version%%.*}" >> config.mak
|
||||
+ echo "SWSMAJOR=%%SHLIB_VER%%" >> config.mak
|
||||
echo "SWSVERSION=$sws_version" >> config.mak
|
||||
echo "SLIBNAME=${SLIBNAME}" >> config.mak
|
||||
echo "SLIBNAME_WITH_VERSION=${SLIBNAME_WITH_VERSION}" >> config.mak
|
||||
@@ -1911,7 +1908,7 @@
|
||||
echo "SLIB_INSTALL_EXTRA_CMD=${SLIB_INSTALL_EXTRA_CMD}" >> config.mak
|
||||
get_version LIBSWSCALE libswscale/swscale.h
|
||||
@@ -2096,7 +2103,7 @@
|
||||
echo "SLIB_UNINSTALL_EXTRA_CMD=${SLIB_UNINSTALL_EXTRA_CMD}" >> config.mak
|
||||
fi
|
||||
echo "LIB_INSTALL_EXTRA_CMD=${LIB_INSTALL_EXTRA_CMD}" >> config.mak
|
||||
-echo "EXTRALIBS=$extralibs" >> config.mak
|
||||
|
@ -118,33 +49,3 @@
|
|||
|
||||
print_config ARCH_ $TMPH config.mak $ARCH_LIST
|
||||
print_config HAVE_ $TMPH config.mak $HAVE_LIST
|
||||
@@ -1932,7 +1929,7 @@
|
||||
|
||||
echo "SRC_PATH=\"$source_path\"" >> config.mak
|
||||
echo "SRC_PATH_BARE=$source_path" >> config.mak
|
||||
-echo "BUILD_ROOT=\"$PWD\"" >> config.mak
|
||||
+echo "BUILD_ROOT=\"$(pwd)\"" >> config.mak
|
||||
|
||||
# Apparently it's not possible to portably echo a backslash.
|
||||
enabled asmalign_pot &&
|
||||
@@ -2008,8 +2005,8 @@
|
||||
Version: $version
|
||||
Requires: $requires
|
||||
Conflicts:
|
||||
-Libs: -L\${libdir} $libs
|
||||
-Cflags: -I\${includedir} -I\${includedir}/$include
|
||||
+Libs: -L\${libdir} $libs -L%%LOCALBASE%%/lib
|
||||
+Cflags: -I\${includedir} -I\${includedir}/$include -I%%LOCALBASE%%/include
|
||||
EOF
|
||||
}
|
||||
|
||||
@@ -2032,7 +2029,8 @@
|
||||
Requires: $requires
|
||||
Conflicts:
|
||||
Libs: \${libdir}/${LIBPREF}${shortname}${LIBSUF} $libs
|
||||
-Cflags: -I\${includedir}
|
||||
+Ldflags: -L%%LOCALBASE%%/lib
|
||||
+Cflags: -I\${includedir} -I%%LOCALBASE%%/include
|
||||
EOF
|
||||
}
|
||||
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
--- libavcodec/imgconvert.c.orig Thu May 3 09:07:28 2007
|
||||
+++ libavcodec/imgconvert.c Thu May 3 09:08:25 2007
|
||||
@@ -2319,7 +2319,6 @@
|
||||
}
|
||||
#endif
|
||||
|
||||
-#ifndef CONFIG_SWSCALER
|
||||
/* XXX: always use linesize. Return -1 if not supported */
|
||||
int img_convert(AVPicture *dst, int dst_pix_fmt,
|
||||
const AVPicture *src, int src_pix_fmt,
|
||||
@@ -2561,7 +2560,6 @@
|
||||
avpicture_free(tmp);
|
||||
return ret;
|
||||
}
|
||||
-#endif
|
||||
|
||||
/* NOTE: we scan all the pixels to have an exact information */
|
||||
static int get_alpha_info_pal8(const AVPicture *src, int width, int height)
|
14
multimedia/ffmpeg/files/patch-subdir.mak
Normal file
14
multimedia/ffmpeg/files/patch-subdir.mak
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- subdir.mak.orig 2008-07-27 15:57:37.873013462 -0500
|
||||
+++ subdir.mak 2008-07-27 15:58:54.041106334 -0500
|
||||
@@ -54,9 +54,9 @@
|
||||
|
||||
install-headers::
|
||||
install -d "$(INCINSTDIR)"
|
||||
- install -d "$(LIBDIR)/pkgconfig"
|
||||
+ install -d "$(prefix)/libdata/pkgconfig"
|
||||
install -m 644 $(addprefix "$(SRC_DIR)"/,$(HEADERS)) "$(INCINSTDIR)"
|
||||
- install -m 644 $(BUILD_ROOT)/lib$(NAME)/lib$(NAME).pc "$(LIBDIR)/pkgconfig"
|
||||
+ install -m 644 $(BUILD_ROOT)/lib$(NAME)/lib$(NAME).pc "$(prefix)/libdata/pkgconfig"
|
||||
|
||||
uninstall-libs::
|
||||
-rm -f "$(SHLIBDIR)/$(SLIBNAME_WITH_MAJOR)" \
|
|
@ -1,61 +1,63 @@
|
|||
bin/ffmpeg
|
||||
bin/ffserver
|
||||
@unexec if cmp -s %D/etc/ffserver.conf %D/etc/ffserver.conf-dist; then rm -f %D/etc/ffserver.conf; fi
|
||||
etc/ffserver.conf
|
||||
etc/ffserver.conf-dist
|
||||
include/ffmpeg/adler32.h
|
||||
include/ffmpeg/avcodec.h
|
||||
include/ffmpeg/avformat.h
|
||||
include/ffmpeg/avio.h
|
||||
include/ffmpeg/avstring.h
|
||||
include/ffmpeg/avutil.h
|
||||
include/ffmpeg/base64.h
|
||||
include/ffmpeg/common.h
|
||||
include/ffmpeg/fifo.h
|
||||
include/ffmpeg/integer.h
|
||||
include/ffmpeg/intfloat_readwrite.h
|
||||
include/ffmpeg/log.h
|
||||
include/ffmpeg/lzo.h
|
||||
include/ffmpeg/mathematics.h
|
||||
include/ffmpeg/md5.h
|
||||
include/ffmpeg/mem.h
|
||||
include/ffmpeg/opt.h
|
||||
include/ffmpeg/random.h
|
||||
include/ffmpeg/rational.h
|
||||
include/ffmpeg/rgb2rgb.h
|
||||
include/ffmpeg/rtp.h
|
||||
include/ffmpeg/rtsp.h
|
||||
include/ffmpeg/rtspcodes.h
|
||||
include/ffmpeg/swscale.h
|
||||
include/postproc/postprocess.h
|
||||
include/libavcodec/avcodec.h
|
||||
include/libavcodec/opt.h
|
||||
include/libavdevice/avdevice.h
|
||||
include/libavformat/avformat.h
|
||||
include/libavformat/avio.h
|
||||
include/libavformat/rtsp.h
|
||||
include/libavformat/rtspcodes.h
|
||||
include/libavutil/adler32.h
|
||||
include/libavutil/avstring.h
|
||||
include/libavutil/avutil.h
|
||||
include/libavutil/base64.h
|
||||
include/libavutil/common.h
|
||||
include/libavutil/crc.h
|
||||
include/libavutil/fifo.h
|
||||
include/libavutil/intfloat_readwrite.h
|
||||
include/libavutil/log.h
|
||||
include/libavutil/lzo.h
|
||||
include/libavutil/mathematics.h
|
||||
include/libavutil/md5.h
|
||||
include/libavutil/mem.h
|
||||
include/libavutil/random.h
|
||||
include/libavutil/rational.h
|
||||
include/libavutil/sha1.h
|
||||
include/libpostproc/postprocess.h
|
||||
lib/libavcodec.a
|
||||
lib/libavcodec.so
|
||||
lib/libavcodec.so.%%SHLIB_VER%%
|
||||
lib/libavcodec.so.51.44.0
|
||||
lib/libavcodec.so.1
|
||||
lib/libavcodec.so.51.61.0
|
||||
lib/libavdevice.a
|
||||
lib/libavdevice.so
|
||||
lib/libavdevice.so.1
|
||||
lib/libavdevice.so.52.0.0
|
||||
lib/libavformat.a
|
||||
lib/libavformat.so
|
||||
lib/libavformat.so.%%SHLIB_VER%%
|
||||
lib/libavformat.so.51.14.0
|
||||
lib/libavformat.so.1
|
||||
lib/libavformat.so.52.18.0
|
||||
lib/libavutil.a
|
||||
lib/libavutil.so
|
||||
lib/libavutil.so.%%SHLIB_VER%%
|
||||
lib/libavutil.so.49.5.0
|
||||
lib/libavutil.so.1
|
||||
lib/libavutil.so.49.7.0
|
||||
lib/libpostproc.a
|
||||
lib/libpostproc.so
|
||||
lib/libpostproc.so.%%SHLIB_VER%%
|
||||
lib/libpostproc.so.1
|
||||
lib/libpostproc.so.51.1.0
|
||||
%%SWSCAL%%lib/libswscale.a
|
||||
%%SWSCAL%%lib/libswscale.so
|
||||
%%SWSCAL%%lib/libswscale.so.%%SHLIB_VER%%
|
||||
%%SWSCAL%%lib/libswscale.so.0.5.0
|
||||
%%VHOOK%%lib/vhook/fish.so
|
||||
%%VHOOK%%lib/vhook/null.so
|
||||
%%VHOOK%%lib/vhook/ppm.so
|
||||
%%VHOOK%%lib/vhook/watermark.so
|
||||
lib/vhook/fish.so
|
||||
lib/vhook/null.so
|
||||
lib/vhook/ppm.so
|
||||
lib/vhook/watermark.so
|
||||
libdata/pkgconfig/libavcodec.pc
|
||||
libdata/pkgconfig/libavdevice.pc
|
||||
libdata/pkgconfig/libavformat.pc
|
||||
libdata/pkgconfig/libavutil.pc
|
||||
libdata/pkgconfig/libpostproc.pc
|
||||
libdata/pkgconfig/libswscale.pc
|
||||
@dirrm lib/vhook
|
||||
@dirrm include/postproc
|
||||
@dirrm include/ffmpeg
|
||||
@dirrm include/libpostproc
|
||||
@dirrm include/libavutil
|
||||
@dirrm include/libavformat
|
||||
@dirrm include/libavdevice
|
||||
@dirrm include/libavcodec
|
||||
|
|
Loading…
Reference in a new issue