- Update to 1.96.1
PR: ports/89577 Submitted by: Ports Fury
This commit is contained in:
parent
a88df5c39d
commit
a1430ab625
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=149586
6 changed files with 49 additions and 35 deletions
|
@ -6,29 +6,43 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= gno3dtet
|
PORTNAME= gno3dtet
|
||||||
PORTVERSION= 1.6.4
|
PORTVERSION= 1.96.1
|
||||||
PORTREVISION= 1
|
|
||||||
CATEGORIES= games gnome
|
CATEGORIES= games gnome
|
||||||
MASTER_SITES= ftp://12.206.131.3/pub/gno3dtet/ \
|
MASTER_SITES= http://eseb.net/ftp/gno3dtet/
|
||||||
http://www.eseb.net/ftp/gno3dtet/
|
|
||||||
EXTRACT_SUFX= .tgz
|
EXTRACT_SUFX= .tgz
|
||||||
|
|
||||||
MAINTAINER= ports@FreeBSD.org
|
MAINTAINER= ports@FreeBSD.org
|
||||||
COMMENT= GNOME version of the classic 3D-ified T*tris
|
COMMENT= GNOME version of the classic 3D-ified T*tris
|
||||||
|
|
||||||
USE_REINPLACE= yes
|
EXTRACT_DEPENDS=intltoolize:${PORTSDIR}/textproc/intltool
|
||||||
|
|
||||||
USE_X_PREFIX= yes
|
USE_X_PREFIX= yes
|
||||||
|
USE_GNOME= gnomehack gnomeprefix gnometarget intlhack libgnomeui librsvg2
|
||||||
|
USE_REINPLACE= yes
|
||||||
USE_GMAKE= yes
|
USE_GMAKE= yes
|
||||||
USE_GNOME= gnomeprefix gnomehack gnomelibs
|
USE_AUTOTOOLS= autoheader:259 automake:19 aclocal:19 autoconf:259
|
||||||
USE_AUTOTOOLS= libtool:15
|
ACLOCAL_ARGS= -I m4 -I ${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
|
||||||
|
AUTOMAKE_ARGS= -a -c -f
|
||||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||||
LIBS="-L${LOCALBASE}/lib"
|
LDFLAGS="-L${LOCALBASE}/lib"
|
||||||
|
INSTALLS_OMF= yes
|
||||||
|
|
||||||
|
run-autotools:: run-autotools-aclocal run-autotools-autoheader \
|
||||||
|
run-autotools-automake run-autotools-autoconf
|
||||||
|
|
||||||
|
post-extract:
|
||||||
|
@cd ${WRKSRC} && ${LOCALBASE}/bin/intltoolize -c -f
|
||||||
|
|
||||||
post-patch:
|
post-patch:
|
||||||
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
|
@${REINPLACE_CMD} -e '/LIBTOOL/d ; \
|
||||||
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
|
s|gnome-games|gno3dtet|g' ${WRKSRC}/configure.in
|
||||||
s|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
|
@${REINPLACE_CMD} -e 's|/gnome/help/|/help/|g' \
|
||||||
${WRKSRC}/configure
|
${WRKSRC}/xmldocs.make
|
||||||
|
@${REINPLACE_CMD} -e 's|/gnome/help/|/help/|g ; \
|
||||||
|
s|datadir)/locale|prefix)/share/locale|g' ${WRKSRC}/src/Makefile.am
|
||||||
|
|
||||||
|
pre-configure:
|
||||||
|
@${INSTALL_SCRIPT} ${AUTOMAKE_DIR}/mkinstalldirs ${WRKSRC}
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
${CHOWN} root:games ${PREFIX}/bin/gno3dtet
|
${CHOWN} root:games ${PREFIX}/bin/gno3dtet
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
MD5 (gno3dtet-1.6.4.tgz) = 62c01388996b648c07fc2fe46fb6bca6
|
MD5 (gno3dtet-1.96.1.tgz) = f298fe3306d5938ef843302a31a19713
|
||||||
SHA256 (gno3dtet-1.6.4.tgz) = 3bfc727884d0fb1fd82bef09d161c035017776c577b2e6a27a0da88daf63c200
|
SHA256 (gno3dtet-1.96.1.tgz) = 81988eee8d824962d5d348ae72c5c66bf4e15dc406eac2bce8a76b098709f37b
|
||||||
SIZE (gno3dtet-1.6.4.tgz) = 313454
|
SIZE (gno3dtet-1.96.1.tgz) = 202401
|
||||||
|
|
|
@ -1,10 +0,0 @@
|
||||||
--- gno3dtet/main.cc.orig Thu May 3 12:30:56 2001
|
|
||||||
+++ gno3dtet/main.cc Sat Oct 6 02:07:05 2001
|
|
||||||
@@ -374,6 +374,7 @@
|
|
||||||
textdomain (PACKAGE);
|
|
||||||
|
|
||||||
// init
|
|
||||||
+ setregid(getegid(), -1);
|
|
||||||
gnome_init_with_popt_table (GNO3DTET_EXENAME, GNO3DTET_VERSION,
|
|
||||||
argc, argv, options, 0, NULL);
|
|
||||||
|
|
10
games/gno3dtet/files/patch-src__main.cc
Normal file
10
games/gno3dtet/files/patch-src__main.cc
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- src/main.cc.orig Wed Mar 9 11:07:47 2005
|
||||||
|
+++ src/main.cc Fri Nov 25 23:00:18 2005
|
||||||
|
@@ -375,6 +375,7 @@
|
||||||
|
textdomain (PACKAGE);
|
||||||
|
|
||||||
|
// init
|
||||||
|
+ setregid(getegid(), -1);
|
||||||
|
// gnome_init_with_popt_table (GNO3DTET_EXENAME, GNO3DTET_VERSION, argc, argv, options, 0, NULL);// gnome-1
|
||||||
|
gnome_program_init (GNO3DTET_EXENAME, GNO3DTET_VERSION,
|
||||||
|
LIBGNOMEUI_MODULE,
|
|
@ -1,9 +1,8 @@
|
||||||
Gno3DTet is a funky 3D-ified version of T*tris
|
Gno3DTet is a funky 3D-ified version of T*tris that reminds me of games
|
||||||
that reminds me of games I used to play 10 years
|
I used to play 10 years ago. It'll make for hours of fun if you learn
|
||||||
ago. It'll make for hours of fun if you learn
|
|
||||||
how to move the pieces around right.
|
how to move the pieces around right.
|
||||||
|
|
||||||
WWW: http://gno3dtet.eseb.net/
|
WWW: http://eseb.net/3dtetris.php
|
||||||
Author: Sebastien Nicoud <snicoud@rmi.net>
|
Author: Sebastien Nicoud <seb at eseb.net>
|
||||||
|
|
||||||
--Will <andrews@technologist.com>
|
--Will <andrews@technologist.com>
|
||||||
|
|
|
@ -1,9 +1,9 @@
|
||||||
bin/gno3dtet
|
bin/gno3dtet
|
||||||
share/gnome/apps/Games/gno3dtet.desktop
|
share/gnome/applications/gno3dtet.desktop
|
||||||
share/gnome/games/gno3dtet.hof
|
share/gnome/games/gno3dtet.hof
|
||||||
share/gnome/help/gno3dtet/C/copying.html
|
share/gnome/help/gno3dtet/C/gno3dtet.xml
|
||||||
share/gnome/help/gno3dtet/C/gno3dtet.html
|
share/gnome/help/gno3dtet/C/legal.xml
|
||||||
share/gnome/help/gno3dtet/C/topic.dat
|
share/gnome/omf/gno3dtet/gno3dtet-C.omf
|
||||||
share/gnome/pixmaps/gno3dtet.png
|
share/gnome/pixmaps/gno3dtet.png
|
||||||
share/gnome/sounds/gno3dtet/danger.wav
|
share/gnome/sounds/gno3dtet/danger.wav
|
||||||
share/gnome/sounds/gno3dtet/fall.wav
|
share/gnome/sounds/gno3dtet/fall.wav
|
||||||
|
@ -11,11 +11,12 @@ share/gnome/sounds/gno3dtet/hof.wav
|
||||||
share/gnome/sounds/gno3dtet/land.wav
|
share/gnome/sounds/gno3dtet/land.wav
|
||||||
share/gnome/sounds/gno3dtet/layer.wav
|
share/gnome/sounds/gno3dtet/layer.wav
|
||||||
share/gnome/sounds/gno3dtet/level.wav
|
share/gnome/sounds/gno3dtet/level.wav
|
||||||
share/gnome/sounds/gno3dtet/move.wav
|
|
||||||
share/gnome/sounds/gno3dtet/new.wav
|
share/gnome/sounds/gno3dtet/new.wav
|
||||||
share/gnome/sounds/gno3dtet/pause.wav
|
share/gnome/sounds/gno3dtet/pause.wav
|
||||||
share/gnome/sounds/gno3dtet/score.wav
|
share/gnome/sounds/gno3dtet/score.wav
|
||||||
share/gnome/sounds/gno3dtet/screwd.wav
|
share/gnome/sounds/gno3dtet/screwd.wav
|
||||||
|
share/locale/fr/LC_MESSAGES/gno3dtet.mo
|
||||||
@dirrm share/gnome/sounds/gno3dtet
|
@dirrm share/gnome/sounds/gno3dtet
|
||||||
|
@dirrm share/gnome/omf/gno3dtet
|
||||||
@dirrm share/gnome/help/gno3dtet/C
|
@dirrm share/gnome/help/gno3dtet/C
|
||||||
@dirrm share/gnome/help/gno3dtet
|
@dirrm share/gnome/help/gno3dtet
|
||||||
|
|
Loading…
Reference in a new issue