- Update to 1.7

- Add DOXYGEN option, disabled by default to keep the port slim
- Remove check unsupported FreeBSD versions
- Change tab to space in WWW line
This commit is contained in:
Guido Falsi 2013-03-09 00:39:43 +00:00
parent e8f803659c
commit a1967cec55
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=313682
6 changed files with 31 additions and 35 deletions

View file

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= openobex
PORTVERSION= 1.6
PORTVERSION= 1.7
CATEGORIES= comms net
MASTER_SITES= http://www.hendrik-sattler.de/downloads/${PORTNAME}/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-Source
@ -9,28 +9,22 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-Source
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Open source implementation of the OBEX protocol
USE_GMAKE= yes
USE_CMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomehack
MAKE_JOBS_SAFE= yes
USE_DOS2UNIX= CMakeLists.txt
CMAKE_ARGS+= -DPKGCONFIG_INSTALL_DIR:STRING="${PREFIX}/libdata/pkgconfig"
OPTIONS_DEFINE= USB
USB_DESC= Enable OBEX over USB
OPTIONS_DEFINE= DOXYGEN
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MUSB}
. if ${OSVERSION} < 800069
LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
CFLAGS+= -I${PREFIX}/include
. else
EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure
. endif
CONFIGURE_ARGS+=--enable-usb
.if ${PORT_OPTIONS:MDOXYGEN}
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
PORTDOCS= *
.else
CONFIGURE_ARGS+=--disable-usb
CMAKE_ARGS+= -DBUILD_DOCUMENTATION=OFF
.endif
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (openobex-1.6-Source.tar.gz) = 3dde9deaba9881c45da3dfea69765fdfaec9e1e0e2114bf0add997a688c615f8
SIZE (openobex-1.6-Source.tar.gz) = 712415
SHA256 (openobex-1.7-Source.tar.gz) = 48180469b85c9101ec17e55c9d9f28fafae0a44d5fe6b75c0be26964c5e19cdb
SIZE (openobex-1.7-Source.tar.gz) = 130372

View file

@ -1,14 +0,0 @@
--- configure.orig 2009-03-07 19:35:55.000000000 +0300
+++ configure 2009-03-07 19:36:21.000000000 +0300
@@ -10736,6 +10736,11 @@
USB_LIBS="-lusb"
usb_lib_found=yes
;;
+ *-*-freebsd*)
+ USB_CFLAGS=""
+ USB_LIBS="-lusb"
+ usb_lib_found=yes
+ ;;
*)
pkg_failed=no

View file

@ -0,0 +1,10 @@
--- CMakeLists.txt.orig 2013-03-06 15:11:39.233082623 +0100
+++ CMakeLists.txt 2013-03-06 15:12:33.951078962 +0100
@@ -1,6 +1,6 @@
cmake_minimum_required ( VERSION 2.8.5 FATAL_ERROR )
-project ( openobex C )
+project ( openobex C CXX )
#
# The project version

View file

@ -3,4 +3,4 @@ implementation of the Object Exchange (OBEX) protocol. OBEX is a
session protocol and can best be described as a binary HTTP protocol.
It's used mainly for Infrared and Bluetooth communication.
WWW: http://gitorious.org/openobex/pages/Home
WWW: http://gitorious.org/openobex/pages/Home

View file

@ -1,8 +1,14 @@
include/openobex/obex.h
include/openobex/obex_const.h
lib/libopenobex.so.2
lib/libopenobex.a
lib/libopenobex.la
include/openobex/version.h
lib/cmake/OpenObex-1.7/openobex-target-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/OpenObex-1.7/openobex-config-version.cmake
lib/cmake/OpenObex-1.7/openobex-target.cmake
lib/cmake/OpenObex-1.7/openobex-config.cmake
lib/libopenobex.so
lib/libopenobex.so.1.7
lib/libopenobex.so.2
libdata/pkgconfig/openobex.pc
@dirrm include/openobex
@dirrm lib/cmake/OpenObex-1.7
@dirrmtry lib/cmake