Add new port: misc/binclock: A small CLI binary clock
PR: 207406 Submitted by: dereckson@espace-win.org (maintainer) Reviewed by: riggs
This commit is contained in:
parent
e4834cfc5b
commit
a1ca5fa19e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=412060
5 changed files with 58 additions and 0 deletions
|
@ -23,6 +23,7 @@
|
|||
SUBDIR += bestfit
|
||||
SUBDIR += bibletime
|
||||
SUBDIR += biblical-curse
|
||||
SUBDIR += binclock
|
||||
SUBDIR += biosfont-demos
|
||||
SUBDIR += birthday
|
||||
SUBDIR += bogosort
|
||||
|
|
30
misc/binclock/Makefile
Normal file
30
misc/binclock/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# Created by: Dereckson <dereckson@gmail.com>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= binclock
|
||||
DISTVERSION= 1.5
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://www.ngolde.de/download/
|
||||
|
||||
MAINTAINER= dereckson@gmail.com
|
||||
COMMENT= CLI binary clock
|
||||
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
PORTDOCS= README
|
||||
PLIST_FILES= bin/binclock etc/binclockrc man/man1/binclock.1.gz
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/binclock ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_DATA} ${WRKSRC}/binclockrc ${STAGEDIR}${PREFIX}/etc
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/binclock.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/binclock
|
||||
|
||||
do-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
2
misc/binclock/distinfo
Normal file
2
misc/binclock/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (binclock-1.5.tar.gz) = 3b34033aef01771235e87848ddc92ef23dc2c989902f2ea1cb652b91e43f3df5
|
||||
SIZE (binclock-1.5.tar.gz) = 12301
|
19
misc/binclock/files/patch-Makefile
Normal file
19
misc/binclock/files/patch-Makefile
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- Makefile.orig 2004-07-24 16:13:19 UTC
|
||||
+++ Makefile
|
||||
@@ -18,8 +18,6 @@
|
||||
# Boston, MA 02111-1307, USA
|
||||
#
|
||||
|
||||
-CC = gcc
|
||||
-CFLAGS = -O2 -Wall --pedantic
|
||||
BIN = binclock
|
||||
SRC = ./src/binclock.c
|
||||
INSPATH = /usr/local/bin/
|
||||
@@ -29,7 +27,6 @@ CONF = /etc/
|
||||
|
||||
all : $(MAINSRC)
|
||||
$(CC) $(CFLAGS) -o $(BIN) $(SRC)
|
||||
- strip $(SOURCEPATH)$(BIN)
|
||||
|
||||
install :
|
||||
|
6
misc/binclock/pkg-descr
Normal file
6
misc/binclock/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
Binary clock to display time in binary format.
|
||||
|
||||
It supports showing the time with eight different colors,
|
||||
and it can run a loop that prints the time every second.
|
||||
|
||||
WWW: http://www.ngolde.de/binclock.html
|
Loading…
Reference in a new issue