Try to fix the remaining dependencies and

back out previous commit.

Also add a FUSE dependency to fix a soft error.

Submitted by:	kan
This commit is contained in:
Martin Blapp 2009-04-06 22:56:31 +00:00
parent e5b1369b34
commit a29d378944
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=231753
3 changed files with 27 additions and 3 deletions

View file

@ -39,12 +39,21 @@ CONFIGURE_ARGS+= --disable-unity
CONFIGURE_ARGS+= --with-x --without-gtkmm
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include"
USE_XORG= x11 xextproto ice xext xineramaproto xinerama xrandr xrender xtst
USE_XORG= x11 ice sm xext xineramaproto xinerama xrandr xrender \
xtst
USE_GNOME= gtk20 glib20
PLIST_SUB+= X11=""
CONFLICTS= open-vm-tools-nox11-[0-9]*
.endif
.if !defined(WITHOUT_FUSE)
LIB_DEPENDS+= fuse.2:${PORTSDIR}/sysutils/fusefs-libs
RUN_DEPENDS+= mount_fusefs:${PORTSDIR}/sysutils/fusefs-kmod
PLIST_SUB+= FUSE=""
.else
PLIST_SUB+= FUSE="@comment "
.endif
CONFLICTS+= vmware-guestd[0-9]* vmware-tools[0-9]*
SUB_FILES= pkg-message

View file

@ -0,0 +1,15 @@
--- hgfsmounter/Makefile.in.orig 2009-04-06 17:24:30.000000000 -0400
+++ hgfsmounter/Makefile.in 2009-04-06 17:26:09.000000000 -0400
@@ -558,9 +558,9 @@
@FREEBSD_TRUE@ mv $(DESTDIR)$(sbindir)/mount.vmhgfs \
@FREEBSD_TRUE@ $(DESTDIR)$(sbindir)/mount_vmhgfs
@FREEBSD_TRUE@@WITH_ROOT_PRIVILEGES_TRUE@ chmod u+s $(DESTDIR)$(sbindir)/mount_vmhgfs
-@FREEBSD_TRUE@ -$(MKDIR_P) $(DESTDIR)/sbin
-@FREEBSD_TRUE@ -$(LN_S) $(DESTDIR)$(sbindir)/mount_vmhgfs \
-@FREEBSD_TRUE@ $(DESTDIR)/sbin/mount_vmhgfs &> /dev/null
+#@FREEBSD_TRUE@ -$(MKDIR_P) $(DESTDIR)/sbin
+#@FREEBSD_TRUE@ -$(LN_S) $(DESTDIR)$(sbindir)/mount_vmhgfs \
+#@FREEBSD_TRUE@ $(DESTDIR)/sbin/mount_vmhgfs &> /dev/null
@FREEBSD_TRUE@uninstall-hook:
@FREEBSD_TRUE@ rm -f $(DESTDIR)$(sbindir)/mount_vmhgfs
@FREEBSD_FALSE@install-exec-hook:

View file

@ -1,10 +1,10 @@
bin/vmware-checkvm
bin/vmware-hgfsclient
bin/vmware-rpctool
bin/vmware-xferlogs
bin/vmtoolsd
bin/vmware-toolbox-cmd
bin/vmware-vmblock-fuse
etc/vmware-tools/tools.conf
%%FUSE%%bin/vmware-vmblock-fuse
lib/open-vm-tools/plugins/vmsvc/libguestInfo.so
lib/open-vm-tools/plugins/vmsvc/libhgfsServer.so
lib/open-vm-tools/plugins/vmsvc/libpowerOps.so