add py-matplotlib 0.60.2

A plotting library uses a syntax familiar to matlab users
This commit is contained in:
Ying-Chieh Liao 2004-08-04 03:32:14 +00:00
parent 32c6373e09
commit a32773c0d0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=115377
6 changed files with 94 additions and 0 deletions

View file

@ -365,6 +365,7 @@
SUBDIR += py-imaging
SUBDIR += py-imaging-handbook
SUBDIR += py-magick
SUBDIR += py-matplotlib
SUBDIR += py-ming
SUBDIR += py-opengl
SUBDIR += py-paint

View file

@ -0,0 +1,53 @@
# ex:ts=8
# Ports collection makefile for: py-matplotlib
# Date created: Aug 4, 2004
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= matplotlib
PORTVERSION= 0.60.2
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= A plotting library uses a syntax familiar to matlab users
BUILD_DEPENDS= ${PYNUMERIC} \
${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
${LOCALBASE}/lib/libagg.a:${PORTSDIR}/graphics/agg
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
RUN_DEPENDS= ${PYNUMERIC} \
${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
USE_PYTHON= 2.2+
USE_PYDISTUTILS= yes
USE_GNOME= gtk20 pygtk2
CFLAGS+= -I${X11BASE}/include
DATADIR= ${PREFIX}/share/py-${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
PLISTDIR= ${PYTHON_SITELIBDIR}/${PORTNAME} ${DATADIR}
.if !defined(NOPORTDOCS)
PLISTDIR+= ${EXAMPLESDIR}
.endif
.include <bsd.port.pre.mk>
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
.endif
.for dir in ${PLISTDIR}
@${FIND} ${dir} ! -type d | \
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${dir} -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.endfor
.include <bsd.port.post.mk>

View file

@ -0,0 +1,2 @@
MD5 (matplotlib-0.60.2.tar.gz) = e4d28311bd5457039a8ff7d26028c6d5
SIZE (matplotlib-0.60.2.tar.gz) = 1533161

View file

@ -0,0 +1,11 @@
--- setup.py.orig Wed Aug 4 11:22:03 2004
+++ setup.py Wed Aug 4 11:22:48 2004
@@ -66,7 +66,7 @@
data.extend(glob.glob('images/*.ppm'))
data.append('.matplotlibrc')
-data_files=[('share/matplotlib', data),]
+data_files=[('share/py-matplotlib', data),]
cxx = glob.glob('CXX/*.cxx')
cxx.extend(glob.glob('CXX/*.c'))

View file

@ -0,0 +1,19 @@
--- setupext.py.orig Fri Jul 9 19:51:16 2004
+++ setupext.py Wed Aug 4 10:57:03 2004
@@ -37,6 +37,7 @@
'linux' : ['/usr/local', '/usr',],
'darwin' : [os.getenv('MPLIB_BASE') or '/usr/local', '/usr', '/sw'],
'freebsd4' : [os.getenv('MBLIB_BASE') or '/usr/local', '/usr'],
+ 'freebsd5' : [os.getenv('MBLIB_BASE') or '/usr/local', '/usr'],
'sunos5' : [os.getenv('MPLIB_BASE') or '/usr/local',],
}
@@ -220,7 +221,7 @@
else:
module.include_dirs.extend([o.tcl_inc, o.tk_inc])
module.library_dirs.extend([o.tcl_lib, o.tk_lib])
- module.libraries.extend(['tk'+o.tkv, 'tcl'+o.tkv])
+ module.libraries.extend(['tk84', 'tcl84'])
def add_windowing_flags(module):

View file

@ -0,0 +1,8 @@
matplotlib is a python 2D plotting library which produces publication quality
figures using in a variety of hardcopy formats (PNG, JPG, PS, SVG) and
interactive GUI environments (WX, GTK, Tkinter) across platforms. matplotlib
can be used in python scripts, interactively from the python shell (ala matlab
or mathematica), in web application servers generating dynamic charts, or
embedded in GTK, Tk or WX applications; see backends.
WWW: http://matplotlib.sourceforge.net/