upgrade to 5.5.2
This commit is contained in:
parent
172953c754
commit
a32c97b070
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=75705
6 changed files with 9 additions and 94 deletions
|
@ -7,7 +7,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= autogen
|
||||
PORTVERSION= 5.4.7
|
||||
PORTVERSION= 5.5.2
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
${MASTER_SITE_GNU}
|
||||
|
@ -20,9 +20,11 @@ LIB_DEPENDS= guile.10:${PORTSDIR}/lang/guile \
|
|||
|
||||
USE_REINPLACE= yes
|
||||
USE_GMAKE= yes
|
||||
GUILE_CONFIG?= ${LOCALBASE}/bin/guile-config
|
||||
XML2_CONFIG?= ${LOCALBASE}/bin/xml2-config
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ARGS= --with-libguile=${LOCALBASE} --with-libxml2=${LOCALBASE}
|
||||
CONFIGURE_ARGS= --with-libguile=yes --with-libxml2=yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= autogen.1 autoopts-config.1 columns.1 getdefs.1 xml2ag.1
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (autogen-5.4.7.tar.gz) = fc936fb5e9908370f2a26d03bbeaf6c6
|
||||
MD5 (autogen-5.5.2.tar.gz) = bfc456a8850038042f03ee48c3b7f6c8
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- autoopts/Makefile.in.orig Mon Oct 14 04:22:43 2002
|
||||
+++ autoopts/Makefile.in Tue Oct 15 21:45:17 2002
|
||||
@@ -117,7 +117,7 @@
|
||||
DISTCLEANFILES = option*.3 libopts.????
|
||||
MAINTAINERCLEANFILES = Makefile.in
|
||||
|
||||
-INCLUDES = @INCLIST@
|
||||
+INCLUDES = @INCLIST@ @GUILE_CPPFLAGS@
|
||||
GENMAN = optionFree.3 optionLoadLine.3 optionProcess.3 optionRestore.3 \
|
||||
optionSaveFile.3 optionSaveState.3 optionVersion.3
|
||||
|
||||
@@ -148,7 +148,7 @@
|
||||
|
||||
libopts_la_SOURCES = $(HDRS) $(CSRC)
|
||||
|
||||
-libopts_la_LIBADD = ../snprintfv/snprintfv/libsnprintfvc.la
|
||||
+libopts_la_LIBADD = ../snprintfv/snprintfv/libsnprintfvc.la @GUILE_LDFLAGS@
|
||||
libopts_la_LDFLAGS = -version-info @AO_CURRENT@:@AO_REVISION@:@AO_AGE@
|
||||
|
||||
libguileopts_la_SOURCES = guileopt.c
|
|
@ -1,32 +1,6 @@
|
|||
--- config/ltmain.sh.orig Fri Feb 22 03:19:44 2002
|
||||
+++ config/ltmain.sh Tue Apr 2 02:40:21 2002
|
||||
@@ -1043,14 +1043,14 @@
|
||||
# These systems don't actually have a C library (as such)
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
esac
|
||||
elif test "X$arg" = "X-lc_r"; then
|
||||
case $host in
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc_r directly, use -pthread flag.
|
||||
continue
|
||||
;;
|
||||
@@ -2441,7 +2441,7 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
;;
|
||||
*)
|
||||
@@ -4210,10 +4210,12 @@
|
||||
--- config/ltmain.sh.orig Mon Feb 17 22:59:26 2003
|
||||
+++ config/ltmain.sh Mon Feb 17 23:00:06 2003
|
||||
@@ -4280,10 +4280,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
|
|
|
@ -1,41 +0,0 @@
|
|||
--- snprintfv/config/ltmain.sh.orig Fri Feb 22 03:19:44 2002
|
||||
+++ snprintfv/config/ltmain.sh Tue Apr 2 02:41:01 2002
|
||||
@@ -1043,14 +1043,14 @@
|
||||
# These systems don't actually have a C library (as such)
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
esac
|
||||
elif test "X$arg" = "X-lc_r"; then
|
||||
case $host in
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc_r directly, use -pthread flag.
|
||||
continue
|
||||
;;
|
||||
@@ -2441,7 +2441,7 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
;;
|
||||
*)
|
||||
@@ -4210,10 +4210,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
|
@ -23,7 +23,7 @@ share/autogen/conftest.tpl
|
|||
share/autogen/fsm-macro.tpl
|
||||
share/autogen/fsm-trans.tpl
|
||||
share/autogen/fsm.tpl
|
||||
share/autogen/libopts-18.4.9.tar.gz
|
||||
share/autogen/libopts-18.6.9.tar.gz
|
||||
share/autogen/optcode.tpl
|
||||
share/autogen/opthead.tpl
|
||||
share/autogen/options.tpl
|
||||
|
|
Loading…
Reference in a new issue