Add ruby-gimp, a Ruby extension library to write GIMP plugins in Ruby
(Ruby-Fu).
This commit is contained in:
parent
acb5e2671b
commit
a33d2d9ef6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=38903
9 changed files with 111 additions and 0 deletions
|
@ -178,6 +178,7 @@
|
|||
SUBDIR += ruby-gd
|
||||
SUBDIR += ruby-gdk_imlib
|
||||
SUBDIR += ruby-gdk_pixbuf
|
||||
SUBDIR += ruby-gimp
|
||||
SUBDIR += ruby-libpng
|
||||
SUBDIR += ruby-ming
|
||||
SUBDIR += ruby-opengl
|
||||
|
|
45
graphics/ruby-gimp/Makefile
Normal file
45
graphics/ruby-gimp/Makefile
Normal file
|
@ -0,0 +1,45 @@
|
|||
# New ports collection makefile for: ruby-gimp
|
||||
# Date created: 28 February 2001
|
||||
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gimp
|
||||
PORTVERSION= 20000227
|
||||
CATEGORIES= graphics ruby
|
||||
MASTER_SITES= http://homepage1.nifty.com/susho/software/gimp/
|
||||
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
|
||||
DISTNAME= ruby-${PORTNAME}-snapshot-${PORTVERSION}
|
||||
DIST_SUBDIR= ruby
|
||||
|
||||
MAINTAINER= knu@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gimp.1:${.CURDIR}/../gimp1
|
||||
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk.so:${PORTSDIR}/x11-toolkits/ruby-gtk
|
||||
|
||||
USE_RUBY= yes
|
||||
USE_RUBY_EXTCONF= yes
|
||||
|
||||
WRKSRC= ${WRKDIR}/ruby-${PORTNAME}
|
||||
INSTALL_TARGET= site-install
|
||||
PLIST_SUB= X11BASE="${X11BASE}"
|
||||
|
||||
DOCS_EN= ENVIRONMENT \
|
||||
README \
|
||||
TODO
|
||||
DOCS_JA= MEMO.ja
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/plug-ins/*.rb ${X11BASE}/libexec/gimp/1.2/plug-ins/
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
|
||||
.for f in ${DOCS_EN}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
|
||||
.endfor
|
||||
.for f in ${DOCS_JA}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/ja/
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/ruby-gimp/distinfo
Normal file
1
graphics/ruby-gimp/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (ruby/ruby-gimp-snapshot-20000227.tar.gz) = a0a6f1d1a746f886bcab3cc9ea3e6a66
|
12
graphics/ruby-gimp/files/patch-gimp::extconf.rb
Normal file
12
graphics/ruby-gimp/files/patch-gimp::extconf.rb
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- gimp/extconf.rb.orig Fri Feb 23 04:53:23 2001
|
||||
+++ gimp/extconf.rb Wed Feb 28 22:43:04 2001
|
||||
@@ -2,8 +2,8 @@
|
||||
require '../mkmf_gimp.rb'
|
||||
|
||||
$CFLAGS += ' ' + GimpConfig::CFLAGS
|
||||
+$LDFLAGS += ' ' + GimpConfig::LDFLAGS
|
||||
|
||||
if have_gimp_library("gimp", "gimp_main") and have_header("libgimp/gimp.h")
|
||||
-# $LDFLAGS += ' ' + GimpConfig::LDFLAGS
|
||||
create_makefile("gimp")
|
||||
end
|
13
graphics/ruby-gimp/files/patch-gimpui::extconf.rb
Normal file
13
graphics/ruby-gimp/files/patch-gimpui::extconf.rb
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- gimpui/extconf.rb.orig Fri Feb 23 04:55:36 2001
|
||||
+++ gimpui/extconf.rb Wed Feb 28 22:42:45 2001
|
||||
@@ -2,9 +2,8 @@
|
||||
require '../mkmf_gimp.rb'
|
||||
|
||||
$CFLAGS += ' ' + GimpConfig::CFLAGS
|
||||
-$LDFLAGS += ' -lgimp'
|
||||
+$LDFLAGS += ' ' + GimpConfig::LDFLAGS
|
||||
|
||||
if have_gimp_library("gimpui", "gimp_ui_init") and have_header("libgimp/gimpui.h")
|
||||
-# $LDFLAGS += ' ' + GimpConfig::LDFLAGS
|
||||
create_makefile("gimpui")
|
||||
end
|
11
graphics/ruby-gimp/files/patch-plug-ins::eval.rb
Normal file
11
graphics/ruby-gimp/files/patch-plug-ins::eval.rb
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- plug-ins/eval.rb.orig Tue Feb 27 20:08:13 2001
|
||||
+++ plug-ins/eval.rb Thu Mar 1 01:29:43 2001
|
||||
@@ -13,7 +13,7 @@
|
||||
"",
|
||||
[
|
||||
[RF_STRING, "code", "Code to eval", "", true],
|
||||
- ],
|
||||
+ ]
|
||||
) { |text|
|
||||
eval(text)
|
||||
}
|
1
graphics/ruby-gimp/pkg-comment
Normal file
1
graphics/ruby-gimp/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Ruby extension library to write GIMP plugins in Ruby (Ruby-Fu)
|
4
graphics/ruby-gimp/pkg-descr
Normal file
4
graphics/ruby-gimp/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
This is a Ruby extension library to write GIMP plugins in Ruby. (Ruby-Fu)
|
||||
|
||||
Author: Masahiro Sakai <zvm01052@nifty.ne.jp>
|
||||
WWW: http://homepage1.nifty.com/susho/software/index.en.html#Gimp-Ruby
|
23
graphics/ruby-gimp/pkg-plist
Normal file
23
graphics/ruby-gimp/pkg-plist
Normal file
|
@ -0,0 +1,23 @@
|
|||
%%RUBY_SITEARCHLIBDIR%%/gimp.so
|
||||
%%RUBY_SITEARCHLIBDIR%%/gimpui.so
|
||||
%%RUBY_SITELIBDIR%%/gimp.rb
|
||||
%%RUBY_SITELIBDIR%%/gimpenums.rb
|
||||
%%RUBY_SITELIBDIR%%/gimpfu.rb
|
||||
%%RUBY_SITELIBDIR%%/gimpshelf.rb
|
||||
%%RUBY_SITELIBDIR%%/gimpui.rb
|
||||
%%PORTDOCS%%%%RUBY_DOCDIR%%/gimp/TODO
|
||||
%%PORTDOCS%%%%RUBY_DOCDIR%%/gimp/README
|
||||
%%PORTDOCS%%%%RUBY_DOCDIR%%/gimp/ENVIRONMENT
|
||||
%%PORTDOCS%%%%RUBY_DOCDIR%%/gimp/ja/MEMO.ja
|
||||
%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gimp/ja
|
||||
%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gimp
|
||||
@cwd %%X11BASE%%
|
||||
libexec/gimp/1.2/plug-ins/clothify.rb
|
||||
libexec/gimp/1.2/plug-ins/coolmetal-logo.rb
|
||||
libexec/gimp/1.2/plug-ins/erase-rows.rb
|
||||
libexec/gimp/1.2/plug-ins/eval.rb
|
||||
libexec/gimp/1.2/plug-ins/list_images.rb
|
||||
libexec/gimp/1.2/plug-ins/raindrop.rb
|
||||
libexec/gimp/1.2/plug-ins/rendermap.rb
|
||||
libexec/gimp/1.2/plug-ins/sphere.rb
|
||||
libexec/gimp/1.2/plug-ins/textured-logo.rb
|
Loading…
Reference in a new issue