irc/quassel: Update to 0.12.5
Changes this release: https://quassel-irc.org/node/130 MFH: 2018Q2 Security: https://vuxml.freebsd.org/freebsd/499f6b41-58db-4f98-b8e7-da8c18985eda.html
This commit is contained in:
parent
792effce25
commit
a34529e2ac
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=468336
5 changed files with 4 additions and 43 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= quassel
|
||||
PORTVERSION= 0.12.4
|
||||
PORTREVISION= 7
|
||||
PORTVERSION= 0.12.5
|
||||
CATEGORIES= irc
|
||||
MASTER_SITES= http://www.quassel-irc.org/pub/
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1467574566
|
||||
SHA256 (quassel-0.12.4.tar.bz2) = 93e4e54cb3743cbe2e5684c2fcba94fd2bc2cd739f7672dee14341b49c29444d
|
||||
SIZE (quassel-0.12.4.tar.bz2) = 3742639
|
||||
TIMESTAMP = 1524642412
|
||||
SHA256 (quassel-0.12.5.tar.bz2) = 1894574dfd79654152a5b7427e7df592b055ae908230504f98a4cb48961e74e2
|
||||
SIZE (quassel-0.12.5.tar.bz2) = 3747392
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
From 4768c9e99f99b581d4e32e797db91d0182391696 Mon Sep 17 00:00:00 2001
|
||||
From: martin <martin.sandsmark@kde.org>
|
||||
Date: Tue, 7 Jun 2016 00:37:22 +0200
|
||||
Subject: [PATCH] Fix the SSL check with Qt 5.6 and GCC 5 (#199)
|
||||
|
||||
--- CMakeLists.txt.orig 2016-04-24 20:36:58 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -428,6 +428,11 @@ endif()
|
||||
cmake_push_check_state(RESET)
|
||||
set(CMAKE_REQUIRED_INCLUDES ${QT_INCLUDES} ${Qt5Core_INCLUDE_DIRS})
|
||||
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
|
||||
+
|
||||
+if (USE_QT5 AND Qt5_POSITION_INDEPENDENT_CODE)
|
||||
+ set(CMAKE_REQUIRED_FLAGS "-fPIC -DQT_NO_VERSION_TAGGING")
|
||||
+endif()
|
||||
+
|
||||
check_cxx_source_compiles("
|
||||
#include \"qglobal.h\"
|
||||
#if defined QT_NO_SSL
|
|
@ -1,15 +0,0 @@
|
|||
--- icons/CMakeLists.txt.orig 2015-04-23 20:47:17 UTC
|
||||
+++ icons/CMakeLists.txt
|
||||
@@ -30,7 +30,6 @@ if (WANT_MONO OR WANT_QTCLIENT)
|
||||
endif()
|
||||
|
||||
set(CLIENT_RCS ${CLIENT_RCS} ${ICON_RCS} PARENT_SCOPE)
|
||||
-endif()
|
||||
|
||||
# Application icon
|
||||
|
||||
@@ -40,3 +39,4 @@ if (HAVE_KDE OR (UNIX AND NOT APPLE))
|
||||
install(FILES hicolor/48x48/apps/quassel.png DESTINATION /usr/share/pixmaps)
|
||||
endif()
|
||||
endif()
|
||||
+endif()
|
|
@ -382,15 +382,12 @@ share/icons/hicolor/scalable/status/irc-channel-parted.svgz
|
|||
%%NLS%%%%DATADIR%%/translations/en_US.qm
|
||||
%%NLS%%%%DATADIR%%/translations/eo.qm
|
||||
%%NLS%%%%DATADIR%%/translations/es.qm
|
||||
%%NLS%%%%DATADIR%%/translations/es_AR.qm
|
||||
%%NLS%%%%DATADIR%%/translations/et.qm
|
||||
%%NLS%%%%DATADIR%%/translations/et_EE.qm
|
||||
%%NLS%%%%DATADIR%%/translations/fi.qm
|
||||
%%NLS%%%%DATADIR%%/translations/fr.qm
|
||||
%%NLS%%%%DATADIR%%/translations/gl.qm
|
||||
%%NLS%%%%DATADIR%%/translations/hi.qm
|
||||
%%NLS%%%%DATADIR%%/translations/hu.qm
|
||||
%%NLS%%%%DATADIR%%/translations/id_ID.qm
|
||||
%%NLS%%%%DATADIR%%/translations/it.qm
|
||||
%%NLS%%%%DATADIR%%/translations/ja.qm
|
||||
%%NLS%%%%DATADIR%%/translations/ko.qm
|
||||
|
@ -411,6 +408,5 @@ share/icons/hicolor/scalable/status/irc-channel-parted.svgz
|
|||
%%NLS%%%%DATADIR%%/translations/sv.qm
|
||||
%%NLS%%%%DATADIR%%/translations/tr.qm
|
||||
%%NLS%%%%DATADIR%%/translations/uk.qm
|
||||
%%NLS%%%%DATADIR%%/translations/uz@Latn.qm
|
||||
%%NLS%%%%DATADIR%%/translations/zh_CN.qm
|
||||
%%NLS%%%%DATADIR%%/translations/zh_TW.qm
|
||||
|
|
Loading…
Reference in a new issue