Update to 0.12.0.

This commit is contained in:
Joe Marcus Clarke 2009-03-21 18:36:50 +00:00
parent d9718ef024
commit a34abc45ef
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=230595
4 changed files with 38 additions and 82 deletions

View file

@ -3,12 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
# $MCom: ports/audio/rhythmbox/Makefile,v 1.93 2009/01/10 01:59:21 mezz Exp $
# $MCom$
#
PORTNAME= rhythmbox
PORTVERSION= 0.10.1
PORTREVISION= 11
PORTVERSION= 0.12.0
CATEGORIES= audio gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@ -17,11 +16,12 @@ MAINTAINER= marcus@FreeBSD.org
COMMENT= Audio player for GNOME
LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
musicbrainz3.6:${PORTSDIR}/audio/libmusicbrainz3 \
id3tag.0:${PORTSDIR}/audio/libid3tag \
totem-plparser.12:${PORTSDIR}/multimedia/totem-pl-parser \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
sexy.2:${PORTSDIR}/x11-toolkits/libsexy \
soup-2.2.8:${PORTSDIR}/devel/libsoup22 \
soup-2.4.1:${PORTSDIR}/devel/libsoup \
gnome-media-profiles.0:${PORTSDIR}/audio/gnome-media
USE_BZIP2= yes
@ -32,7 +32,7 @@ USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui nautiluscdburner
WANT_GNOME= yes
USE_GSTREAMER= flac mp3 gnomevfs gconf jpeg
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --enable-nautilus-menu --with-playback=gstreamer-0-10
CONFIGURE_ARGS= --disable-vala
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
CONFIGURE_ENV= LIBS="-lm" \
@ -46,10 +46,9 @@ OPTIONS= DAAP "Enable iTunes music sharing" off \
FAAD "Enable FAAD decoder support" off \
NOTIFY "Enable libnotify support" on \
VORBIS "Enable Ogg/Vorbis support" on \
LIRC "Enable Infrared syncing support" off
# GDA "Enable GDA database storage" off
CONFLICTS= rhythmbox-0.11.[0-9]*
LIRC "Enable Infrared syncing support" off \
MTP "Enable MS Media Transfer Protocol support" off \
GECKO_PLUGIN "Enable iTunes browser plugin" on
.include <bsd.port.pre.mk>
@ -63,13 +62,6 @@ CONFIGURE_ARGS+= --disable-vorbis --disable-vorbistest
USE_GSTREAMER+= faad
.endif
#.if defined(WITH_GDA)
#USE_GNOME+= libgda2
#CONFIGURE_ARGS+=--with-database=libgda
#.else
CONFIGURE_ARGS+=--with-database=tree
#.endif
.if defined(WITH_LIRC)
LIB_DEPENDS+= lirc_client.1:${PORTSDIR}/comms/lirc
PLIST_SUB+= LIRC=""
@ -79,6 +71,15 @@ CONFIGURE_ARGS+=--disable-lirc
PLIST_SUB+= LIRC="@comment "
.endif
.if defined(WITH_MTP)
LIB_DEPENDS+= mtp.8:${PORTSDIR}/audio/libmtp
PLIST_SUB+= MTP=""
CONFIGURE_ARGS+= --with-mtp
.else
CONFIGURE_ARGS+= --without-mtp
PLIST_SUB+= MTP="@comment "
.endif
.if defined(WITH_DAAP)
CONFIGURE_ARGS+= --enable-daap --with-mdns=avahi
LIB_DEPENDS+= avahi-client:${PORTSDIR}/net/avahi-app \
@ -99,10 +100,10 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/notification-daemon:${PORTSDIR}/deskutils/no
CONFIGURE_ARGS+= --disable-libnotify
.endif
.if ${HAVE_GNOME:Mpygtk2}!=""
.if exists(${LOCALBASE}/libdata/pkgconfig/gst-python-0.10.pc)
USE_PYTHON= yes
.include "${PORTSDIR}/Mk/bsd.python.mk"
USE_GNOME+= pygtk2
USE_GSTREAMER+= python
CONFIGURE_ARGS+=--enable-python
PLIST_SUB+= PYTHON=""
.else
@ -119,4 +120,20 @@ CONFIGURE_ARGS+=--without-ipod
PLIST_SUB+= IPOD="@comment "
.endif
.if !defined(WITHOUT_GECKO_PLUGIN)
USE_GECKO= firefox mozilla seamonkey xulrunner<->firefox firefox-devel<->firefox
.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
USE_WEBPLUGINS= gecko18
WEBPLUGINS_FILES=librhythmbox-itms-detection-plugin.so
.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
CONFIGURE_ARGS+=--enable-browser-plugin
CONFIGURE_ENV+= MOZILLA_PLUGINDIR=${WEBPLUGINS_DIR}
PLIST_SUB+= GECKO_PLUGIN=""
.else
CONFIGURE_ARGS+=--disable-browser-plugin
PLIST_SUB+= GECKO_PLUGIN="@comment "
.endif
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
MD5 (gnome2/rhythmbox-0.10.1.tar.bz2) = 6ab510d54654d2973f91b5d0de54f854
SHA256 (gnome2/rhythmbox-0.10.1.tar.bz2) = a303076477a9a7b6a226613a6f3b43f4641ce977357c9aa9652932dc0b9bbd16
SIZE (gnome2/rhythmbox-0.10.1.tar.bz2) = 3408309
MD5 (gnome2/rhythmbox-0.12.0.tar.bz2) = ae6bc15786cc7659b41c313e45adf44a
SHA256 (gnome2/rhythmbox-0.12.0.tar.bz2) = 797d0e0d542d4c4ddc436f1ea395f272ebcdaa46fff112226ec9ab244af5b7eb
SIZE (gnome2/rhythmbox-0.12.0.tar.bz2) = 4925468

View file

@ -1,51 +0,0 @@
--- plugins/ipod/rb-ipod-source.c.orig Sun Nov 19 12:12:33 2006
+++ plugins/ipod/rb-ipod-source.c Sun Nov 19 12:28:50 2006
@@ -695,33 +695,36 @@ hal_udi_is_ipod (const char *udi)
char *spider_udi;
int vnd_id = 0;
int product_id = 0;
+ DBusError phone_error;
+
+ dbus_error_init (&phone_error);
spider_udi = g_strdup(parent_udi);
while (vnd_id == 0 && product_id == 0 && spider_udi != NULL) {
char *old_udi = spider_udi;
spider_udi = libhal_device_get_property_string (ctx, spider_udi,
- "info.parent", &error);
- if (dbus_error_is_set (&error)) {
- dbus_error_free (&error);
- dbus_error_init (&error);
+ "info.parent", &phone_error);
+ if (dbus_error_is_set (&phone_error)) {
+ dbus_error_free (&phone_error);
+ dbus_error_init (&phone_error);
spider_udi = NULL;
break;
}
g_free(old_udi);
vnd_id = libhal_device_get_property_int (ctx, spider_udi,
- "usb.vendor_id", &error);
- if (dbus_error_is_set(&error)) {
- dbus_error_free (&error);
- dbus_error_init (&error);
+ "usb.vendor_id", &phone_error);
+ if (dbus_error_is_set(&phone_error)) {
+ dbus_error_free (&phone_error);
+ dbus_error_init (&phone_error);
vnd_id = 0;
}
product_id = libhal_device_get_property_int (ctx, spider_udi,
- "usb.product_id", &error);
- if (dbus_error_is_set(&error)) {
- dbus_error_free (&error);
- dbus_error_init (&error);
+ "usb.product_id", &phone_error);
+ if (dbus_error_is_set(&phone_error)) {
+ dbus_error_free (&phone_error);
+ dbus_error_init (&phone_error);
product_id = 0;
}
}

View file

@ -1,10 +0,0 @@
--- shell/Makefile.in.orig 2008-06-07 13:56:05.000000000 -0400
+++ shell/Makefile.in 2008-06-07 13:56:26.000000000 -0400
@@ -351,6 +351,7 @@ INCLUDES = \
$(WARN_CFLAGS) \
$(GDA_CFLAGS) \
$(RHYTHMBOX_CFLAGS) \
+ $(SOUP_CFLAGS) \
$(TOTEM_PLPARSER_CFLAGS) \
$(DBUS_CFLAGS) \
$(LIBNAUTILUS_BURN_CFLAGS) \