Fix build on current and remove BROKEN tag
PR: ports/48830 Submitted by: tjr
This commit is contained in:
parent
8810494a59
commit
a3515324ff
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=76906
8 changed files with 151 additions and 4 deletions
|
@ -33,8 +33,4 @@ CODA_VERSION?= 5.3.19
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 500037
|
||||
BROKEN= "Does not build"
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
36
net/coda5_server/files/patch-aa
Normal file
36
net/coda5_server/files/patch-aa
Normal file
|
@ -0,0 +1,36 @@
|
|||
--- coda-src/update/updatesrv.cc.orig Sun Mar 2 17:55:46 2003
|
||||
+++ coda-src/update/updatesrv.cc Sun Mar 2 17:57:50 2003
|
||||
@@ -184,6 +184,7 @@
|
||||
long portmapid;
|
||||
struct stat statbuf;
|
||||
char *miscdir;
|
||||
+ time_t tim;
|
||||
|
||||
/* process the command line arguments */
|
||||
for (i = 1; i < argc; i++) {
|
||||
@@ -305,7 +306,7 @@
|
||||
}
|
||||
gettimeofday(&tp, &tsp);
|
||||
LogMsg(0, SrvDebugLevel, stdout,
|
||||
- "Update Server started %s", ctime(&tp.tv_sec));
|
||||
+ "Update Server started %s", ctime(&(tim = tp.tv_sec)));
|
||||
|
||||
CODA_ASSERT(LWP_WaitProcess((char *)&parentPid) == LWP_SUCCESS);
|
||||
|
||||
@@ -455,6 +456,7 @@
|
||||
char name[MAXPATHLEN]; /* area to hold the name */
|
||||
struct stat buff; /* buffer for stat */
|
||||
int len;
|
||||
+ time_t tim;
|
||||
|
||||
rc = 0;
|
||||
|
||||
@@ -518,7 +520,7 @@
|
||||
*CurrentUsecs = tp.tv_usec;
|
||||
LogMsg(2, SrvDebugLevel, stdout,
|
||||
"UpdateFetch returns %s newtime is %d at %s",
|
||||
- ViceErrorMsg((int)rc), *NewTime, ctime(&tp.tv_sec));
|
||||
+ ViceErrorMsg((int)rc), *NewTime, ctime(&(tim = tp.tv_sec)));
|
||||
return(rc);
|
||||
}
|
||||
|
39
net/coda5_server/files/patch-ab
Normal file
39
net/coda5_server/files/patch-ab
Normal file
|
@ -0,0 +1,39 @@
|
|||
--- coda-src/update/updateclnt.cc.orig Sun Mar 2 17:58:32 2003
|
||||
+++ coda-src/update/updateclnt.cc Sun Mar 2 17:59:25 2003
|
||||
@@ -152,6 +152,7 @@
|
||||
int i, rc;
|
||||
int len;
|
||||
char errmsg[MAXPATHLEN];
|
||||
+ time_t tim;
|
||||
|
||||
*host = '\0';
|
||||
|
||||
@@ -226,7 +227,7 @@
|
||||
gettimeofday(&tp, &tsp);
|
||||
LogMsg(0, SrvDebugLevel, stdout,
|
||||
"Update Client pid = %d started at %s",
|
||||
- getpid(), ctime(&tp.tv_sec));
|
||||
+ getpid(), ctime(&(tim = tp.tv_sec)));
|
||||
|
||||
time.tv_sec = waitinterval;
|
||||
time.tv_usec = 0;
|
||||
@@ -688,16 +689,17 @@
|
||||
{
|
||||
struct timeval tv;
|
||||
struct timezone tz;
|
||||
+ time_t tim;
|
||||
|
||||
if(rename("UpdateLog","UpdateLog.old")) {
|
||||
LogMsg(0, SrvDebugLevel, stdout, "Rename for UpdateLog failed with a %s\n", ViceErrorMsg(errno));
|
||||
}
|
||||
else {
|
||||
gettimeofday(&tv, &tz);
|
||||
- LogMsg(0, SrvDebugLevel, stdout, "Moving UpdateLog to UpdateLog.old at %s", ctime(&tv.tv_sec));
|
||||
+ LogMsg(0, SrvDebugLevel, stdout, "Moving UpdateLog to UpdateLog.old at %s", ctime(&(tim = tv.tv_sec)));
|
||||
freopen("UpdateLog","a+",stdout);
|
||||
freopen("UpdateLog","a+",stderr);
|
||||
- LogMsg(0, SrvDebugLevel, stdout, "New UpdateLog started at %s", ctime(&tv.tv_sec));
|
||||
+ LogMsg(0, SrvDebugLevel, stdout, "New UpdateLog started at %s", ctime(&(tim = tv.tv_sec)));
|
||||
}
|
||||
}
|
||||
|
20
net/coda5_server/files/patch-ac
Normal file
20
net/coda5_server/files/patch-ac
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- coda-src/venus/fso_cachefile.cc.orig Sun Mar 2 17:32:28 2003
|
||||
+++ coda-src/venus/fso_cachefile.cc Sun Mar 2 17:33:30 2003
|
||||
@@ -132,7 +132,7 @@
|
||||
/* Must be called from within a transaction! Assume caller has done
|
||||
RVMLIB_REC_OBJECT() */
|
||||
|
||||
-void CacheFile::Create(int newlength = 0)
|
||||
+void CacheFile::Create(int newlength)
|
||||
{
|
||||
LOG(10, ("CacheFile::Create: %s, %d\n", name, newlength));
|
||||
|
||||
@@ -183,7 +183,7 @@
|
||||
return 0;
|
||||
}
|
||||
|
||||
-int CacheFile::Copy(char *destname, ino_t *ino, int recovering = 0)
|
||||
+int CacheFile::Copy(char *destname, ino_t *ino, int recovering)
|
||||
{
|
||||
LOG(10, ("CacheFile::Copy: from %s, %d, %d/%d, to %s\n",
|
||||
name, inode, validdata, length, destname));
|
13
net/coda5_server/files/patch-ad
Normal file
13
net/coda5_server/files/patch-ad
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- coda-src/venus/vproc.cc.orig Sun Mar 2 17:42:30 2003
|
||||
+++ coda-src/venus/vproc.cc Sun Mar 2 17:43:34 2003
|
||||
@@ -784,8 +784,10 @@
|
||||
#if !defined(NetBSD1_3) && !defined(__NetBSD_Version__)
|
||||
sp->st_lspare = 0;
|
||||
#endif
|
||||
+#if __FreeBSD_version < 5
|
||||
sp->st_qspare[0] = 0;
|
||||
sp->st_qspare[1] = 0;
|
||||
+#endif
|
||||
#endif /* __BSD44__ */
|
||||
}
|
||||
|
16
net/coda5_server/files/patch-ae
Normal file
16
net/coda5_server/files/patch-ae
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- coda-src/vice/srv.cc.orig Sun Mar 2 17:49:12 2003
|
||||
+++ coda-src/vice/srv.cc Sun Mar 2 17:54:40 2003
|
||||
@@ -1270,8 +1270,13 @@
|
||||
char buf[100], buf2[100]; /* can't believe there will be more logs! */
|
||||
struct dirent **namelist = NULL;
|
||||
|
||||
+#if __FreeBSD__ >= 5
|
||||
+ count = scandir(".", &namelist, (int (*)(dirent *)) xselect,
|
||||
+ (int (*)(const void *, const void *)) compar);
|
||||
+#else
|
||||
count = scandir(".", &namelist, (int (*)(const dirent *)) xselect,
|
||||
(int (*)(const void *, const void *)) compar);
|
||||
+#endif
|
||||
/* It is safe now to blindly rename */
|
||||
for (i = 0; i < count; i++) {
|
||||
sprintf(buf, "SrvLog-%d", count-i);
|
14
net/coda5_server/files/patch-af
Normal file
14
net/coda5_server/files/patch-af
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- tools/our-install.orig Sun Mar 2 17:18:33 2003
|
||||
+++ tools/our-install Sun Mar 2 17:21:13 2003
|
||||
@@ -11,8 +11,10 @@
|
||||
PATH=/bin:/usr/bin:/sbin:/usr/sbin:/usr/ucb
|
||||
export PATH
|
||||
|
||||
-if [ $SYS = NetBSD -o $SYS = FreeBSD -o $SYS = OpenBSD ] ; then
|
||||
+if [ $SYS = NetBSD -o $SYS = OpenBSD ] ; then
|
||||
OWNGRP=root.wheel
|
||||
+elif [ $SYS = FreeBSD ] ; then
|
||||
+OWNGRP=root:wheel
|
||||
else
|
||||
OWNGRP=root:root
|
||||
fi
|
13
net/coda5_server/files/patch-ag
Normal file
13
net/coda5_server/files/patch-ag
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- lib-src/kernel-includes/coda.h.orig Sun Mar 2 18:11:14 2003
|
||||
+++ lib-src/kernel-includes/coda.h Sun Mar 2 18:11:58 2003
|
||||
@@ -125,6 +125,10 @@
|
||||
#define __BIT_TYPES_DEFINED__
|
||||
#endif
|
||||
|
||||
+#if __FreeBSD__ >= 5
|
||||
+#define __BIT_TYPES_DEFINED__
|
||||
+#endif
|
||||
+
|
||||
#ifndef __BIT_TYPES_DEFINED__
|
||||
#define __BIT_TYPES_DEFINED__
|
||||
typedef signed char int8_t;
|
Loading…
Reference in a new issue