- Update to 0.8.22
This commit is contained in:
parent
3af2f04dd4
commit
a357f58e9f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=189232
8 changed files with 29 additions and 76 deletions
|
@ -6,7 +6,6 @@
|
|||
#
|
||||
|
||||
PORTNAME= libXGP
|
||||
PORTREVISION= 1
|
||||
MASTERDIR= ${.CURDIR}/../libYGP
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
||||
|
|
|
@ -6,16 +6,15 @@
|
|||
#
|
||||
|
||||
PORTNAME?= libYGP
|
||||
PORTVERSION= 0.8.10
|
||||
PORTVERSION= 0.8.22
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= SF
|
||||
MASTER_SITE_SUBDIR= libymp
|
||||
MASTER_SITES= SF/libymp
|
||||
DISTNAME= libYGP-${PORTVERSION}
|
||||
|
||||
MAINTAINER= infofarmer@FreeBSD.org
|
||||
COMMENT= Yet another General Purpose library
|
||||
|
||||
LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
|
||||
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
|
||||
|
||||
USE_BZIP2= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
@ -23,25 +22,28 @@ USE_GNOME= pkgconfig gnomehack
|
|||
USE_LDCONFIG= yes
|
||||
USE_GETTEXT= yes
|
||||
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE} --with-gmp
|
||||
CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE} --with-gmp\
|
||||
--disable-static --disable-rpath
|
||||
|
||||
.if ${PORTNAME:M*XGP}
|
||||
LIB_DEPENDS+= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
|
||||
YGP-${PORTVERSION}.0:${PORTSDIR}/devel/libYGP
|
||||
PLIST_SUB+= YGP="@comment " XGP=""
|
||||
USE_GGNOME+= gtkhtml3
|
||||
CFG_PATCH+= s/mozembed/mozembedNO/g;
|
||||
XGP_PATCH+= s/(^@AM.*)?GtkMozViewer(.lo|.c|.Plo@am__quote@)//;
|
||||
MKIN_PATCH+= s/^(SUBDIRS = ).*$$/\1XGP/;
|
||||
YGP.0:${PORTSDIR}/devel/libYGP
|
||||
PLIST_SUB= YGP="@comment " XGP=""
|
||||
CFG_PATCH= s/mozembed/mozembedNO/g;
|
||||
XGP_PATCH= s/(^@AM.*)?GtkMozViewer(.lo|.c|.Plo@am__quote@)//;
|
||||
MKIN_PATCH= s/^(SUBDIRS = ).*$$/\1XGP/;
|
||||
.else
|
||||
PLIST_SUB+= XGP="@comment " YGP=""
|
||||
MKIN_PATCH+= s/@MYSUBDIRS@/YGP/;
|
||||
PLIST_SUB= XGP="@comment " YGP=""
|
||||
MKIN_PATCH= s/@MYSUBDIRS@/YGP/;
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -Ee 's/(test.*)==/\1=/g;${CFG_PATCH}' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e '/test.*==/s|==|=|g;/LIBRELEASE=/s|=.*|=0|;${CFG_PATCH}' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -Ee '${XGP_PATCH}' ${WRKSRC}/XGP/Makefile.in
|
||||
@${REINPLACE_CMD} -Ee '${MKIN_PATCH}' ${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -Ee '/include_HEADERS/s|config.h||;${MKIN_PATCH}' ${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e '/^#include/s|malloc.h|stdlib.h|' ${WRKSRC}/XGP/GTKViewer.c
|
||||
@${REINPLACE_CMD} -e '/^typedef int socklen_t;/d' ${WRKSRC}/YGP/Socket.cpp
|
||||
@${REINPLACE_CMD} -e '/^#.*define sleep/d' ${WRKSRC}/YGP/Tests/Thread.cpp
|
||||
.if ${PORTNAME:M*XGP}
|
||||
@${FIND} ${WRKSRC} -type f -print0 | \
|
||||
${XARGS} -0 ${REINPLACE_CMD} -e 's/ygp-cfg/xgp-cfg/g'
|
||||
|
@ -52,13 +54,6 @@ post-patch:
|
|||
.endif
|
||||
|
||||
post-install:
|
||||
@${LN} -sf ${PREFIX}/lib/${PORTNAME}-${PORTVERSION}.so \
|
||||
${PREFIX}/lib/${PORTNAME}-${PORTVERSION}.so.0
|
||||
@${LN} -sf ${PREFIX}/lib/${PORTNAME}-0.so ${PREFIX}/lib/${PORTNAME}.so.0
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
BROKEN= does not compile on 4.x
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (libYGP-0.8.10.tar.bz2) = 36cbc7ea8713acf5bd34a66430b9639e
|
||||
SHA256 (libYGP-0.8.10.tar.bz2) = 774ec0afce34a0945217b4a3cdb7fe57982e6ccd8c3c4d598d4cf35bc1f9d5da
|
||||
SIZE (libYGP-0.8.10.tar.bz2) = 675357
|
||||
MD5 (libYGP-0.8.22.tar.bz2) = e62fa953c819e3f781117a0f0575f494
|
||||
SHA256 (libYGP-0.8.22.tar.bz2) = cc663c62630bbeae661799d274645f738462f3f64a34b5bd8c9ed552b185c826
|
||||
SIZE (libYGP-0.8.22.tar.bz2) = 710674
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- ./Makefile.in.orig Sun Aug 20 14:16:06 2006
|
||||
+++ ./Makefile.in Sun Aug 20 14:16:06 2006
|
||||
@@ -251,7 +251,7 @@
|
||||
target_alias = @target_alias@
|
||||
SUBDIRS = intl @MYSUBDIRS@ po bin
|
||||
DIST_SUBDIRS = intl YGP XGP CGP po doc bin
|
||||
-include_HEADERS = ygp-cfg.h config.h
|
||||
+include_HEADERS = ygp-cfg.h
|
||||
EXTRA_DIST = config.rpath README.windows mkinstalldirs
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
all: ygp-cfg.h
|
|
@ -1,11 +0,0 @@
|
|||
--- ./XGP/GTKViewer.c.orig Sun Aug 20 14:19:48 2006
|
||||
+++ ./XGP/GTKViewer.c Sun Aug 20 14:19:58 2006
|
||||
@@ -40,7 +40,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <errno.h>
|
||||
-#include <malloc.h>
|
||||
+#include <stdlib.h>
|
||||
#include <string.h>
|
||||
|
||||
#include <dlfcn.h>
|
|
@ -1,10 +0,0 @@
|
|||
--- ./YGP/Socket.cpp.orig Thu Aug 10 04:08:18 2006
|
||||
+++ ./YGP/Socket.cpp Sun Aug 20 14:16:06 2006
|
||||
@@ -58,7 +58,6 @@
|
||||
typedef size_t ssize_t;
|
||||
#endif
|
||||
#ifndef HAVE_SOCKLEN_T
|
||||
-typedef int socklen_t;
|
||||
#endif
|
||||
|
||||
|
|
@ -1,10 +0,0 @@
|
|||
--- ./YGP/Tests/Thread.cpp.orig Sun Jun 4 01:32:35 2006
|
||||
+++ ./YGP/Tests/Thread.cpp Sun Aug 20 14:16:06 2006
|
||||
@@ -30,7 +30,6 @@
|
||||
#include <ygp-cfg.h>
|
||||
|
||||
#if defined HAVE__SLEEP
|
||||
-# define sleep _sleep
|
||||
#endif
|
||||
|
||||
|
|
@ -18,6 +18,7 @@
|
|||
%%YGP%%include/YGP/Exception.h
|
||||
%%YGP%%include/YGP/File.h
|
||||
%%YGP%%include/YGP/FileRExp.h
|
||||
%%YGP%%include/YGP/FileTypeChk.h
|
||||
%%YGP%%include/YGP/Handle.h
|
||||
%%YGP%%include/YGP/IDirSrch.h
|
||||
%%YGP%%include/YGP/INIFile.h
|
||||
|
@ -44,6 +45,7 @@
|
|||
%%YGP%%include/YGP/Thread.h
|
||||
%%YGP%%include/YGP/Tokenize.h
|
||||
%%YGP%%include/YGP/Trace.h
|
||||
%%YGP%%include/YGP/Utility.h
|
||||
%%YGP%%include/YGP/XDirSrch.h
|
||||
%%YGP%%include/YGP/XStrBuf.h
|
||||
%%YGP%%include/YGP/XStream.h
|
||||
|
@ -73,20 +75,19 @@
|
|||
%%XGP%%include/XGP/XFileList.h
|
||||
%%XGP%%include/XGP/XPrintDlg.h
|
||||
%%XGP%%include/XGP/XValue.h
|
||||
%%YGP%%lib/libYGP-0.8.10.so
|
||||
%%YGP%%lib/libYGP-0.8.10.so.0
|
||||
%%YGP%%lib/libYGP.a
|
||||
%%YGP%%lib/libYGP.la
|
||||
%%YGP%%lib/libYGP-0.so
|
||||
%%YGP%%lib/libYGP.so
|
||||
%%XGP%%lib/libXGP-0.8.10.so
|
||||
%%XGP%%lib/libXGP-0.8.10.so.0
|
||||
%%XGP%%lib/libXGP.a
|
||||
%%YGP%%lib/libYGP.so.0
|
||||
%%XGP%%lib/libXGP.la
|
||||
%%XGP%%lib/libXGP-0.so
|
||||
%%XGP%%lib/libXGP.so
|
||||
%%XGP%%lib/libXGP.so.0
|
||||
%%YGP%%libdata/pkgconfig/YGP.pc
|
||||
%%XGP%%libdata/pkgconfig/XGP.pc
|
||||
%%XGP%%share/XGP/Browser_GTKHTML.png
|
||||
%%XGP%%share/XGP/Browser_GTKMOZEMBED.png
|
||||
%%XGP%%share/XGP/Browser_dillo.png
|
||||
%%XGP%%share/XGP/Browser_epiphany.png
|
||||
%%XGP%%share/XGP/Browser_firefox.png
|
||||
%%XGP%%share/XGP/Browser_galeon.png
|
||||
|
|
Loading…
Reference in a new issue