- Add OPTIMIZED_CFLAGS option.

- Add message to pkg-plist about installed files that weren't removed.
- Fix building of binaries (missing macro definition: "WF").

Approved by:	garga (mentor)
This commit is contained in:
Alejandro Pulver 2006-04-17 19:27:49 +00:00
parent 8e84e20a52
commit a3b0bce535
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=159826
3 changed files with 8 additions and 3 deletions

View file

@ -21,6 +21,7 @@ COMMENT= "Wolfenstein 3D Linux" by Steven Fuller (1992)
USE_SDL= sdl
OPTIONS= WOLF_SW "Install shareware data for Wolfenstein 3D" on \
OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
SPEAR_SW "Install shareware data for Spear of Destiny" off
SUB_FILES= pkg-message wolf3d
@ -42,6 +43,10 @@ PLIST_SUB+= WOLF_SW=""
PLIST_SUB+= WOLF_SW="@comment "
.endif
.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
MAKE_ENV+= OPT_CF="-O2 -fomit-frame-pointer -ffast-math -funroll-loops"
.endif
.if defined(WITH_SPEAR_SW)
DISTFILES+= speardata${EXTRACT_SUFX}:sw
PLIST_SUB+= SPEAR_SW=""

View file

@ -1,12 +1,12 @@
--- Makefile.orig Thu Sep 27 20:58:29 2001
+++ Makefile Sun Apr 9 10:34:17 2006
+++ Makefile Thu Apr 13 15:49:57 2006
@@ -1,7 +1,8 @@
-CC = gcc
+#CC = gcc
#CC = gcc-3.0
-CFLAGS = -g -Wall -pedantic
+CFLAGS += -O2 -fomit-frame-pointer -ffast-math -funroll-loops
+CFLAGS += $(OPT_CF) $(WF)
+#CFLAGS = -g -Wall -pedantic
#CFLAGS = -g -O2 -Wall -pedantic
#CFLAGS = -Wall -O6 -fomit-frame-pointer -ffast-math -funroll-loops -mpentiumpro -mcpu=pentiumpro -march=pentiumpro

View file

@ -23,7 +23,7 @@ libexec/wolf3d/sdlwolf3d-ws
%%SPEAR_SW%%%%DATADIR%%/vgagraph.sdm
%%SPEAR_SW%%%%DATADIR%%/vgahead.sdm
%%SPEAR_SW%%%%DATADIR%%/vswap.sdm
@dirrm %%DATADIR%%
@unexec rmdir %D/%%DATADIR%% 2>/dev/null || echo "If you are permanently removing this port, you should remove any Wolfenstein 3D and/or Spear Of Destiny data files left in %D/%%DATADIR%%." | fmt
%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm libexec/wolf3d