misc/xplr: Unbreak build on FreeBSD 11-{i386,amd64}
getentropy(3) did not appear until FreeBSD 12, anything lower will not compile, throwing an undefined reference to `getentropy'. We can safely remove this once FreeBSD 11 is EOL. Reported-by: pkg-fallout
This commit is contained in:
parent
c391e5fd39
commit
a3c6016fad
2 changed files with 22 additions and 2 deletions
|
@ -1,7 +1,7 @@
|
|||
PORTNAME= xplr
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.14.3
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= misc
|
||||
|
||||
MAINTAINER= lcook@FreeBSD.org
|
||||
|
@ -177,4 +177,13 @@ post-install-EXAMPLES-on:
|
|||
${INSTALL_DATA} ${_EXAMPLES} \
|
||||
${STAGEDIR}${EXAMPLESDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
# XXX: getentropy(3) did not appear until FreeBSD 12, anything lower will
|
||||
# not compile, throwing an undefined reference to `getentropy'. We can
|
||||
# safely remove this once FreeBSD 11 is EOL.
|
||||
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200000
|
||||
EXTRA_PATCHES= ${PATCHDIR}/extra-cargo-crates_luajit-src-210.1.3+restyfe08842_luajit2_src_lj__prng.c
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- cargo-crates/luajit-src-210.1.3+restyfe08842/luajit2/src/lj_prng.c.orig 2021-07-11 17:23:58 UTC
|
||||
+++ cargo-crates/luajit-src-210.1.3+restyfe08842/luajit2/src/lj_prng.c
|
||||
@@ -116,7 +116,7 @@ static PRGR libfunc_rgr;
|
||||
#define LJ_TARGET_HAS_GETENTROPY 1
|
||||
#endif
|
||||
#elif LJ_TARGET_BSD || LJ_TARGET_SOLARIS || LJ_TARGET_CYGWIN
|
||||
-#define LJ_TARGET_HAS_GETENTROPY 1
|
||||
+#define LJ_TARGET_HAS_GETENTROPY 0
|
||||
#endif
|
||||
|
||||
#if LJ_TARGET_HAS_GETENTROPY
|
Loading…
Reference in a new issue