- Update to version 3.1
PR: 57534 Submitted by: Ports Fury
This commit is contained in:
parent
95890583fc
commit
a3f314ca7d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=90138
4 changed files with 4 additions and 58 deletions
|
@ -7,7 +7,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= gspoof
|
||||
PORTVERSION= 3.0
|
||||
PORTVERSION= 3.1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -21,11 +21,10 @@ USE_GNOME= gnometarget gtk20
|
|||
USE_REINPLACE= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-libnet-prefix=${LOCALBASE}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/usr/local/lib|${LOCALBASE}/lib|g ; \
|
||||
s|/usr/local/include|${LOCALBASE}/include|g ; \
|
||||
s|-Wall -O2|$${CFLAGS}|g' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|-Wall -O2|$${CFLAGS}|g' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|-Wall -O2|@CFLAGS@|g' ${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|/usr/local/share|${PREFIX}/share|g ; \
|
||||
s|/usr/share|${X11BASE}/share|g' ${WRKSRC}/gtk.c
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (gspoof-3.0.tar.gz) = fb7de0bfc1353d8edc4f1825b2013959
|
||||
MD5 (gspoof-3.1.tar.gz) = 97ec57688ffba90dcadda11354ceaffe
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
--- console.c.orig Sat Aug 30 00:16:50 2003
|
||||
+++ console.c Sat Aug 30 15:56:23 2003
|
||||
@@ -335,7 +335,11 @@
|
||||
fgets(value, 20, stdin);
|
||||
seq = atol(value);
|
||||
}
|
||||
+#ifdef __FreeBSD__
|
||||
+ while (atoi(value) < 0 || strtoll(value, NULL, 10) > 4294970000);
|
||||
+#else
|
||||
while (atoi(value) < 0 || atoll(value) > 4294970000);
|
||||
+#endif
|
||||
}
|
||||
else if (!strcmp ("3.5", cmd))
|
||||
{
|
||||
@@ -345,7 +349,11 @@
|
||||
fgets(value, 20, stdin);
|
||||
ack = atol(value);
|
||||
}
|
||||
+#ifdef __FreeBSD__
|
||||
+ while (atoi(value) < 0 || strtoll(value, NULL, 10) > 4294970000);
|
||||
+#else
|
||||
while (atoi(value) < 0 || atoll(value) > 4294970000);
|
||||
+#endif
|
||||
}
|
||||
else if (!strcmp ("3.6", cmd))
|
||||
{
|
|
@ -1,27 +0,0 @@
|
|||
--- gfuncts.c.orig Sat Aug 30 00:16:50 2003
|
||||
+++ gfuncts.c Sat Aug 30 15:58:09 2003
|
||||
@@ -382,14 +382,24 @@
|
||||
info ("Invalid destination port value\n");
|
||||
return -1;
|
||||
}
|
||||
+#ifdef __FreeBSD__
|
||||
+ if (strtoll(gtk_entry_get_text(GTK_ENTRY(seq_entry)), NULL, 10)<0 ||
|
||||
+ strtoll(gtk_entry_get_text(GTK_ENTRY(seq_entry)), NULL, 10)>4294970000)
|
||||
+#else
|
||||
if (atoll(gtk_entry_get_text(GTK_ENTRY(seq_entry)))<0 ||
|
||||
atoll(gtk_entry_get_text(GTK_ENTRY(seq_entry)))>4294970000)
|
||||
+#endif
|
||||
{
|
||||
info ("Invalid sequence number value\n");
|
||||
return -1;
|
||||
}
|
||||
+#ifdef __FreeBSD__
|
||||
+ if (strtoll(gtk_entry_get_text(GTK_ENTRY(ack_entry)), NULL, 10)<0 ||
|
||||
+ strtoll(gtk_entry_get_text(GTK_ENTRY(ack_entry)), NULL, 10)>4294970000)
|
||||
+#else
|
||||
if (atoll(gtk_entry_get_text(GTK_ENTRY(ack_entry)))<0 ||
|
||||
atoll(gtk_entry_get_text(GTK_ENTRY(ack_entry)))>4294970000)
|
||||
+#endif
|
||||
{
|
||||
info ("Invalid acknowledgment value\n");
|
||||
return -1;
|
Loading…
Reference in a new issue