Fix some build warnings.

This commit is contained in:
Christian Weisgerber 2003-06-01 23:27:53 +00:00
parent 41f78b665b
commit a3f47ceabc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=81946
3 changed files with 28 additions and 1 deletions

View file

@ -21,7 +21,7 @@ MAN8= vtund.8
MLINKS= vtund.8 vtun.8
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_AUTOCONF_VER= 213
CONFIGURE_ARGS= --localstatedir=/var \
--with-ssl-headers=${OPENSSLBASE}/include/openssl \
--with-ssl-lib=${OPENSSLBASE}/lib \

View file

@ -0,0 +1,14 @@
$FreeBSD$
--- configure.in.orig Mon Jun 2 01:21:53 2003
+++ configure.in Mon Jun 2 01:22:02 2003
@@ -134,7 +134,7 @@
AC_MSG_RESULT()
AC_CHECKING( for md5 Library and Header files ... )
AC_SEARCH_HEADERS(md5.h,
- $SSL_HDR_DIR /usr/include/openssl "" /usr/include /usr/include/ssl /usr/local/include /usr/local/ssl/include, /usr/include/sys,
+ $SSL_HDR_DIR /usr/include/openssl "" /usr/include /usr/include/ssl /usr/local/include /usr/local/ssl/include /usr/include/sys,
,
AC_MSG_ERROR( SSL headers not found. )
)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- lfd_lzo.c.orig Mon Jun 2 01:22:14 2003
+++ lfd_lzo.c Mon Jun 2 01:22:29 2003
@@ -36,6 +36,7 @@
#ifdef HAVE_LZO
#include "lzo1x.h"
+#include "lzoutil.h"
static lzo_byte *zbuf;
static lzo_voidp wmem;