Fix packaging (one of the Makefile wasn't DESTDIR aware)

While here fix shebang on perl scripts
This commit is contained in:
Baptiste Daroussin 2013-09-24 23:32:30 +00:00
parent e5beb68903
commit a42ed5f9e4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=328215
3 changed files with 36 additions and 2 deletions

View file

@ -2,14 +2,15 @@
PORTNAME= bsdbuild
PORTVERSION= 3.0
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://stable.hypertriton.com/bsdbuild/
MAINTAINER= ports@FreeBSD.org
COMMENT= BSD-licensed portable build system
USES= perl5
USES= perl5 shebangfix
SHEBANG_FILES= *.pl mk/*.pl
GNU_CONFIGURE= yes
LICENSE= BSD

View file

@ -0,0 +1,31 @@
--- ./ManReader/Makefile.orig 2012-07-27 06:21:45.000000000 +0200
+++ ./ManReader/Makefile 2013-09-25 01:25:39.843961894 +0200
@@ -5,23 +5,23 @@
all:
install:
- @if [ ! -d "${DATADIR}/ManReader" ]; then \
+ @if [ ! -d "${DESTDIR}${DATADIR}/ManReader" ]; then \
echo "${INSTALL_DATA_DIR} ${DATADIR}/ManReader"; \
- ${SUDO} ${INSTALL_DATA_DIR} ${DATADIR}/ManReader; \
+ ${SUDO} ${INSTALL_DATA_DIR} ${DESTDIR}${DATADIR}/ManReader; \
fi; \
for F in ${DATAFILES}; do \
echo "${INSTALL_DATA} $$F ${DATADIR}/ManReader"; \
- ${SUDO} ${INSTALL_DATA} $$F ${DATADIR}/ManReader; \
+ ${SUDO} ${INSTALL_DATA} $$F ${DESTDIR}${DATADIR}/ManReader; \
done
install-links:
@if [ ! -d "${DATADIR}/ManReader" ]; then \
echo "${INSTALL_DATA_DIR} ${DATADIR}/ManReader"; \
- ${SUDO} ${INSTALL_DATA_DIR} ${DATADIR}/ManReader; \
+ ${SUDO} ${INSTALL_DATA_DIR} ${DESTDIR}${DATADIR}/ManReader; \
fi; \
for F in ${DATAFILES}; do \
echo "ln -sf `pwd`/$$F ${DATADIR}/ManReader/$$F"; \
- ${SUDO} ln -sf `pwd`/$$F ${DATADIR}/ManReader/$$F; \
+ ${SUDO} ln -sf `pwd`/$$F ${DESTDIR}${DATADIR}/ManReader/$$F; \
done
clean:

View file

@ -139,6 +139,7 @@
%%DATADIR%%/libtool/configure.in
%%DATADIR%%/libtool/ltconfig
%%DATADIR%%/libtool/ltmain.sh
%%DATADIR%%/ManReader/Mdoc.pm
%%DATADIR%%/manlinks.pl
%%DATADIR%%/mkconcurrent.pl
%%DATADIR%%/mkdep
@ -161,5 +162,6 @@ man/man5/build.prog.mk.5.gz
man/man5/build.proj.mk.5.gz
man/man5/build.www.mk.5.gz
@dirrmtry %%DATADIR%%/libtool
@dirrmtry %%DATADIR%%/ManReader
@dirrmtry %%DATADIR%%/BSDBuild
@dirrmtry %%DATADIR%%