Fix build:
- Use any installed version of [x]emacs - If there's no emacs at all, fall back to xemacs21-mule - files/patch-isa_isabelle-system.el: Avoid interactive prompt if building with GNU emacs. Submitted by: barner, maintainer (partly) Approved by: Timothy Bourke <timbob@bigpond.com> (maintainer) Reported by: kris via pointyhat
This commit is contained in:
parent
49bff133bf
commit
a446c1e3b4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=142776
2 changed files with 35 additions and 7 deletions
|
@ -17,19 +17,34 @@ DISTNAME= ProofGeneral-3.5
|
|||
MAINTAINER= timbob@bigpond.com
|
||||
COMMENT= A generic interface for proof assistants
|
||||
|
||||
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
|
||||
${EMACS_NAME}:${EMACS_PORTSDIR}
|
||||
PKGNAMESUFFIX+= -${EMACS_NAME}
|
||||
|
||||
.if exists(${LOCALBASE}/bin/xemacs)
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages:${PORTSDIR}/editors/xemacs-packages
|
||||
BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash
|
||||
RUN_DEPENDS+= ${LOCALBASE}/share/applications/.keep_me:${PORTSDIR}/misc/kdehier
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/bin/xemacs) || !exists(${LOCALBASE}/bin/emacs)
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
#
|
||||
# Unless EMACS_PORT_NAME is overriden by the user,
|
||||
# use any installed version of [X]Emacs.
|
||||
#
|
||||
# If there is none installed, use xemacs21-mule.
|
||||
#
|
||||
.if !defined(EMACS_PORT_NAME)
|
||||
.if !exists(${LOCALBASE}/bin/emacs)
|
||||
EMACS_PORT_NAME=xemacs21-mule
|
||||
|
||||
# xemacs21-mule does not depend on xemacs-packages, so add a dependency here
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages/lisp/xlib/xlib-xlib.el:${PORTSDIR}/editors/xemacs-packages
|
||||
RUN_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages/lisp/xlib/xlib-xlib.el:${PORTSDIR}/editors/xemacs-packages
|
||||
.else
|
||||
EMACS_PORT_NAME=emacs21
|
||||
.endif
|
||||
.endif
|
||||
|
||||
# Needed for proper build- and run-time [x]xemacs dependencies,
|
||||
# and the definition of EMACS_NAME and EMACS_SITE_LISPDIR
|
||||
.include "${PORTSDIR}/Mk/bsd.emacs.mk"
|
||||
|
||||
MAKE_ARGS+= EMACS_NAME=${EMACS_NAME} EMACS_SITE_LISPDIR=${EMACS_SITE_LISPDIR}
|
||||
USE_GMAKE= yes
|
||||
|
@ -73,4 +88,4 @@ post-install:
|
|||
.endif
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
13
math/proofgeneral/files/patch-isa_isabelle-system.el
Normal file
13
math/proofgeneral/files/patch-isa_isabelle-system.el
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- isa/isabelle-system.el.orig Thu Sep 8 12:43:45 2005
|
||||
+++ isa/isabelle-system.el Thu Sep 8 12:45:12 2005
|
||||
@@ -73,10 +73,6 @@
|
||||
with full path."
|
||||
(interactive)
|
||||
(unless (or isatool-not-found (file-executable-p isa-isatool-command))
|
||||
- (setq isa-isatool-command
|
||||
- (read-file-name
|
||||
- "Please give the full path to `isatool' (RET if you don't have it): "
|
||||
- nil nil nil))
|
||||
(if (not (file-executable-p isa-isatool-command))
|
||||
(progn
|
||||
(setq isatool-not-found t)
|
Loading…
Reference in a new issue