- Update to 2.0.10
This commit is contained in:
parent
4d0661f943
commit
a44e39e368
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=556264
4 changed files with 54 additions and 6 deletions
|
@ -1,7 +1,8 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= lazarus
|
||||
PORTVERSION= 2.0.8
|
||||
PORTVERSION= 2.0.10
|
||||
DISTVERSIONSUFFIX= -2
|
||||
PKGNAMESUFFIX?= -gtk2
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES= editors devel
|
||||
|
@ -26,7 +27,7 @@ USES= desktop-file-utils fpc gettext gmake iconv shared-mime-info xorg
|
|||
USE_FPC?= chm cairo dblib fcl-base fcl-db fcl-fpcunit fcl-image fcl-json fcl-net \
|
||||
fcl-registry fcl-res fcl-web fcl-xml fppkg gtk2 ibase iconvenc mysql \
|
||||
numlib odbc opengl openssl oracle pasjpeg postgres regexpr rtl-extra \
|
||||
sqlite x11
|
||||
rtl-generics sqlite x11
|
||||
USE_XORG= x11
|
||||
OPT?= "-Sgic "
|
||||
|
||||
|
@ -80,7 +81,7 @@ do-build:
|
|||
post-build:
|
||||
@cd ${WRKSRC} && \
|
||||
${RM} -R COPYING* README* debian localize.bat test *.orig *.bak startlazarus.app \
|
||||
ide/Makefile*.orig ide/Makefile*.bak
|
||||
ide/Makefile*.orig ide/Makefile*.bak lcl/interfaces/qt5/qtobjects.pas.orig
|
||||
|
||||
pre-install:
|
||||
@${ECHO} "#!/bin/sh" > ${WRKDIR}/lazarus-wrapper
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1587103144
|
||||
SHA256 (freepascal/lazarus-2.0.8.tar.gz) = 90b037280e5c63265bc25a63e6e78c9cb979fc4b45aa84606e3856b09ac791c5
|
||||
SIZE (freepascal/lazarus-2.0.8.tar.gz) = 65602475
|
||||
TIMESTAMP = 1601836014
|
||||
SHA256 (freepascal/lazarus-2.0.10-2.tar.gz) = 64d5626468dd24a3332b205f3abd0a581ab7de1b060a2d57e21864066cfd43b7
|
||||
SIZE (freepascal/lazarus-2.0.10-2.tar.gz) = 69626076
|
||||
|
|
33
editors/lazarus/files/patch-ide_lazbuild.lpr
Normal file
33
editors/lazarus/files/patch-ide_lazbuild.lpr
Normal file
|
@ -0,0 +1,33 @@
|
|||
--- ide/lazbuild.lpr 2018-07-28 08:38:06.000000000 -0500
|
||||
+++ ide/lazbuild.lpr 2020-11-19 20:38:27.421396000 -0500
|
||||
@@ -372,7 +372,7 @@
|
||||
if not FileExistsUTF8(Filename) then
|
||||
begin
|
||||
// Check for packages if the specified name is a valid identifier
|
||||
- if LazIsValidIdent(OriginalFileName) then begin
|
||||
+ if PackageFileNameIsValid(OriginalFileName) then begin
|
||||
if PackageAction=lpaAddPkgLinks then begin
|
||||
Error(ErrorFileNotFound,'lpk file expected, but '+OriginalFilename+' found');
|
||||
Exit;
|
||||
@@ -487,11 +487,10 @@
|
||||
XMLConfig.Free;
|
||||
end;
|
||||
// check Package Name
|
||||
- if (Result.Name='') or (not LazIsValidIdent(Result.Name)) then begin
|
||||
+ if (Result.Name='') or (not IsValidPkgName(Result.Name)) then
|
||||
Error(ErrorPackageNameInvalid,
|
||||
Format(lisPkgMangThePackageNameOfTheFileIsInvalid,
|
||||
[Result.Name, LineEnding, Result.Filename]));
|
||||
- end;
|
||||
// check if Package with same name is already loaded
|
||||
ConflictPkg:=PackageGraph.FindPackageWithName(Result.Name,nil);
|
||||
if ConflictPkg<>nil then begin
|
||||
@@ -1051,7 +1050,7 @@
|
||||
PkgFilename:='';
|
||||
if CompareFileExt(PackageNamesOrFiles[i],'.lpk')=0 then
|
||||
PkgFilename:=ExpandFileNameUTF8(PackageNamesOrFiles[i])
|
||||
- else if LazIsValidIdent(PackageNamesOrFiles[i]) then begin
|
||||
+ else if IsValidPkgName(PackageNamesOrFiles[i]) then begin
|
||||
PackageLink:=TLazPackageLink(LazPackageLinks.FindLinkWithPkgName(PackageNamesOrFiles[i]));
|
||||
if PackageLink=nil then
|
||||
begin
|
14
editors/lazarus/files/patch-lcl-interfaces-qt5_qtobjects.pas
Normal file
14
editors/lazarus/files/patch-lcl-interfaces-qt5_qtobjects.pas
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- lcl/interfaces/qt5/qtobjects.pas 2020-11-23 21:01:09.916716000 -0500
|
||||
+++ lcl/interfaces/qt5/qtobjects.pas 2020-11-23 21:02:33.484592000 -0500
|
||||
@@ -3115,8 +3115,9 @@
|
||||
SelFont := AFont;
|
||||
if (AFont.FHandle <> nil) and (Widget <> nil) then
|
||||
begin
|
||||
- QFnt := QPainter_font(Widget);
|
||||
- AssignQtFont(AFont.FHandle, QFnt);
|
||||
+ QFnt := QFont_Create(AFont.FHandle);
|
||||
+ QPainter_setFont(Widget, QFnt);
|
||||
+ QFont_destroy(QFnt);
|
||||
vFont.Angle := AFont.Angle;
|
||||
end;
|
||||
end;
|
Loading…
Reference in a new issue