Project was renamed

PR:		110753
Submitted by:	trasz (maintainer)
Repocopy by:    marcus
This commit is contained in:
Martin Wilke 2007-03-28 06:17:18 +00:00
parent 6c5ebc9748
commit a489328f44
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=188631
8 changed files with 7 additions and 114 deletions

View file

@ -116,7 +116,7 @@
SUBDIR += rtc
SUBDIR += sdlmame
SUBDIR += sdlmess
SUBDIR += sim
SUBDIR += simh
SUBDIR += sim6811
SUBDIR += ski
SUBDIR += skyeye

View file

@ -1,70 +0,0 @@
# New ports collection makefile for: sim
# Date created: 7 November 1997
# Whom: jraynard
#
# $FreeBSD$
#
PORTNAME= sim
PORTVERSION= 3.7
CATEGORIES= emulators
MASTER_SITES= http://simh.trailing-edge.com/sources/
DISTNAME= ${PORTNAME}hv37-0
MAINTAINER= trasz@pin.if.uz.zgora.pl
COMMENT= Emulates classic DEC, HP, GRI, IBM, Altair, SDS, Honeywell, and others
USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -qoa
USE_GMAKE= yes
RESTRICTED= Non-commercial use only
MAKEFILE= makefile
NO_WRKSUBDIR= yes
OPTIONS= NETWORK "Enable Sim_Ether module (and ports libpcap)" on
BIN_FILES= altair h316 ibm1130 nova pdp15 pdp9 vax780 \
altairz80 hp2100 id16 pdp1 pdp4 s3 \
i1401 id32 pdp10 pdp7 sds \
gri i1620 lgp pdp11 pdp8 vax
PORTDOCS= 0readme_37.txt 0readme_ethernet.txt
PLIST_FILES= ${BIN_FILES:S/^/bin\//g} %%DATADIR%%/ka655x.bin bin/sim-eclipse
PLIST_DIRS= %%DATADIR%%
SUB_FILES+= pkg-message
.include <bsd.port.pre.mk>
# XXX How do we know that libpcap.a is really the correct >0.9.x version?!
.if defined (WITH_NETWORK)
RUN_DEPENDS= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
BUILD_DEPENDS= ${RUN_DEPENDS}
MAKE_ENV= USE_NETWORK=1
.endif
pre-patch:
@${MKDIR} ${WRKSRC}/BIN
do-install:
.for file in ${BIN_FILES}
${INSTALL_PROGRAM} ${WRKDIR}/BIN/${file} ${PREFIX}/bin
.endfor
# eclipse conflicts with java/eclipse, install it as sim-eclipse
${INSTALL_PROGRAM} ${WRKDIR}/BIN/eclipse ${PREFIX}/bin/sim-eclipse
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKDIR}/VAX/ka655x.bin ${DATADIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@for i in ${PORTDOCS}; do\
${INSTALL_DATA} ${WRKDIR}/$$i ${DOCSDIR}; \
done
.endif
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View file

@ -1,3 +0,0 @@
MD5 (simhv37-0.zip) = 5f5f037f8c710862bc7223d5be010c40
SHA256 (simhv37-0.zip) = 23ae538b7607d231d9e64c170b7a4cc7b7c9d0c1c8bbd662c565ac0a56d15069
SIZE (simhv37-0.zip) = 2362666

View file

@ -1,11 +0,0 @@
--- makefile.orig Fri Feb 2 07:12:20 2007
+++ makefile Sun Feb 11 15:57:23 2007
@@ -10,7 +10,7 @@
else
OS_CCDEFS = -D_GNU_SOURCE
endif
-CC = gcc -std=c99 -O2 -U__STRICT_ANSI__ -g -lm -lrt $(OS_CCDEFS) -I .
+CC += ${CFLAGS} -lm $(OS_CCDEFS) -I .
ifeq ($(USE_NETWORK),)
else
NETWORK_OPT = -DUSE_NETWORK -isystem /usr/local/include /usr/local/lib/libpcap.a

View file

@ -1,5 +0,0 @@
*********************************************************************
The file needed by the VAX emulator is located in %%PREFIX%%/share/sim
*********************************************************************

View file

@ -1,18 +0,0 @@
SIMH is a higly portable, multi-system simulator.
SIMH implements simulators for:
- Data General Nova, Eclipse
- Digital Equipment Corporation PDP-1, PDP-4, PDP-7, PDP-8, PDP-9,
PDP-10, PDP-11, PDP-15, VAX
- GRI Corporation GRI-909
- IBM 1401, 1620, 1130, System 3
- Interdata (Perkin-Elmer) 16b and 32b systems
- Hewlett-Packard 2116, 2100, 21MX
- Honeywell H316/H516
- MITS Altair 8800, with both 8080 and Z80
- Royal-Mcbee LGP-30, LGP-21
- Scientific Data Systems SDS 940
These simulators are capable of running the Unix V5, V6 and V7 binaries
licenced for non-commercial use by SCO. See ${WRKDIR}/simh_doc.txt for
further details.

View file

@ -5,11 +5,11 @@
# $FreeBSD$
#
PORTNAME= sim
PORTNAME= simh
PORTVERSION= 3.7
CATEGORIES= emulators
MASTER_SITES= http://simh.trailing-edge.com/sources/
DISTNAME= ${PORTNAME}hv37-0
DISTNAME= ${PORTNAME}v37-0
MAINTAINER= trasz@pin.if.uz.zgora.pl
COMMENT= Emulates classic DEC, HP, GRI, IBM, Altair, SDS, Honeywell, and others
@ -30,7 +30,7 @@ BIN_FILES= altair h316 ibm1130 nova pdp15 pdp9 vax780 \
PORTDOCS= 0readme_37.txt 0readme_ethernet.txt
PLIST_FILES= ${BIN_FILES:S/^/bin\//g} %%DATADIR%%/ka655x.bin bin/sim-eclipse
PLIST_FILES= ${BIN_FILES:S/^/bin\//g} %%DATADIR%%/ka655x.bin bin/simh-eclipse
PLIST_DIRS= %%DATADIR%%
SUB_FILES+= pkg-message
@ -51,8 +51,8 @@ do-install:
.for file in ${BIN_FILES}
${INSTALL_PROGRAM} ${WRKDIR}/BIN/${file} ${PREFIX}/bin
.endfor
# eclipse conflicts with java/eclipse, install it as sim-eclipse
${INSTALL_PROGRAM} ${WRKDIR}/BIN/eclipse ${PREFIX}/bin/sim-eclipse
# eclipse conflicts with java/eclipse, install it as simh-eclipse
${INSTALL_PROGRAM} ${WRKDIR}/BIN/eclipse ${PREFIX}/bin/simh-eclipse
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKDIR}/VAX/ka655x.bin ${DATADIR}

View file

@ -1,5 +1,5 @@
*********************************************************************
The file needed by the VAX emulator is located in %%PREFIX%%/share/sim
The file needed by the VAX emulator is located in %%PREFIX%%/share/simh
*********************************************************************