games/chessx: Update to 1.4.6
PR: 229924 Submitted by: freebsd_ports@k-worx.org Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D16393
This commit is contained in:
parent
7383dace6a
commit
a4cb76115e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=475118
5 changed files with 17 additions and 27 deletions
|
@ -1,21 +1,19 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= chessx
|
||||
PORTVERSION= 1.3.2
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.4.6
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Qt 4 chess database application
|
||||
COMMENT= Qt 5 chess database application
|
||||
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USES= desktop-file-utils qmake qt:4 shared-mime-info tar:tgz
|
||||
USE_QT= corelib gui svg network linguisttools_build \
|
||||
moc_build qmake_build rcc_build uic_build
|
||||
QMAKE_ARGS+= QMAKE_LRELEASE=${LRELEASE}
|
||||
USES= desktop-file-utils qmake:outsource qt:5 shared-mime-info tar:tgz
|
||||
USE_QT= buildtools_build concurrent core gui linguisttools_build multimedia \
|
||||
network opengl printsupport svg widgets xml
|
||||
|
||||
PLIST_FILES= bin/chessx \
|
||||
share/applications/chessx.desktop \
|
||||
|
@ -23,10 +21,10 @@ PLIST_FILES= bin/chessx \
|
|||
|
||||
OPTIONS_DEFINE= STOCKFISH CRAFTY
|
||||
|
||||
STOCKFISH_DESC= Install Stockfish Chess Engine
|
||||
STOCKFISH_RUN_DEPENDS= stockfish:games/stockfish
|
||||
|
||||
CRAFTY_DESC= Install Crafty Chess Application
|
||||
CRAFTY_RUN_DEPENDS= crafty:games/crafty
|
||||
|
||||
STOCKFISH_DESC= Install Stockfish Chess Engine
|
||||
STOCKFISH_RUN_DEPENDS= stockfish:games/stockfish
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (chessx-1.3.2.tgz) = b136cf56d37d34867cdb9538176e1703b14f61b3384885b6f100580d0af0a3ff
|
||||
SIZE (chessx-1.3.2.tgz) = 4107133
|
||||
TIMESTAMP = 1532163987
|
||||
SHA256 (chessx-1.4.6.tgz) = ad951910a3bd53f5655f9e85101e7969b536078473e09a2a7dded6ef171a68ed
|
||||
SIZE (chessx-1.4.6.tgz) = 4223076
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- chessx.pro.orig 2015-05-05 13:46:26 UTC
|
||||
--- chessx.pro.orig 2018-07-21 09:39:34 UTC
|
||||
+++ chessx.pro
|
||||
@@ -393,6 +393,15 @@ macx {
|
||||
@@ -445,6 +445,16 @@ macx {
|
||||
QMAKE_INFO_PLIST = mac_osx/Info.plist
|
||||
}
|
||||
|
||||
|
@ -13,6 +13,7 @@
|
|||
+ INSTALLS += target desktop pixmaps
|
||||
+}
|
||||
+
|
||||
RESOURCES = resources.qrc
|
||||
+
|
||||
RESOURCES = \
|
||||
resources.qrc
|
||||
|
||||
TRANSLATIONS = i18n/chessx_de.ts \
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- src/database/threadedguess.cpp.orig 2015-04-28 18:00:47 UTC
|
||||
+++ src/database/threadedguess.cpp
|
||||
@@ -2,6 +2,7 @@
|
||||
* Copyright (C) 2014 by Jens Nissen jens-chessx@gmx.net *
|
||||
****************************************************************************/
|
||||
|
||||
+#include <QMetaType>
|
||||
#include "threadedguess.h"
|
||||
#include "guess.h"
|
||||
|
|
@ -1,4 +1,4 @@
|
|||
ChessX is an open source chess database based on Qt4. With ChessX you
|
||||
ChessX is an open source chess database based on Qt5. With ChessX you
|
||||
can operate on your collection of chess games in many ways: browse,
|
||||
edit, add, organize, analyze, etc. Additionally ChessX can interface
|
||||
with chess engines via UCI and Winboard protocol.
|
||||
|
|
Loading…
Reference in a new issue