Update devel/p5-Unix-Statgrab to 0.04

PR:		87004
Submitted by:	Tim Bishop <tim@bishnet.net> (maintainer)
Approved by:	novel (mentor)
This commit is contained in:
Emanuel Haupt 2005-10-07 07:23:28 +00:00
parent d9ebb92f3d
commit a4ce109a6b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=144452
3 changed files with 4 additions and 49 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= Unix-Statgrab
PORTVERSION= 0.03
PORTREVISION= 1
PORTVERSION= 0.04
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Unix
@ -28,10 +27,9 @@ MAN3= Unix::Statgrab.3
.include <bsd.port.pre.mk>
post-patch:
.if ${PERL_LEVEL} < 500600
post-patch:
@${PERL} -i -pe 's/}\(/}->(/' ${WRKSRC}/lib/Unix/Statgrab.pm
.endif
@${RM} ${WRKSRC}/lib/Unix/Statgrab.pm.orig
.include <bsd.port.post.mk>

View file

@ -1,2 +1,2 @@
MD5 (Unix-Statgrab-0.03.tar.gz) = 089380f21fa7e3d4b7a1bc55d658fd9c
SIZE (Unix-Statgrab-0.03.tar.gz) = 23264
MD5 (Unix-Statgrab-0.04.tar.gz) = 94787010e27183ce5cf354c58c465d0d
SIZE (Unix-Statgrab-0.04.tar.gz) = 23653

View file

@ -1,43 +0,0 @@
diff -ruN Unix-Statgrab-0.03/Statgrab.xs Unix-Statgrab-0.03.new/Statgrab.xs
--- Statgrab.xs Sun Apr 3 06:32:41 2005
+++ Statgrab.xs Sat Jul 30 12:10:10 2005
@@ -1113,13 +1113,13 @@
RETVAL
IV
-dup (self, num = 0)
+duplex (self, num = 0)
sg_network_iface_stats_my *self;
int num;
CODE:
if (num < 0 || num >= self->nifs)
XSRETURN_UNDEF;
- RETVAL = IF(num)->dup;
+ RETVAL = IF(num)->duplex;
OUTPUT:
RETVAL
diff -ruN Unix-Statgrab-0.03/lib/Unix/Statgrab.pm Unix-Statgrab-0.03.new/lib/Unix/Statgrab.pm
--- lib/Unix/Statgrab.pm Sun Apr 3 06:45:44 2005
+++ lib/Unix/Statgrab.pm Sat Jul 30 12:09:53 2005
@@ -479,7 +479,7 @@
The speed of the interface, in megabits/sec
-=item * B<dup($if)>
+=item * B<duplex($if)>
One of C<SG_IFACE_DUPLEX_FULL>, C<SG_IFACE_DUPLEX_HALF> and C<SG_IFACE_DUPLEX_UNKNOWN>. Unknown could mean that duplex hasn't been negotiated yet.
diff -ruN Unix-Statgrab-0.03/t/Unix-Statgrab.t Unix-Statgrab-0.03.new/t/Unix-Statgrab.t
--- t/Unix-Statgrab.t Sun Apr 3 06:35:08 2005
+++ t/Unix-Statgrab.t Sat Jul 30 12:09:29 2005
@@ -50,7 +50,7 @@
ierrors oerrors collisions systime/ ],
get_network_io_stats_diff => [ qw/num_ifaces interface_name tx rx ipackets opackets
ierrors oerrors collisions systime/ ],
- get_network_iface_stats => [ qw/num_ifaces interface_name speed dup up/ ],
+ get_network_iface_stats => [ qw/num_ifaces interface_name speed duplex up/ ],
get_page_stats => [ qw/pages_pagein pages_pageout systime/ ],
get_page_stats_diff => [ qw/pages_pagein pages_pageout systime/ ],
get_user_stats => [ qw/num_entries name_list/ ],