- Update to 11.3
- Strip shared library Changes: https://github.com/buganini/gbsdconv/releases PR: 201017 Submitted by: sunpoet (myself) Approved by: Kuan-Chung Chiu <buganini@gmail.com> (maintainer)
This commit is contained in:
parent
e2b26a2388
commit
a4f678ed2f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=390753
3 changed files with 6 additions and 29 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gbsdconv
|
||||
PORTVERSION= 11.1
|
||||
PORTVERSION= 11.3
|
||||
CATEGORIES= converters python
|
||||
|
||||
MAINTAINER= buganini@gmail.com
|
||||
|
@ -27,4 +27,7 @@ PLIST_FILES= bin/gbsdconv \
|
|||
%%DATADIR%%/gbsdconv.xml \
|
||||
%%DATADIR%%/gbsdconv2.png
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gbsdconv_taglib.so
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (buganini-gbsdconv-11.1_GH0.tar.gz) = 34f13dd5d242002fc1577508f067c6878466d4d20191cfb9dead513b9af36903
|
||||
SIZE (buganini-gbsdconv-11.1_GH0.tar.gz) = 19728
|
||||
SHA256 (buganini-gbsdconv-11.3_GH0.tar.gz) = 4ab852cbcb3b6f9b16fccb7cb3dd0a9c6c2736a0b7e369afe26a55a08809cc6e
|
||||
SIZE (buganini-gbsdconv-11.3_GH0.tar.gz) = 19915
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
--- Makefile.orig 2013-09-09 09:56:10.000000000 +0400
|
||||
+++ Makefile 2014-01-28 04:02:41.281082541 +0400
|
||||
@@ -1,17 +1,17 @@
|
||||
PREFIX?=/usr/local
|
||||
|
||||
-LIBS=-L${PREFIX}/lib -ltag
|
||||
+LIBS=-L${LOCALBASE}/lib -ltag
|
||||
|
||||
all: gbsdconv_taglib
|
||||
|
||||
gbsdconv_taglib: taglib/tag_c.cpp
|
||||
- $(CXX) -I${PREFIX}/include/taglib -fPIC -shared -o gbsdconv_taglib.so taglib/tag_c.cpp ${LIBS}
|
||||
+ $(CXX) -I${LOCALBASE}/include/taglib -fPIC -shared -o gbsdconv_taglib.so taglib/tag_c.cpp ${LIBS}
|
||||
|
||||
install:
|
||||
- install -m 755 gbsdconv ${PREFIX}/bin
|
||||
- install -m 444 gbsdconv_taglib.so ${PREFIX}/lib
|
||||
- mkdir -p ${PREFIX}/share/gbsdconv
|
||||
- install -m 444 gbsdconv.png gbsdconv.xml gbsdconv2.png ${PREFIX}/share/gbsdconv
|
||||
+ install -m 755 gbsdconv ${DESTDIR}${PREFIX}/bin
|
||||
+ install -m 444 gbsdconv_taglib.so ${DESTDIR}${PREFIX}/lib
|
||||
+ mkdir -p ${DESTDIR}${PREFIX}/share/gbsdconv
|
||||
+ install -m 444 gbsdconv.png gbsdconv.xml gbsdconv2.png ${DESTDIR}${PREFIX}/share/gbsdconv
|
||||
|
||||
clean:
|
||||
rm -f gbsdconv_taglib.so
|
Loading…
Reference in a new issue