Caribbean Stud gambling game for X Window System
PR: ports/7409 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
This commit is contained in:
parent
3bcf7d6e00
commit
a4f997a075
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=17452
8 changed files with 129 additions and 0 deletions
30
games/CaribbeanStud/Makefile
Normal file
30
games/CaribbeanStud/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# New ports collection makefile for: CaribbeanStud
|
||||
# Version required: 1.0
|
||||
# Date created: 4 July 1998
|
||||
# Whom: Andrey Zakhvatov
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= CS
|
||||
PKGNAME= CaribbeanStud-1.0
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
|
||||
MASTER_SITE_SUBDIR= games
|
||||
|
||||
MAINTAINER= andy@icc.surw.chel.su
|
||||
|
||||
MAKEFILE= Xmakefile
|
||||
REQUIRES_MOTIF= yes
|
||||
USE_X_PREFIX= yes
|
||||
|
||||
do-install:
|
||||
@ ${INSTALL_PROGRAM} ${WRKSRC}/CaribbeanStud ${PREFIX}/bin
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/CaribbeanStud.res ${PREFIX}/lib/X11/app-defaults/CaribbeanStud
|
||||
.if !defined(NOPORTDOCS)
|
||||
@ ${MKDIR} ${PREFIX}/share/doc/CaribbeanStud
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/CaribbeanStud
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/class.ps ${PREFIX}/share/doc/CaribbeanStud
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
games/CaribbeanStud/distinfo
Normal file
1
games/CaribbeanStud/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (CS.tar.gz) = 4d9b732165158b2c29c44825fdb105a6
|
51
games/CaribbeanStud/files/patch-aa
Normal file
51
games/CaribbeanStud/files/patch-aa
Normal file
|
@ -0,0 +1,51 @@
|
|||
--- Xmakefile Fri Jan 31 22:47:59 1997
|
||||
+++ /home/andy/tmp/wrk/Xmakefile Sat Jul 4 19:07:47 1998
|
||||
@@ -77,17 +77,27 @@
|
||||
#UILFLAGS=-I/usr/include/uil -I/usr/include/Motif1.2/uil
|
||||
###
|
||||
|
||||
+## FreeBSD
|
||||
+##
|
||||
+XINCLUDES=-I$(X11BASE)/include
|
||||
+UILFLAGS=
|
||||
+CFLAGS+= -fhandle-exceptions -fno-for-scope
|
||||
+CXXFLAGS+= $(XINCLUDES)
|
||||
+LDFLAGS+=-L$(X11BASE)/lib
|
||||
+LDLIBS=
|
||||
+MOTIFLIBS=-lXm -lXmu -lXt -lX11
|
||||
+
|
||||
#LDLIBS = -lPW
|
||||
# Program configuration
|
||||
# ---------------------
|
||||
|
||||
-LDFLAGS = ${XLIBS} $(MRMLIBS)
|
||||
-MOTIFLIBS = -lXm -lXmu -lXt -lX11
|
||||
+#LDFLAGS = ${XLIBS} $(MRMLIBS)
|
||||
+#MOTIFLIBS = -lXm -lXmu -lXt -lX11
|
||||
|
||||
-CFLAGS= -g -I. ${XINCLUDES} $(UILFLAGS)
|
||||
-CCFLAGS=${CFLAGS}
|
||||
+#CFLAGS+= ${XINCLUDES} $(UILFLAGS)
|
||||
+#CCFLAGS=${CFLAGS}
|
||||
|
||||
-UIL=uil
|
||||
+#UIL=uil
|
||||
|
||||
#MOTIFLIBS = -lXm -lXt -lX11 -lPW
|
||||
|
||||
@@ -122,7 +132,7 @@
|
||||
|
||||
CaribbeanStud: $(OBJS)
|
||||
rm -f $@
|
||||
- $(CCC) $(CCFLAGS) -o $@ $(OBJS) $(LDFLAGS) $(LDLIBS) $(MOTIFLIBS)
|
||||
+ $(CXX) -o $@ $(OBJS) $(LDFLAGS) $(LDLIBS) $(MOTIFLIBS)
|
||||
|
||||
depend:: $(SRCS) $(HEADERS)
|
||||
makedepend $(CFLAGS) $(CPPFLAGS) -- $(ALLDEFINES) -- $(SRCS)
|
||||
@@ -134,5 +144,5 @@
|
||||
|
||||
.SUFFIXES: .cpp $(SUFFIXES)
|
||||
.cpp.o:
|
||||
- $(COMPILE.cc) $(OUTPUT_OPTION) $<
|
||||
+ $(CXX) -c $(CXXFLAGS) $(OUTPUT_OPTION) $<
|
||||
|
11
games/CaribbeanStud/files/patch-ab
Normal file
11
games/CaribbeanStud/files/patch-ab
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Hands.cpp Fri Jan 31 22:47:58 1997
|
||||
+++ /home/andy/tmp/wrk/Hands.cpp Sat Jul 4 18:54:30 1998
|
||||
@@ -46,7 +46,7 @@
|
||||
_next = 0;
|
||||
}
|
||||
|
||||
-Hand Hands::HandValue() const
|
||||
+enum Hands::Hand Hands::HandValue() const
|
||||
{
|
||||
return _hand;
|
||||
}
|
15
games/CaribbeanStud/files/patch-ac
Normal file
15
games/CaribbeanStud/files/patch-ac
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- Seat.cpp Fri Jan 31 22:47:58 1997
|
||||
+++ /home/andy/tmp/wrk/Seat.cpp Sat Jul 4 19:48:21 1998
|
||||
@@ -151,10 +151,10 @@
|
||||
gcv.font = XLoadFont(_dpy, "10x20");
|
||||
gcflags = GCForeground | GCBackground | GCGraphicsExposures;
|
||||
_redgc = XCreateGC(_dpy, RootWindow(_dpy, _screen), gcflags, &gcv);
|
||||
+ // allocate drawing area background color, set areas
|
||||
+ XAllocNamedColor(_dpy, cmap, "Forest Green", &color, &color);
|
||||
|
||||
}
|
||||
- // allocate drawing area background color, set areas
|
||||
- XAllocNamedColor(_dpy, cmap, "Forest Green", &color, &color);
|
||||
i = 0;
|
||||
XtSetArg(args[i], XmNbackground, color.pixel); i++;
|
||||
XtSetArg(args[i], XmNforeground, whitepixel); i++;
|
1
games/CaribbeanStud/pkg-comment
Normal file
1
games/CaribbeanStud/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Caribbean Stud gambling game for X Window System.
|
15
games/CaribbeanStud/pkg-descr
Normal file
15
games/CaribbeanStud/pkg-descr
Normal file
|
@ -0,0 +1,15 @@
|
|||
Caribbean Stud is a Motif based gambling game for X Window System.
|
||||
|
||||
OPTIONS: ( All can be changed in CaribbeanStud.res )
|
||||
Default bankroll 200
|
||||
Table minimum 10
|
||||
Number of Players 2 (1-6)
|
||||
Current Jackpot 34000000
|
||||
Minimum Jackpot 3000000
|
||||
|
||||
The class.ps is the class diagram of this game.
|
||||
|
||||
Please direct comments, suggestions, and patches to:
|
||||
------------------------------------------------------------------
|
||||
Qun Zhang
|
||||
qzhang@oucsace.cs.ohiou.edu
|
5
games/CaribbeanStud/pkg-plist
Normal file
5
games/CaribbeanStud/pkg-plist
Normal file
|
@ -0,0 +1,5 @@
|
|||
bin/CaribbeanStud
|
||||
lib/X11/app-defaults/CaribbeanStud
|
||||
share/doc/CaribbeanStud/README
|
||||
share/doc/CaribbeanStud/class.ps
|
||||
@dirrm share/doc/CaribbeanStud
|
Loading…
Reference in a new issue