2012-08-23 multimedia/x264-devel: x264 github development made this port obsolete
This commit is contained in:
parent
0902061ef7
commit
a503253701
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=303805
8 changed files with 1 additions and 228 deletions
1
MOVED
1
MOVED
|
@ -3663,3 +3663,4 @@ www/py-django12||2012-08-31|Has expired: Unsupported version
|
|||
www/p5-Xango||2012-08-31|Has expired: Removed from CPAN
|
||||
lang/spidermonkey|lang/spidermonkey17|2012-09-01|Moved to allow for addition of the 1.8 development line.
|
||||
cad/gtkwave3|cad/gtkwave|2012-09-04|There is only one version of this now
|
||||
multimedia/x264-devel||2012-09-07|Has expired: x264 github development makes this port obsolete
|
||||
|
|
|
@ -365,7 +365,6 @@
|
|||
SUBDIR += webcamd
|
||||
SUBDIR += win32-codecs
|
||||
SUBDIR += x264
|
||||
SUBDIR += x264-devel
|
||||
SUBDIR += xanim
|
||||
SUBDIR += xawtv
|
||||
SUBDIR += xbmc
|
||||
|
|
|
@ -1,147 +0,0 @@
|
|||
# New ports collection makefile for: x264
|
||||
# Date created: 2005-01-11
|
||||
# Whom: Michael Johnson <ahze@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= x264
|
||||
PORTVERSION= 0.${X264_BUILD}.${X264_REV}
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL} \
|
||||
http://samples.mplayerhq.hu/yuv4mpeg2/:pgo
|
||||
MASTER_SITE_SUBDIR= mm/x264
|
||||
PKGNAMESUFFIX= -devel
|
||||
DISTNAME= ${PORTNAME}-${X264_GITVER}
|
||||
DISTFILES= ${DISTNAME}.tar.xz
|
||||
DIST_SUBDIR= x264
|
||||
EXTRACT_ONLY= ${DISTFILES}
|
||||
|
||||
MAINTAINER= mm@FreeBSD.org
|
||||
COMMENT= Library and tool for encoding H.264/AVC video streams
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BUILD_DEPENDS= yasm>=0.6.0:${PORTSDIR}/devel/yasm \
|
||||
${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils \
|
||||
${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
|
||||
|
||||
CONFLICTS= x264-0.*
|
||||
|
||||
DEPRECATED= x264 github development makes this port obsolete
|
||||
EXPIRATION_DATE= 2012-08-23
|
||||
|
||||
LATEST_LINK= x264-devel
|
||||
|
||||
X264_BUILD= 124
|
||||
X264_REV= 2197
|
||||
X264_COMMIT= 69a0443e7d8ab032a7f3c3468a42177d5e64daa2
|
||||
X264_GITVER= ${X264_COMMIT:C/^(.......).*$/\1/g}
|
||||
|
||||
USE_XZ= yes
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}
|
||||
USE_GMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
HAS_CONFIGURE= yes
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
OPTIONS= DEBUG "Enable Debugging" Off \
|
||||
PGO "Enable Profile-Guided Optimization" Off \
|
||||
GCC44 "Use gcc 4.4+" Off \
|
||||
GPAC "Enable MPEG-4 Output" On \
|
||||
X11_OUTPUT "Enable X11 Output" Off
|
||||
|
||||
CONFIGURE_ARGS+= --extra-cflags="${CPPFLAGS} ${CFLAGS} -fPIC -I${LOCALBASE}/include" \
|
||||
--extra-ldflags="${LDFLAGS} -L${LOCALBASE}/lib" \
|
||||
--enable-static --enable-shared
|
||||
|
||||
CONFIGURE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
|
||||
MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
|
||||
|
||||
PLIST_SUB+= X264_BUILD=${X264_BUILD}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_GCC44)
|
||||
USE_GCC?= 4.4+
|
||||
.endif
|
||||
|
||||
# Around the time GCC stack protection (aka Propolice) for userland
|
||||
# was enabled on src/share/mk/bsd.sys.mk
|
||||
# SVN rev 180012 on 2008-06-25 21:33:28Z by ru
|
||||
.if ${OSVERSION} >= 800040
|
||||
LDFLAGS+= -fstack-protector
|
||||
.endif
|
||||
|
||||
CONFIGURE_ENV+= ARCH= \
|
||||
TARGET_ARCH=
|
||||
MAKE_ENV+= ARCH= \
|
||||
TARGET_ARCH=
|
||||
|
||||
.if defined(WITH_DEBUG)
|
||||
CONFIGURE_ARGS+= --enable-debug
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PGO) && ${SLAVE_PORT:L}!="yes"
|
||||
# y4m sample video
|
||||
Y4M_VIDEO=example.y4m
|
||||
Y4M_VIDEO_DISTFILE=example.y4m.bz2
|
||||
|
||||
DISTFILES+= ${Y4M_VIDEO_DISTFILE}:pgo
|
||||
ALL_TARGET= fprofiled
|
||||
MAKE_ENV+= VIDS="${WRKDIR}/${Y4M_VIDEO}"
|
||||
|
||||
RESTRICTED= ${Y4M_VIDEO_DISTFILE} file may not be mirrored
|
||||
RESTRICTED_FILES= ${Y4M_VIDEO_DISTFILE}
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_GPAC)
|
||||
BUILD_DEPENDS+= gpac-libgpac>=0.4.5,1:${PORTSDIR}/multimedia/gpac-libgpac
|
||||
LIB_DEPENDS+= gpac.1:${PORTSDIR}/multimedia/gpac-libgpac
|
||||
CONFIGURE_ARGS+= --enable-gpac
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-gpac
|
||||
.endif
|
||||
|
||||
.if defined(WITH_X11_OUTPUT)
|
||||
CONFIGURE_ARGS+= --enable-visualize
|
||||
USE_XORG= x11
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
.if defined(WITH_PGO) && ${SLAVE_PORT:L}!="yes"
|
||||
@( cd ${WRKDIR} && ${BZIP2_CMD} -dc ${DISTDIR}/${DIST_SUBDIR}/${Y4M_VIDEO_DISTFILE} > ${Y4M_VIDEO} )
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|; \
|
||||
s|-lpthread|${PTHREAD_LIBS}|g; \
|
||||
s|/bin/bash|${LOCALBASE}/bin/bash|; \
|
||||
s|gpac_static|gpac|g' \
|
||||
${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|bash|sh|' ${WRKSRC}/version.sh
|
||||
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|; \
|
||||
s|$${libdir}/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
|
||||
${WRKSRC}/Makefile
|
||||
.if !defined(WITH_GCC44)
|
||||
@${REINPLACE_CMD} -e 's|$$(CC) -shared -o|COMPILER_PATH= $$(CC) -shared -o|g' \
|
||||
-e 's|$$(CC) -o|COMPILER_PATH= $$(CC) -o|g' \
|
||||
${WRKSRC}/Makefile
|
||||
.endif
|
||||
|
||||
.if ${SLAVE_PORT:L}=="no"
|
||||
.if 0 # BROKEN
|
||||
post-build:
|
||||
cd ${WRKSRC}/tools && ${MAKE} avc2avi
|
||||
|
||||
pre-install:
|
||||
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' \
|
||||
${WRKSRC}/x264.pc
|
||||
|
||||
post-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/tools/avc2avi ${PREFIX}/bin
|
||||
.endif # BROKEN
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,4 +0,0 @@
|
|||
SHA256 (x264/x264-69a0443.tar.xz) = 343a75618aa1dee1881971dda9f96b06545ffd180316766ee495ba688f76365b
|
||||
SIZE (x264/x264-69a0443.tar.xz) = 496732
|
||||
SHA256 (x264/example.y4m.bz2) = a5bec9d37362bd9d7773fbd0644643f9ec096d654d20823004e88d5df32bbff7
|
||||
SIZE (x264/example.y4m.bz2) = 4910029
|
|
@ -1,27 +0,0 @@
|
|||
--- Makefile.orig 2012-04-24 23:13:17.000000000 +0200
|
||||
+++ Makefile 2012-05-04 12:21:04.220847109 +0200
|
||||
@@ -84,13 +84,13 @@
|
||||
endif
|
||||
X86SRC = $(X86SRC0:%=common/x86/%)
|
||||
|
||||
-ifeq ($(ARCH),X86)
|
||||
+ifeq ($(ARCH),i386)
|
||||
ARCH_X86 = yes
|
||||
ASMSRC = $(X86SRC) common/x86/pixel-32.asm
|
||||
ASFLAGS += -DARCH_X86_64=0
|
||||
endif
|
||||
|
||||
-ifeq ($(ARCH),X86_64)
|
||||
+ifeq ($(ARCH),amd64)
|
||||
ARCH_X86 = yes
|
||||
ASMSRC = $(X86SRC:-32.asm=-64.asm) common/x86/trellis-64.asm
|
||||
ASFLAGS += -DARCH_X86_64=1
|
||||
@@ -106,7 +106,7 @@
|
||||
endif
|
||||
|
||||
# AltiVec optims
|
||||
-ifeq ($(ARCH),PPC)
|
||||
+ifeq ($(ARCH),powerpc)
|
||||
ifneq ($(AS),)
|
||||
SRCS += common/ppc/mc.c common/ppc/pixel.c common/ppc/dct.c \
|
||||
common/ppc/quant.c common/ppc/deblock.c \
|
|
@ -1,29 +0,0 @@
|
|||
--- common/cpu.c.orig 2010-06-24 22:45:07.000000000 +0200
|
||||
+++ common/cpu.c 2010-07-18 22:55:49.324572565 +0200
|
||||
@@ -234,7 +234,7 @@
|
||||
|
||||
#elif ARCH_PPC
|
||||
|
||||
-#if SYS_MACOSX || SYS_OPENBSD
|
||||
+#if SYS_MACOSX || SYS_OPENBSD || SYS_FREEBSD
|
||||
#include <sys/sysctl.h>
|
||||
uint32_t x264_cpu_detect( void )
|
||||
{
|
||||
@@ -242,12 +242,16 @@
|
||||
uint32_t cpu = 0;
|
||||
#if SYS_OPENBSD
|
||||
int selectors[2] = { CTL_MACHDEP, CPU_ALTIVEC };
|
||||
-#else
|
||||
+#elif SYS_MACOSX
|
||||
int selectors[2] = { CTL_HW, HW_VECTORUNIT };
|
||||
#endif
|
||||
int has_altivec = 0;
|
||||
size_t length = sizeof( has_altivec );
|
||||
+#if SYS_MACOSX || SYS_OPENBSD
|
||||
int error = sysctl( selectors, 2, &has_altivec, &length, NULL, 0 );
|
||||
+#else
|
||||
+ int error = sysctlbyname("hw.altivec", &has_altivec, &length, NULL, 0 );
|
||||
+#endif
|
||||
|
||||
if( error == 0 && has_altivec != 0 )
|
||||
cpu |= X264_CPU_ALTIVEC;
|
|
@ -1,13 +0,0 @@
|
|||
x264 is a free library for encoding H.264/AVC (aka MPEG-4 Part 10)
|
||||
video streams.
|
||||
|
||||
Encoder features
|
||||
* CAVLC/CABAC
|
||||
* Multi-references
|
||||
* Intra: all modes (4x4 and 16x16 with all predictions)
|
||||
* Inter P: all partitions (from 16x16 down to 4x4)
|
||||
* Inter B: partitions from 16x16 down to 8x8 (including SKIP/DIRECT)
|
||||
* Ratecontrol: constant quantizer, constant bitrate, or multipass ABR
|
||||
* Scene cut detection
|
||||
|
||||
WWW: http://www.videolan.org/x264.html
|
|
@ -1,7 +0,0 @@
|
|||
bin/x264
|
||||
include/x264.h
|
||||
include/x264_config.h
|
||||
lib/libx264.a
|
||||
lib/libx264.so
|
||||
lib/libx264.so.%%X264_BUILD%%
|
||||
libdata/pkgconfig/x264.pc
|
Loading…
Reference in a new issue