Compatibility fix for R18.
- Fix portlint warnings - Use DOS2UNIX_GLOB to fix all source files
This commit is contained in:
parent
2b7ad9ca54
commit
a52ab0a5e8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=390549
4 changed files with 13 additions and 6 deletions
|
@ -16,9 +16,9 @@ PLIST_SUB= VERSION="${PORTVERSION}"
|
|||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= iamaleksey
|
||||
|
||||
DOS2UNIX_FILES= Makefile
|
||||
ALL_TARGET= compile doc
|
||||
USES= dos2unix gmake iconv:build
|
||||
DOS2UNIX_GLOB= Makefile *.hrl *.erl
|
||||
|
||||
post-extract:
|
||||
@${REINPLACE_CMD} -e "s@<@<@g" -e "s@>@>@g" ${WRKSRC}/doc/*.ndoc
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- Makefile.orig
|
||||
--- Makefile.orig 2015-06-25 10:00:03 UTC
|
||||
+++ Makefile
|
||||
@@ -1,3 +1,5 @@
|
||||
+include app.mk
|
||||
|
@ -6,7 +6,7 @@
|
|||
###-----------------------------------------------------------------------------
|
||||
### APPLICATION LAYOUT
|
||||
###-----------------------------------------------------------------------------
|
||||
@@ -35,7 +37,10 @@
|
||||
@@ -35,7 +37,10 @@ clobber: clean
|
||||
test:
|
||||
./rebar ct
|
||||
|
||||
|
@ -18,7 +18,7 @@
|
|||
|
||||
man: $(MANS)
|
||||
@$(MV) doc/man/$(APPNAME)_overview.3 doc/man/$(APPNAME).1
|
||||
@@ -49,14 +54,14 @@
|
||||
@@ -49,14 +54,14 @@ pdf: $(PDFS)
|
||||
%.3: %.ndoc
|
||||
@$(CD) doc; $(SED) "s|%MODULES%|`echo $(MODS)`|g" ../$^ | \
|
||||
$(SED) "s|%VSN%|$(VSN)|g" | $(SED) "s|%APPLICATION%|$(APPNAME)|g" | \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- app.mk.orig
|
||||
--- app.mk.orig 2012-01-11 12:00:24 UTC
|
||||
+++ app.mk
|
||||
@@ -25,7 +25,7 @@
|
||||
@@ -25,7 +25,7 @@ STUB_EFLAGS = -W0 -o stubs
|
||||
CD = cd
|
||||
CP = cp -vf
|
||||
ECHO = echo
|
||||
|
|
7
devel/common_lib/files/patch-rebar.config
Normal file
7
devel/common_lib/files/patch-rebar.config
Normal file
|
@ -0,0 +1,7 @@
|
|||
--- rebar.config.orig 2012-01-11 12:00:24 UTC
|
||||
+++ rebar.config
|
||||
@@ -1,3 +1,3 @@
|
||||
-{erl_opts, [warnings_as_errors, debug_info]}.
|
||||
+{erl_opts, [debug_info]}.
|
||||
|
||||
{xref_checks, [undefined_function_calls]}.
|
Loading…
Reference in a new issue