- Fix build on head/10

- Support staging
- Use new LIB_DEPENDS format
- Unsilence post-install commands
This commit is contained in:
Guido Falsi 2014-01-17 12:27:30 +00:00
parent 2a66bb8ec1
commit a54b9bae02
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=340030
9 changed files with 87 additions and 7 deletions

View file

@ -10,8 +10,8 @@ MASTER_SITES= http://camaya.net/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Jabber/XMPP client library
LIB_DEPENDS= idn.17:${PORTSDIR}/dns/libidn \
gnutls.26:${PORTSDIR}/security/gnutls
LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn \
libgnutls.so:${PORTSDIR}/security/gnutls
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
@ -21,13 +21,13 @@ CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|libgnutls-config|pkg-config gnutls|' ${WRKSRC}/configure
post-install:
@${FIND} ${PREFIX}/include/gloox ! -type d | \
${SED} "s,${PREFIX}/,," >> ${TMPPLIST}
@${FIND} ${PREFIX}/include/gloox -type d | ${SORT} -r | \
${SED} "s,${PREFIX}/,@dirrm ," >> ${TMPPLIST}
${FIND} ${STAGEDIR}${PREFIX}/include/gloox ! -type d | \
${SED} "s,${STAGEDIR}${PREFIX}/,," >> ${TMPPLIST}
${FIND} ${STAGEDIR}${PREFIX}/include/gloox -type d | ${SORT} -r | \
${SED} "s,${STAGEDIR}${PREFIX}/,@dirrm ," >> ${TMPPLIST}
.include <bsd.port.mk>

View file

@ -0,0 +1,10 @@
--- src/examples/bosh_example.cpp.orig 2009-06-22 11:39:04.000000000 +0200
+++ src/examples/bosh_example.cpp 2013-12-26 22:57:50.576228531 +0100
@@ -22,6 +22,7 @@
#include <unistd.h>
#include <stdio.h>
#include <string>
+#include <ctime>
#include <cstdio> // [s]print[f]

View file

@ -0,0 +1,10 @@
--- src/examples/e2ee_client.cpp.orig 2009-10-13 20:57:34.000000000 +0200
+++ src/examples/e2ee_client.cpp 2013-12-26 22:57:55.817222888 +0100
@@ -15,6 +15,7 @@
#include <stdio.h>
#include <locale.h>
#include <string>
+#include <ctime>
#include <cstdio> // [s]print[f]

View file

@ -0,0 +1,10 @@
--- src/examples/e2ee_server.cpp.orig 2009-10-13 20:47:21.000000000 +0200
+++ src/examples/e2ee_server.cpp 2013-12-26 22:58:00.534218841 +0100
@@ -15,6 +15,7 @@
#include <stdio.h>
#include <locale.h>
#include <string>
+#include <ctime>
#include <cstdio> // [s]print[f]

View file

@ -0,0 +1,10 @@
--- src/examples/ft_recv.cpp.orig 2009-10-06 15:14:26.000000000 +0200
+++ src/examples/ft_recv.cpp 2013-12-26 22:58:05.182220399 +0100
@@ -13,6 +13,7 @@
#include <unistd.h>
#include <stdio.h>
#include <string>
+#include <ctime>
#include <cstdio> // [s]print[f]

View file

@ -0,0 +1,10 @@
--- src/examples/ft_send.cpp.orig 2009-10-06 15:15:09.000000000 +0200
+++ src/examples/ft_send.cpp 2013-12-26 22:58:11.944229970 +0100
@@ -16,6 +16,7 @@
#include <unistd.h>
#include <stdio.h>
#include <string>
+#include <ctime>
#include <fstream>
#include <ios>

View file

@ -0,0 +1,10 @@
--- src/examples/message_example.cpp.orig 2009-10-26 00:34:48.000000000 +0100
+++ src/examples/message_example.cpp 2013-12-26 22:58:16.855221562 +0100
@@ -23,6 +23,7 @@
#include <stdio.h>
#include <string>
+#include <ctime>
#include <cstdio> // [s]print[f]

View file

@ -0,0 +1,10 @@
--- src/examples/pubsub_example.cpp.orig 2009-06-22 11:35:17.000000000 +0200
+++ src/examples/pubsub_example.cpp 2013-12-26 22:58:22.252225373 +0100
@@ -22,6 +22,7 @@
#include <unistd.h>
#include <stdio.h>
#include <string>
+#include <ctime>
#if defined( WIN32 ) || defined( _WIN32 )
# include <windows.h>

View file

@ -0,0 +1,10 @@
--- src/util.h.orig 2009-10-30 18:47:43.000000000 +0100
+++ src/util.h 2013-12-26 21:42:43.366548503 +0100
@@ -16,6 +16,7 @@
#include "gloox.h"
#include <cmath>
+#include <cstdlib>
#include <algorithm>
#include <string>
#include <list>