Fix gcc 4.2 build.

Approved by:	portmgr (erwin)
This commit is contained in:
Max Khon 2007-11-15 22:22:16 +00:00
parent b1f1582edf
commit a557de663f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=202731
5 changed files with 41 additions and 11 deletions

View file

@ -35,10 +35,6 @@ OPTIONS= BPP8 "With BPP8" Off \
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= Does not compile with GCC 4.2
.endif
post-patch:
.ifdef(WITH_BPP32) || defined(PACKAGE_BUILDING) || defined(BATCH)
${REINPLACE_CMD} -e 's/%%BPP%%/BPP32/' ${WRKSRC}/Makefile

View file

@ -0,0 +1,18 @@
--- Patch.c.orig 2007-11-16 02:31:51.000000000 +0600
+++ Patch.c 2007-11-16 02:35:41.000000000 +0600
@@ -24,15 +24,6 @@
void SSlot(byte Value); /* Used to switch secondary slots */
-#ifdef FMSX
-extern byte *RAM[],PSL[],SSLReg;
-static byte RdZ80(word A)
-{
- if(A!=0xFFFF) return(RAM[A>>13][A&0x1FFF]);
- else return((PSL[3]==3)? ~SSLReg:RAM[7][0x1FFF]);
-}
-#endif
-
/** PatchZ80() ***********************************************/
/** Emulate BIOS calls. This function is called on an ED FE **/
/** instruction to emulate disk/tape access, etc. **/

View file

@ -34,10 +34,4 @@ do-install:
@ ${INSTALL_MAN} ${WRKSRC}/vxmount.1 ${PREFIX}/man/man1
@ ${INSTALL_MAN} ${WRKSRC}/vxumount.1 ${PREFIX}/man/man1
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= Does not compile with GCC 4.2
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -0,0 +1,11 @@
--- dir.c.orig 2007-11-16 03:10:42.000000000 +0600
+++ dir.c 2007-11-16 03:11:11.000000000 +0600
@@ -105,7 +105,7 @@
if (direct->ino)
filldir (dir, direct->name, direct->namelen, direct->ino);
- (char *) direct += direct->reclen;
+ direct = (char *) direct + direct->reclen;
}
free (block);

View file

@ -0,0 +1,11 @@
--- olt.c.orig 2007-11-16 03:09:17.000000000 +0600
+++ olt.c 2007-11-16 03:12:11.000000000 +0600
@@ -85,7 +85,7 @@
case VXFS_OLTSB:
break;
}
- (int) ent += ent->oltcommon.size;
+ ent = (char *) ent + ent->oltcommon.size;
}
if (vxdebug)