Added new port tkhylafax which is a tcl/tk frontend to Sam Lefflers

hylafax package. Packaging tested.
This commit is contained in:
Andreas Klemm 1997-06-08 11:23:36 +00:00
parent c0e84f1f0b
commit a57abb68af
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=6797
7 changed files with 121 additions and 0 deletions

24
comms/tkhylafax/Makefile Normal file
View file

@ -0,0 +1,24 @@
# New ports collection Makefile for: tkhylafax-3.0
# Version required: 3.0b2
# Date released: Sun Jun 8 11:51:21 CEST 1997
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
# $Id$
#
DISTNAME= tkhylafax-3.0b2
PKGNAME= tkhylafax-3.0
CATEGORIES= comms
MASTER_SITES= http://www.NeoSoft.com/tcl/ftparchive/sorted/comm/tkhylafax-3.0b2/
MAINTAINER= andreas@FreeBSD.org
WRKSRC= ${WRKDIR}/tkhylafax-3.0
RUN_DEPENDS= wish4.2:${PORTSDIR}/x11/tk42 \
sendfax:${PORTSDIR}/comms/hylafax \
gs:${PORTSDIR}/print/ghostscript4 \
gv:${PORTSDIR}/print/gv
MAN1= tkhylafax.1
.include <bsd.port.mk>

1
comms/tkhylafax/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (tkhylafax-3.0b2.tar.gz) = 69b349ff7c6509769d17080109d2c765

View file

@ -0,0 +1,46 @@
--- Makefile.orig Sun Dec 29 19:26:39 1996
+++ Makefile Sun Jun 8 13:06:59 1997
@@ -14,10 +14,10 @@
TCLMAN_DEST = /usr/local/man/man1
# The full path to tclsh
-TCLSH = /usr/local/bin/tclsh
+TCLSH = tclsh7.6
# The full path to wish.
-WISH = /usr/local/bin/wish
+WISH = wish4.2
### DON'T EDIT ANYTHING BELOW THIS LINE ###
TCLLIB_FILES = \
@@ -40,7 +40,9 @@
TCLPRG_FILE = tkhylafax
TCLMAN_FILE = tkhylafax
-all: lib install.man tkhylafax
+all:
+
+install: lib install.man tkhylafax.inst
echo 'auto_mkindex $(TCLLIB_DEST) *.tcl *.t' | $(TCLSH);
$(TCLLIB_DEST):
@@ -59,16 +61,15 @@
if [ ! -d $(TCLPRG_DEST) ]; then mkdir -p $(TCLPRG_DEST); fi
chmod 775 $(TCLPRG_DEST)
-tkhylafax: $(TCLPRG_DEST)
+tkhylafax.inst: $(TCLPRG_DEST)
@echo "Patching tkhylafax..."
mv tkhylafax tkhylafax.unpatched
sed -e 's|XXX_TKHYLAFAX_XXX|$(TCLLIB_DEST)|g' \
tkhylafax.unpatched > tkhylafax
@echo "Done"
@echo "Installing tkhylafax command..."
- cp $(TCLPRG_FILE) $(TCLPRG_DEST)/$@
- chmod 775 $(TCLPRG_DEST)/$@
- mv tkhylafax.unpatched tkhylafax
+ cp $(TCLPRG_FILE) $(TCLPRG_DEST)/tkhylafax
+ chmod 775 $(TCLPRG_DEST)/tkhylafax
@echo "Done"
install.man:

View file

@ -0,0 +1,19 @@
--- tkhylafax.orig Tue Dec 31 02:49:43 1996
+++ tkhylafax Sun Jun 8 12:34:58 1997
@@ -1,6 +1,6 @@
#!/bin/sh
#\
-exec wish "$0" ${1+"$@"}
+exec wish4.2 "$0" ${1+"$@"}
#
#
@@ -291,7 +291,7 @@
proc previewCover { args } {
- set faxcmd "[mkCover] | ghostview -"
+ set faxcmd "[mkCover] | gv -"
# Exec it
if {[catch {eval exec $faxcmd &} err]} {

View file

@ -0,0 +1 @@
a tcl/tk interface to Sam Leffler's fax package

12
comms/tkhylafax/pkg-descr Normal file
View file

@ -0,0 +1,12 @@
tkhylafax is a tcl/tk interface to Sam Leffler's HYLAFAX package
features:
o Batching fax destinations
o Builtin faxnumber database
o Fast cover sheet generation
o Cover sheet preview
o Cover sheet ONLY transmission option
o Directory browser
o Fax job dequeuing made easier
o Fax job scheduling made easier
o Highly configurable

18
comms/tkhylafax/pkg-plist Normal file
View file

@ -0,0 +1,18 @@
bin/tkhylafax
lib/tkhylafax-3.0/entryDialog.t
lib/tkhylafax-3.0/extract.t
lib/tkhylafax-3.0/faxIt.t
lib/tkhylafax-3.0/fileSelect.t
lib/tkhylafax-3.0/listBatches.t
lib/tkhylafax-3.0/mkCover.t
lib/tkhylafax-3.0/mkWidgets.t
lib/tkhylafax-3.0/options.t
lib/tkhylafax-3.0/preferences.t
lib/tkhylafax-3.0/rolodex.t
lib/tkhylafax-3.0/searchEntries.t
lib/tkhylafax-3.0/sendBatch.t
lib/tkhylafax-3.0/svrStatus.t
lib/tkhylafax-3.0/tkhylafax.xbm
lib/tkhylafax-3.0/viewBatch.t
lib/tkhylafax-3.0/tclIndex
man/man1/tkhylafax.1.gz