Some efforts to make update.pl working
This commit is contained in:
parent
253e1b647b
commit
a5923326c5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46828
2 changed files with 17 additions and 0 deletions
|
@ -16,6 +16,8 @@ MAINTAINER= anton@urc.ac.ru
|
|||
|
||||
NO_BUILD= YES
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/mach/String/CRC32.pm:${PORTSDIR}/devel/p5-String-CRC32
|
||||
|
||||
DRWEB_PREFIX= ${PREFIX}/${PORTNAME}
|
||||
|
||||
do-install:
|
||||
|
@ -23,6 +25,7 @@ do-install:
|
|||
${TAR} -xzf ${WRKSRC}/${DISTNAME}.tar.gz -C ${DRWEB_PREFIX} --exclude *.ini
|
||||
${TAR} -xzOf ${WRKSRC}/${DISTNAME}.tar.gz drweb32.ini >${DRWEB_PREFIX}/drweb32.ini.sample
|
||||
${SED} 's#!!PREFIX!!#${DRWEB_PREFIX}#' < ${FILESDIR}/drwebd.sh >${WRKSRC}/drwebd.sh
|
||||
cd ${DRWEB_PREFIX}/update; patch < ${FILESDIR}/update-patch
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/drwebd.sh ${PREFIX}/etc/rc.d
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
14
security/drweb/files/update-patch
Normal file
14
security/drweb/files/update-patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- update.pl.bak Tue Jul 31 18:42:13 2001
|
||||
+++ update.pl Sat Aug 25 03:16:22 2001
|
||||
@@ -15,9 +15,9 @@
|
||||
use String::CRC32;
|
||||
|
||||
my $version = '425';
|
||||
-my $url = $ARGV[1] || 'http://www.drweb.ru/ftp/update_free/linux/drweb32.lst';
|
||||
+#my $url = $ARGV[1] || 'http://www.drweb.ru/ftp/update_free/linux/drweb32.lst';
|
||||
#my $url = $ARGV[1] || 'http://www.drweb.ru/ftp/update_free/freebsd3/drweb32.lst';
|
||||
-#my $url = $ARGV[1] || 'http://www.drweb.ru/ftp/update_free/freebsd4/drweb32.lst';
|
||||
+my $url = $ARGV[1] || 'http://www.drweb.ru/ftp/update_free/freebsd4/drweb32.lst';
|
||||
|
||||
my $fetch = ''; # autotest for fetch, wget
|
||||
unless ( $fetch ) { $fetch.=" -q -o" if chomp ( $fetch = `which fetch` ); }
|
Loading…
Reference in a new issue