- Fix CMake error introduces with revision r334518

CMake Error at extensions/CMakeLists.txt:28 (string):
  string begin index: -1 is out of range 0 - 9

- Bump PORTREVISION
This commit is contained in:
Olivier Duchateau 2014-01-02 15:19:00 +00:00
parent a9243a1b6e
commit a61beae3f4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=338445
2 changed files with 7 additions and 4 deletions

View file

@ -3,6 +3,7 @@
PORTNAME= midori
PORTVERSION= 0.5.6
PORTREVISION= 1
CATEGORIES= www xfce
MASTER_SITES= http://www.midori-browser.org/downloads/
DISTNAME= ${PORTNAME}_${PORTVERSION}_all_

View file

@ -1,11 +1,13 @@
--- ./extensions/CMakeLists.txt.orig 2013-09-17 10:59:53.000000000 +0000
+++ ./extensions/CMakeLists.txt 2013-09-17 14:46:05.000000000 +0000
@@ -24,6 +24,13 @@
--- ./extensions/CMakeLists.txt.orig 2013-11-20 01:26:52.000000000 +0000
+++ ./extensions/CMakeLists.txt 2014-01-02 16:00:24.000000000 +0000
@@ -24,6 +24,15 @@
"nsplugin-manager.vala"
)
endif ()
+string(FIND ${CMAKE_SYSTEM_NAME} "BSD" BEGIN)
+string(SUBSTRING ${CMAKE_SYSTEM_NAME} ${BEGIN} 3 BSD)
+if (${BEGIN} GREATER 0)
+ string(SUBSTRING ${CMAKE_SYSTEM_NAME} ${BEGIN} 3 BSD)
+endif ()
+if (BSD)
+ list(REMOVE_ITEM EXTENSIONS
+ "devpet.vala"