Initial import of clisp-1999.07.22.
This is CLISP - an ANSI Common Lisp. PR: 16542 Submitted by: Jeff Brown <jabrown@caida.org>
This commit is contained in:
parent
681a41826f
commit
a62db8f6c0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=25732
7 changed files with 181 additions and 0 deletions
|
@ -11,6 +11,7 @@
|
|||
SUBDIR += bwbasic
|
||||
SUBDIR += caml-light
|
||||
SUBDIR += cim
|
||||
SUBDIR += clisp
|
||||
SUBDIR += cmucl
|
||||
SUBDIR += cu-prolog
|
||||
SUBDIR += dylan
|
||||
|
|
70
lang/clisp/Makefile
Normal file
70
lang/clisp/Makefile
Normal file
|
@ -0,0 +1,70 @@
|
|||
# New ports collection makefile for: clisp
|
||||
# Version required: 1999-07-22
|
||||
# Date created: Feb 5 2000
|
||||
# Whom: Jeff Brown <jabrown@caida.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= clisp-1999-07-22
|
||||
PKGNAME= clisp-1999.07.22
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ftp://ftp2.cons.org/pub/lisp/clisp/source/ \
|
||||
ftp://ftp.cdrom.com/pub/lisp/clisp/source/
|
||||
|
||||
MAINTAINER= jabrown@caida.org
|
||||
|
||||
# Build subdirectory
|
||||
BUILD_DIRNAME=obj
|
||||
|
||||
# These came from clisp's "configure" on my system.
|
||||
MAKEMAKE_ARGS=--prefix=${PREFIX} --with-readline --with-gettext \
|
||||
--with-dynamic-ffi
|
||||
|
||||
# The post-install target uses these to fix permissions.
|
||||
DATA_PATHS=${PREFIX}/lib/clisp ${PREFIX}/share/doc/clisp \
|
||||
${PREFIX}/share/locale/de/LC_MESSAGES/clisp.mo \
|
||||
${PREFIX}/share/locale/en/LC_MESSAGES/clisp.mo \
|
||||
${PREFIX}/share/locale/es/LC_MESSAGES/clisp.mo \
|
||||
${PREFIX}/share/locale/fr/LC_MESSAGES/clisp.mo
|
||||
PROG_PATHS=${PREFIX}/bin/clisp
|
||||
MAN_PATHS=${PREFIX}/man/man1/clisp.1 ${PREFIX}/man/man3/clreadline.3
|
||||
|
||||
# The source doesn't include a top-level Makefile, so we'll fake one.
|
||||
post-extract:
|
||||
@cd ${WRKSRC} && \
|
||||
printf "all install:\n\t@cd ${WRKSRC}/${BUILD_DIRNAME} && \$${MAKE} \$${MAKEFLAGS} \$$@\n" > ${WRKSRC}/Makefile
|
||||
|
||||
# It looks like the 'configure' script in the source gets seriously confused
|
||||
# by the environment it gets from GNU_CONFIGURE=YES, so we'll call it here.
|
||||
#
|
||||
# The 'configure' wants the CC environment variable to include CFLAGS; but
|
||||
# I'll ignore it since if CFLAGS includes "-pipe", configure gets stuck reading
|
||||
# from stdin, using the assembler in gcc 2.7.2.3
|
||||
pre-configure:
|
||||
@cd ${WRKSRC} && \
|
||||
${RM} -rf ${BUILD_DIRNAME} && \
|
||||
env CC="${CC}" ./configure --prefix=${PREFIX} ${BUILD_DIRNAME}
|
||||
# env CC="${CC} ${CFLAGS}"
|
||||
|
||||
# The 'configure' script stops short of doing this for us.
|
||||
post-configure:
|
||||
@cd ${WRKSRC}/${BUILD_DIRNAME} && \
|
||||
./makemake ${MAKEMAKE_ARGS} > Makefile && \
|
||||
make config.lsp
|
||||
|
||||
# The build uses INSTALL_* to copy files around, but since the Ports
|
||||
# INSTALL_* try to set file permissions, using them breaks non-root builds.
|
||||
# Instead, we'll just fix up permissions after we install the files.
|
||||
post-install:
|
||||
${CHOWN} -R ${BINOWN}.${BINGRP} ${PROG_PATHS}
|
||||
${CHMOD} -R ugo+rX,ugo-w ${PROG_PATHS}
|
||||
${CHOWN} -R ${SHAREOWN}.${SHAREGRP} ${DATA_PATHS}
|
||||
${CHMOD} -R ugo+rX,ugo-w ${DATA_PATHS}
|
||||
${CHOWN} -R ${MANOWN}.${MANGRP} ${MAN_PATHS}
|
||||
${CHMOD} -R ugo+rX,ugo-w ${MAN_PATHS}
|
||||
|
||||
MAN1= clisp.1
|
||||
MAN3= clreadline.3
|
||||
|
||||
.include <bsd.port.mk>
|
1
lang/clisp/distinfo
Normal file
1
lang/clisp/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (clisp-1999-07-22.tar.gz) = 25bdf66df55b81a54c16ea5102610483
|
17
lang/clisp/files/patch-aa
Normal file
17
lang/clisp/files/patch-aa
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- src/makemake.in.orig Tue Jul 20 12:03:11 1999
|
||||
+++ src/makemake.in Sun Feb 6 11:12:23 2000
|
||||
@@ -1593,7 +1593,14 @@
|
||||
echol "mandir = \$(exec_prefix)${NEXT_}man"
|
||||
echol "htmldir = \$(exec_prefix)${NEXT_}share${NEXT_}html"
|
||||
echol "dvidir = \$(exec_prefix)${NEXT_}share${NEXT_}dvi"
|
||||
+fsstnd=freebsd
|
||||
case "$fsstnd" in
|
||||
+ freebsd)
|
||||
+ echol "docdir = \$(exec_prefix)${NEXT_}share${NEXT_}doc"
|
||||
+ echol "lispdocdir = \$(docdir)${NEXT_}clisp"
|
||||
+ echol "htmldir = \$(lispdocdir)"
|
||||
+ echol "dvidir = \$(lispdocdir)"
|
||||
+ ;;
|
||||
gnu_ext)
|
||||
echol "docdir = \$(exec_prefix)${NEXT_}doc"
|
||||
echol "lispdocdir = \$(docdir)${NEXT_}clisp"
|
1
lang/clisp/pkg-comment
Normal file
1
lang/clisp/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
This is CLISP - an ANSI Common Lisp
|
20
lang/clisp/pkg-descr
Normal file
20
lang/clisp/pkg-descr
Normal file
|
@ -0,0 +1,20 @@
|
|||
Common Lisp is a high-level, all-purpose, object-oriented, dynamic,
|
||||
functional programming language.
|
||||
|
||||
CLISP is a Common Lisp implementation by Bruno Haible of Karlsruhe
|
||||
University and Michael Stoll of Munich University, both in Germany. It
|
||||
mostly supports the Lisp described in the ANSI Common Lisp standard.
|
||||
|
||||
CLISP includes an interpreter, a compiler, a large subset of CLOS, a
|
||||
foreign language interface and a socket interface. An X11 interface is
|
||||
available through CLX and Garnet. Command line editing is provided by
|
||||
readline.
|
||||
|
||||
CLISP is free software and may be distributed under the terms of GNU
|
||||
GPL. You may distribute commercial applications compiled with CLISP,
|
||||
see file COPYRIGHT in the CLISP distribution.
|
||||
|
||||
The user interface comes in German, English, French and Spanish, and
|
||||
can be change at run time.
|
||||
|
||||
WWW: http://clisp.cons.org/
|
71
lang/clisp/pkg-plist
Normal file
71
lang/clisp/pkg-plist
Normal file
|
@ -0,0 +1,71 @@
|
|||
bin/clisp
|
||||
lib/clisp/clisp-link
|
||||
lib/clisp/base/libavcall.a
|
||||
lib/clisp/base/libcallback.a
|
||||
lib/clisp/base/libintl.a
|
||||
lib/clisp/base/libnoreadline.a
|
||||
lib/clisp/base/libreadline.a
|
||||
lib/clisp/base/libsigsegv.a
|
||||
lib/clisp/base/lisp.a
|
||||
lib/clisp/base/lisp.run
|
||||
lib/clisp/base/lispinit.mem
|
||||
lib/clisp/base/makevars
|
||||
lib/clisp/base/modules.h
|
||||
lib/clisp/base/modules.o
|
||||
lib/clisp/data/UnicodeData.txt
|
||||
lib/clisp/full/libavcall.a
|
||||
lib/clisp/full/libcallback.a
|
||||
lib/clisp/full/libintl.a
|
||||
lib/clisp/full/libnoreadline.a
|
||||
lib/clisp/full/libreadline.a
|
||||
lib/clisp/full/libsigsegv.a
|
||||
lib/clisp/full/lisp.a
|
||||
lib/clisp/full/lisp.run
|
||||
lib/clisp/full/lispinit.mem
|
||||
lib/clisp/full/makevars
|
||||
lib/clisp/full/modules.h
|
||||
lib/clisp/full/modules.o
|
||||
lib/clisp/linkkit/clisp.h
|
||||
lib/clisp/linkkit/modules.c
|
||||
lib/clisp/linkkit/modules.d
|
||||
share/doc/clisp/ANNOUNCE
|
||||
share/doc/clisp/COPYRIGHT
|
||||
share/doc/clisp/GNU-GPL
|
||||
share/doc/clisp/MAGIC.add
|
||||
share/doc/clisp/NEWS
|
||||
share/doc/clisp/README
|
||||
share/doc/clisp/README.de
|
||||
share/doc/clisp/README.es
|
||||
share/doc/clisp/SUMMARY
|
||||
share/doc/clisp/doc/CLOS-guide.txt
|
||||
share/doc/clisp/doc/LISP-tutorial.txt
|
||||
share/doc/clisp/doc/clisp.1
|
||||
share/doc/clisp/doc/clisp.dvi
|
||||
share/doc/clisp/doc/clisp.gif
|
||||
share/doc/clisp/doc/clisp.html
|
||||
share/doc/clisp/doc/clreadline.3
|
||||
share/doc/clisp/doc/clreadline.dvi
|
||||
share/doc/clisp/doc/clreadline.html
|
||||
share/doc/clisp/doc/editors.txt
|
||||
share/doc/clisp/doc/impnotes.html
|
||||
share/doc/clisp/doc/readline.dvi
|
||||
share/locale/de/LC_MESSAGES/clisp.mo
|
||||
share/locale/en/LC_MESSAGES/clisp.mo
|
||||
share/locale/es/LC_MESSAGES/clisp.mo
|
||||
share/locale/fr/LC_MESSAGES/clisp.mo
|
||||
@dirrm share/doc/clisp/doc
|
||||
@dirrm share/doc/clisp
|
||||
@dirrm lib/clisp/base
|
||||
@dirrm lib/clisp/data
|
||||
@dirrm lib/clisp/full
|
||||
@dirrm lib/clisp/linkkit
|
||||
@dirrm lib/clisp
|
||||
@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale/de 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale/en/LC_MESSAGES 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale/en 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale/es/LC_MESSAGES 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale/es 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale/fr/LC_MESSAGES 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale/fr 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale 2>/dev/null || true
|
Loading…
Reference in a new issue