Add mdh, which is kindof like the GNOME panel except not.
This commit is contained in:
parent
74f5eee387
commit
a66cf2b83d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=93846
7 changed files with 77 additions and 0 deletions
|
@ -49,6 +49,7 @@
|
|||
SUBDIR += logjam2
|
||||
SUBDIR += loserjabber
|
||||
SUBDIR += mcal
|
||||
SUBDIR += mdh
|
||||
SUBDIR += mencal
|
||||
SUBDIR += mhc
|
||||
SUBDIR += mhc-emacs20
|
||||
|
|
35
deskutils/mdh/Makefile
Normal file
35
deskutils/mdh/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
# New ports collection makefile for: mdh
|
||||
# Date created: 12 November 2003
|
||||
# Whom: Adam Weinberger <adamw@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mdh
|
||||
PORTVERSION= 1.9.54
|
||||
CATEGORIES= deskutils gnome
|
||||
MASTER_SITES= http://www.gozer.org/my_stuff/gtk/gtk/mdh/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= GTK2-based toolbar, sortof a gnomepanel replacement sortof
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_BZIP2= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_GNOME= gnomehack gnomeprefix gnometarget gtk20
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s|<wait.h>|<sys/wait.h>|" \
|
||||
${WRKSRC}/src/mdh.c ${WRKSRC}/src/mdh_panel_temp.c
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
|
||||
.ifndef(NOPORTDOCS)
|
||||
@${MKDIR} ${DATADIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/README ${DATADIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
deskutils/mdh/distinfo
Normal file
1
deskutils/mdh/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (mdh-1.9.54.tar.bz2) = eaacc354521d01a9a41aec9c147e9fe8
|
13
deskutils/mdh/files/patch-src::mdh_panel_temp.c
Normal file
13
deskutils/mdh/files/patch-src::mdh_panel_temp.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- src/mdh_panel_temp.c.orig Wed Nov 12 05:36:52 2003
|
||||
+++ src/mdh_panel_temp.c Wed Nov 12 05:37:28 2003
|
||||
@@ -33,9 +33,9 @@
|
||||
#include <string.h>
|
||||
#include <stdarg.h>
|
||||
#include <errno.h>
|
||||
+#include <sys/types.h>
|
||||
#include <regex.h>
|
||||
#include <signal.h>
|
||||
-#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
#include <time.h>
|
||||
#include <wait.h>
|
19
deskutils/mdh/files/patch-src::mdh_panel_uptime.c
Normal file
19
deskutils/mdh/files/patch-src::mdh_panel_uptime.c
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- src/mdh_panel_uptime.c.orig Wed Nov 12 05:38:41 2003
|
||||
+++ src/mdh_panel_uptime.c Wed Nov 12 05:45:55 2003
|
||||
@@ -40,6 +40,7 @@
|
||||
|
||||
#ifdef BSD4_4
|
||||
#include <sys/sysctl.h>
|
||||
+#include <sys/time.h>
|
||||
#endif
|
||||
|
||||
#ifdef __sun__
|
||||
@@ -227,7 +228,7 @@
|
||||
|
||||
#ifdef BSD4_4
|
||||
if(sysctl(mib, 2, &btime, &size, NULL, 0) != -1 && btime.tv_sec != 0)
|
||||
- sec = (time(NULL) - boottime.tv_sec) + 30;
|
||||
+ sec = (time(NULL) - btime.tv_sec) + 30;
|
||||
#endif
|
||||
|
||||
*seconds = sec;
|
5
deskutils/mdh/pkg-descr
Normal file
5
deskutils/mdh/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
mdh (MailDooHicky) is a GTK2-based toolbar that can display the time,
|
||||
email message count and various system (CPU, network, etc.) utilization.
|
||||
It also features user-definable buttons, a run window and scratch-pad.
|
||||
|
||||
WWW: http://www.gozer.org/my_stuff/gtk/mdh.php
|
3
deskutils/mdh/pkg-plist
Normal file
3
deskutils/mdh/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
bin/mdh
|
||||
%%PORTDOCS%%%%DATADIR%%/README
|
||||
%%PORTDOCS%%@dirrm %%DATADIR%%
|
Loading…
Reference in a new issue