xen-{kernel/tools}: update to 4.13

Sponsored by:		Citrix Systems R&D
Approved by:		bapt
Differential revision:	https://reviews.freebsd.org/D23170
This commit is contained in:
Roger Pau Monné 2020-02-17 09:17:52 +00:00
parent b19a4acbe5
commit a6b94a0696
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=526355
13 changed files with 78 additions and 492 deletions

View file

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= xen
PORTVERSION= 4.12.1
PORTVERSION= 4.13.0
PORTREVISION= 0
CATEGORIES= emulators
MASTER_SITES= http://downloads.xenproject.org/release/xen/${PORTVERSION}/
@ -14,7 +14,7 @@ LICENSE= GPLv2
ONLY_FOR_ARCHS= amd64
USES= cpe gmake python:2.7,build
USES= cpe gmake python:build
# Ports build environment has ARCH=amd64 set which disables Xen automatic arch
# detection, but amd64 is not a valid arch for Xen. Hardcode x86_64 on the
@ -25,19 +25,6 @@ STRIP= #
PLIST_FILES= /boot/xen \
lib/debug/boot/xen.debug
# LLD 8 changed the behaviour re the placement of orphaned sections, which
# produces a non-bootable Xen kernel:
#
# https://bugs.llvm.org/show_bug.cgi?id=42327
#
# Backport the fixes from upstream
EXTRA_PATCHES+= ${PATCHDIR}/0001-x86-linker-add-a-reloc-section-to-ELF-linker-script.patch:-p1 \
${PATCHDIR}/0003-xen-link-handle-.init.rodata.cst-sections-in-the-lin.patch:-p1 \
${PATCHDIR}/0004-x86-check-for-multiboot-1-2-header-presence.patch:-p1
# Fix for Intel foreign mapping issues.
EXTRA_PATCHES+= ${PATCHDIR}/0001-x86-ept-pass-correct-level-to-p2m_entry_modify.patch:-p1
.include <bsd.port.options.mk>
.if ${OPSYS} != FreeBSD

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1565595632
SHA256 (xen-4.12.1.tar.gz) = 5450a85497b84167df1d229b3ab98fb24ef4d6b0510dce522798c13c1b090159
SIZE (xen-4.12.1.tar.gz) = 26970584
TIMESTAMP = 1578928967
SHA256 (xen-4.13.0.tar.gz) = c69ae21b2ddeaf25532a81a448fcc6a218bc56f93c8907b2d416b2d4339c0afe
SIZE (xen-4.13.0.tar.gz) = 39005191

View file

@ -1,57 +0,0 @@
From ec2ab491b52815c1daedfdf3d95d13cfe25fb38e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Roger=20Pau=20Monn=C3=A9?= <roger.pau@citrix.com>
Date: Tue, 16 Jul 2019 09:05:28 +0200
Subject: [PATCH] x86/ept: pass correct level to p2m_entry_modify
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
EPT differs from NPT and shadow when translating page orders to levels
in the physmap page tables. EPT page tables level for order 0 pages is
0, while NPT and shadow instead use 1, ie: EPT page tables levels
starts at 0 while NPT and shadow starts at 1.
Fix the p2m_entry_modify call in atomic_write_ept_entry to always add
one to the level, in order to match NPT and shadow usage.
While there also add a check to ensure p2m_entry_modify is never
called with level == 0. That should allow to catch future errors
related to the level parameter.
Fixes: c7a4c088ad1c ('x86/mm: split p2m ioreq server pages special handling into helper')
Signed-off-by: Roger Pau Monné <roger.pau@citrix.com>
Reviewed-by: Jan Beulich <jbeulich@suse.com>
Reviewed-by: Kevin Tian <kevin.tian@intel.com>
---
xen/arch/x86/mm/p2m-ept.c | 2 +-
xen/include/asm-x86/p2m.h | 1 +
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/xen/arch/x86/mm/p2m-ept.c b/xen/arch/x86/mm/p2m-ept.c
index e3044bee2e..6b8468c793 100644
--- a/xen/arch/x86/mm/p2m-ept.c
+++ b/xen/arch/x86/mm/p2m-ept.c
@@ -51,7 +51,7 @@ static int atomic_write_ept_entry(struct p2m_domain *p2m,
int level)
{
int rc = p2m_entry_modify(p2m, new.sa_p2mt, entryptr->sa_p2mt,
- _mfn(new.mfn), _mfn(entryptr->mfn), level);
+ _mfn(new.mfn), _mfn(entryptr->mfn), level + 1);
if ( rc )
return rc;
diff --git a/xen/include/asm-x86/p2m.h b/xen/include/asm-x86/p2m.h
index 09ef7e02fd..aff34e3adf 100644
--- a/xen/include/asm-x86/p2m.h
+++ b/xen/include/asm-x86/p2m.h
@@ -946,6 +946,7 @@ static inline int p2m_entry_modify(struct p2m_domain *p2m, p2m_type_t nt,
p2m_type_t ot, mfn_t nfn, mfn_t ofn,
unsigned int level)
{
+ BUG_ON(!level);
BUG_ON(level > 1 && (nt == p2m_ioreq_server || nt == p2m_map_foreign));
if ( level != 1 || (nt == ot && mfn_eq(nfn, ofn)) )
--
2.20.1 (Apple Git-117)

View file

@ -1,50 +0,0 @@
From 597c57becbeba21ff9f0c078ba2e32973d09d258 Mon Sep 17 00:00:00 2001
From: Roger Pau Monne <roger.pau@citrix.com>
Date: Thu, 27 Jun 2019 11:33:33 +0200
Subject: [PATCH 1/4] x86/linker: add a reloc section to ELF linker script
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
if the hypervisor has been built with EFI support (ie: multiboot2).
This allows to position the .reloc section correctly in the output
binary.
Note that for the ELF output format the .reloc section is moved before
.bss because the data it contains is read-only, so it belongs with the
other sections containing read-only data.
Signed-off-by: Roger Pau Monné <roger.pau@citrix.com>
Acked-by: Jan Beulich <jbeulich@suse.com>
Acked-by: Andrew Cooper <andrew.cooper3@citrix.com>
---
xen/arch/x86/xen.lds.S | 13 +++++++++++++
1 file changed, 13 insertions(+)
diff --git a/xen/arch/x86/xen.lds.S b/xen/arch/x86/xen.lds.S
index 98a99444c2..cee7cf80dd 100644
--- a/xen/arch/x86/xen.lds.S
+++ b/xen/arch/x86/xen.lds.S
@@ -175,6 +175,19 @@ SECTIONS
} :text
#endif
#endif
+
+/*
+ * ELF builds are linked to a fixed virtual address, and in principle
+ * shouldn't have a .reloc section. However, due to the way EFI support is
+ * currently implemented, retaining the .reloc section is necessary.
+ */
+#if defined(XEN_BUILD_EFI) && !defined(EFI)
+ . = ALIGN(4);
+ DECL_SECTION(.reloc) {
+ *(.reloc)
+ } :text
+#endif
+
_erodata = .;
. = ALIGN(SECTION_ALIGN);
--
2.20.1 (Apple Git-117)

View file

@ -1,53 +0,0 @@
From 874fc28b72fbb49f4f304b9acd3d49afd8326042 Mon Sep 17 00:00:00 2001
From: Roger Pau Monne <roger.pau@citrix.com>
Date: Thu, 27 Jun 2019 11:33:34 +0200
Subject: [PATCH 3/4] xen/link: handle .init.rodata.cst* sections in the linker
script
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Note that those sections when not prefixed with .init are already
handled by the more general .rodata.* matching pattern in the .rodata
output section.
Signed-off-by: Roger Pau Monné <roger.pau@citrix.com>
Acked-by: Andrew Cooper <andrew.cooper3@citrix.com>
[Make .init.rodata consistent with .rodata]
Signed-off-by: Andrew Cooper <andrew.cooper3@citrix.com>
---
xen/arch/arm/xen.lds.S | 3 +--
xen/arch/x86/xen.lds.S | 3 +--
2 files changed, 2 insertions(+), 4 deletions(-)
diff --git a/xen/arch/arm/xen.lds.S b/xen/arch/arm/xen.lds.S
index e664c4441a..12c107f45d 100644
--- a/xen/arch/arm/xen.lds.S
+++ b/xen/arch/arm/xen.lds.S
@@ -154,8 +154,7 @@ SECTIONS
. = ALIGN(PAGE_SIZE);
.init.data : {
*(.init.rodata)
- *(.init.rodata.rel)
- *(.init.rodata.str*)
+ *(.init.rodata.*)
. = ALIGN(POINTER_ALIGN);
__setup_start = .;
diff --git a/xen/arch/x86/xen.lds.S b/xen/arch/x86/xen.lds.S
index cee7cf80dd..a73139cd29 100644
--- a/xen/arch/x86/xen.lds.S
+++ b/xen/arch/x86/xen.lds.S
@@ -219,8 +219,7 @@ SECTIONS
#endif
*(.init.rodata)
- *(.init.rodata.rel)
- *(.init.rodata.str*)
+ *(.init.rodata.*)
. = ALIGN(POINTER_ALIGN);
__setup_start = .;
--
2.20.1 (Apple Git-117)

View file

@ -1,64 +0,0 @@
From e632d56f0f5787204ef9b640d5f9153dcd4cb3de Mon Sep 17 00:00:00 2001
From: Roger Pau Monne <roger.pau@citrix.com>
Date: Thu, 27 Jun 2019 11:33:35 +0200
Subject: [PATCH 4/4] x86: check for multiboot{1, 2} header presence
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
After building the hypervisor binary. Note that the check is performed
by searching for the magic header value at the start of the binary.
Signed-off-by: Roger Pau Monné <roger.pau@citrix.com>
Acked-by: Jan Beulich <jbeulich@suse.com>
Acked-by: Andrew Cooper <andrew.cooper3@citrix.com>
---
.gitignore | 1 +
xen/arch/x86/Makefile | 10 ++++++++--
2 files changed, 9 insertions(+), 2 deletions(-)
diff --git a/.gitignore b/.gitignore
index a77cbff02c..8a19c8af04 100644
--- a/.gitignore
+++ b/.gitignore
@@ -278,6 +278,7 @@ tools/xentrace/xentrace
xen/.banner
xen/.config
xen/.config.old
+xen/.xen.elf32
xen/System.map
xen/arch/x86/asm-macros.i
xen/arch/x86/boot/mkelf32
diff --git a/xen/arch/x86/Makefile b/xen/arch/x86/Makefile
index 8a8d8f060f..5e3840084b 100644
--- a/xen/arch/x86/Makefile
+++ b/xen/arch/x86/Makefile
@@ -99,9 +99,15 @@ endif
syms-warn-dup-y := --warn-dup
syms-warn-dup-$(CONFIG_SUPPRESS_DUPLICATE_SYMBOL_WARNINGS) :=
+$(TARGET): TMP = $(@D)/.$(@F).elf32
$(TARGET): $(TARGET)-syms $(efi-y) boot/mkelf32
- ./boot/mkelf32 $(notes_phdrs) $(TARGET)-syms $(TARGET) $(XEN_IMG_OFFSET) \
+ ./boot/mkelf32 $(notes_phdrs) $(TARGET)-syms $(TMP) $(XEN_IMG_OFFSET) \
`$(NM) $(TARGET)-syms | sed -ne 's/^\([^ ]*\) . __2M_rwdata_end$$/0x\1/p'`
+ od -t x4 -N 8192 $(TMP) | grep 1badb002 > /dev/null || \
+ { echo "No Multiboot1 header found" >&2; false; }
+ od -t x4 -N 32768 $(TMP) | grep e85250d6 > /dev/null || \
+ { echo "No Multiboot2 header found" >&2; false; }
+ mv $(TMP) $(TARGET)
ALL_OBJS := $(BASEDIR)/arch/x86/boot/built_in.o $(BASEDIR)/arch/x86/efi/built_in.o $(ALL_OBJS)
@@ -249,7 +255,7 @@ efi/mkreloc: efi/mkreloc.c
clean::
rm -f asm-offsets.s *.lds boot/*.o boot/*~ boot/core boot/mkelf32
rm -f asm-macros.i $(BASEDIR)/include/asm-x86/asm-macros.*
- rm -f $(BASEDIR)/.xen-syms.[0-9]* boot/.*.d
+ rm -f $(BASEDIR)/.xen-syms.[0-9]* boot/.*.d $(BASEDIR)/.xen.elf32
rm -f $(BASEDIR)/.xen.efi.[0-9]* efi/*.efi efi/mkreloc
rm -f boot/cmdline.S boot/reloc.S boot/*.lnk boot/*.bin
rm -f note.o
--
2.20.1 (Apple Git-117)

View file

@ -2,7 +2,7 @@
PORTNAME= xen
PKGNAMESUFFIX= -tools
PORTVERSION= 4.12.1
PORTVERSION= 4.13.0
PORTREVISION= 0
CATEGORIES= sysutils emulators
MASTER_SITES= http://downloads.xenproject.org/release/xen/${PORTVERSION}/
@ -16,7 +16,8 @@ LICENSE_COMB= multi
LIB_DEPENDS= libyajl.so:devel/yajl \
liblzo2.so:archivers/lzo2 \
libpixman-1.so:x11/pixman \
libargp.so:devel/argp-standalone
libargp.so:devel/argp-standalone \
libxml2.so:textproc/libxml2
BUILD_DEPENDS= seabios>0:misc/seabios
RUN_DEPENDS= seabios>0:misc/seabios
DOCS_BUILD_DEPENDS=markdown:textproc/markdown
@ -34,7 +35,7 @@ ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than amd64"
USES= cpe gettext gmake gnome libtool localbase:ldflags perl5 \
pkgconfig python:2.7 shebangfix
pkgconfig python shebangfix iconv
USE_GNOME= glib20
USE_LDCONFIG= yes
HAS_CONFIGURE= yes
@ -54,18 +55,6 @@ DOCS_ALL_TARGET= docs
INSTALL_TARGET= install-tools
DOCS_INSTALL_TARGET= install-docs
EXTRA_PATCHES+= ${PATCHDIR}/0001-tools-include-propagate-python-interpreter-path.patch:-p1
# LLD 8 changed the behaviour re the placement of orphaned sections, which
# produces a non-bootable Xen kernel:
#
# https://bugs.llvm.org/show_bug.cgi?id=42327
#
# Backport the fixes from upstream
EXTRA_PATCHES+= ${PATCHDIR}/0001-x86-linker-add-a-reloc-section-to-ELF-linker-script.patch:-p1 \
${PATCHDIR}/0003-xen-link-handle-.init.rodata.cst-sections-in-the-lin.patch:-p1 \
${PATCHDIR}/0004-x86-check-for-multiboot-1-2-header-presence.patch:-p1
.include <bsd.port.options.mk>
.if ${OPSYS} != FreeBSD

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1565599755
SHA256 (xen-4.12.1.tar.gz) = 5450a85497b84167df1d229b3ab98fb24ef4d6b0510dce522798c13c1b090159
SIZE (xen-4.12.1.tar.gz) = 26970584
TIMESTAMP = 1578928967
SHA256 (xen-4.13.0.tar.gz) = c69ae21b2ddeaf25532a81a448fcc6a218bc56f93c8907b2d416b2d4339c0afe
SIZE (xen-4.13.0.tar.gz) = 39005191

View file

@ -1,33 +0,0 @@
From 6b9481a710c2158ba47fbc18a0767f643cfdfee1 Mon Sep 17 00:00:00 2001
From: Roger Pau Monne <roger.pau@citrix.com>
Date: Thu, 18 Apr 2019 11:35:00 +0200
Subject: [PATCH] tools/include: propagate python interpreter path
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
To the Makefile that generates the cpuid policy. Without this fix if
the tools python interpreter is different than the default 'python' it
won't be correctly propagated.
Signed-off-by: Roger Pau Monné <roger.pau@citrix.com>
---
tools/include/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/include/Makefile b/tools/include/Makefile
index d693810053..71538e1ce2 100644
--- a/tools/include/Makefile
+++ b/tools/include/Makefile
@@ -32,7 +32,7 @@ endif
touch $@
all-$(CONFIG_X86): xen/.dir
- $(MAKE) -C xen/lib/x86 all XEN_ROOT=$(XEN_ROOT)
+ $(MAKE) -C xen/lib/x86 all XEN_ROOT=$(XEN_ROOT) PYTHON=$(PYTHON)
# Not xen/xsm as that clashes with link to
# $(XEN_ROOT)/xen/include/public/xsm above.
--
2.17.2 (Apple Git-113)

View file

@ -1,50 +0,0 @@
From 597c57becbeba21ff9f0c078ba2e32973d09d258 Mon Sep 17 00:00:00 2001
From: Roger Pau Monne <roger.pau@citrix.com>
Date: Thu, 27 Jun 2019 11:33:33 +0200
Subject: [PATCH 1/4] x86/linker: add a reloc section to ELF linker script
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
if the hypervisor has been built with EFI support (ie: multiboot2).
This allows to position the .reloc section correctly in the output
binary.
Note that for the ELF output format the .reloc section is moved before
.bss because the data it contains is read-only, so it belongs with the
other sections containing read-only data.
Signed-off-by: Roger Pau Monné <roger.pau@citrix.com>
Acked-by: Jan Beulich <jbeulich@suse.com>
Acked-by: Andrew Cooper <andrew.cooper3@citrix.com>
---
xen/arch/x86/xen.lds.S | 13 +++++++++++++
1 file changed, 13 insertions(+)
diff --git a/xen/arch/x86/xen.lds.S b/xen/arch/x86/xen.lds.S
index 98a99444c2..cee7cf80dd 100644
--- a/xen/arch/x86/xen.lds.S
+++ b/xen/arch/x86/xen.lds.S
@@ -175,6 +175,19 @@ SECTIONS
} :text
#endif
#endif
+
+/*
+ * ELF builds are linked to a fixed virtual address, and in principle
+ * shouldn't have a .reloc section. However, due to the way EFI support is
+ * currently implemented, retaining the .reloc section is necessary.
+ */
+#if defined(XEN_BUILD_EFI) && !defined(EFI)
+ . = ALIGN(4);
+ DECL_SECTION(.reloc) {
+ *(.reloc)
+ } :text
+#endif
+
_erodata = .;
. = ALIGN(SECTION_ALIGN);
--
2.20.1 (Apple Git-117)

View file

@ -1,53 +0,0 @@
From 874fc28b72fbb49f4f304b9acd3d49afd8326042 Mon Sep 17 00:00:00 2001
From: Roger Pau Monne <roger.pau@citrix.com>
Date: Thu, 27 Jun 2019 11:33:34 +0200
Subject: [PATCH 3/4] xen/link: handle .init.rodata.cst* sections in the linker
script
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Note that those sections when not prefixed with .init are already
handled by the more general .rodata.* matching pattern in the .rodata
output section.
Signed-off-by: Roger Pau Monné <roger.pau@citrix.com>
Acked-by: Andrew Cooper <andrew.cooper3@citrix.com>
[Make .init.rodata consistent with .rodata]
Signed-off-by: Andrew Cooper <andrew.cooper3@citrix.com>
---
xen/arch/arm/xen.lds.S | 3 +--
xen/arch/x86/xen.lds.S | 3 +--
2 files changed, 2 insertions(+), 4 deletions(-)
diff --git a/xen/arch/arm/xen.lds.S b/xen/arch/arm/xen.lds.S
index e664c4441a..12c107f45d 100644
--- a/xen/arch/arm/xen.lds.S
+++ b/xen/arch/arm/xen.lds.S
@@ -154,8 +154,7 @@ SECTIONS
. = ALIGN(PAGE_SIZE);
.init.data : {
*(.init.rodata)
- *(.init.rodata.rel)
- *(.init.rodata.str*)
+ *(.init.rodata.*)
. = ALIGN(POINTER_ALIGN);
__setup_start = .;
diff --git a/xen/arch/x86/xen.lds.S b/xen/arch/x86/xen.lds.S
index cee7cf80dd..a73139cd29 100644
--- a/xen/arch/x86/xen.lds.S
+++ b/xen/arch/x86/xen.lds.S
@@ -219,8 +219,7 @@ SECTIONS
#endif
*(.init.rodata)
- *(.init.rodata.rel)
- *(.init.rodata.str*)
+ *(.init.rodata.*)
. = ALIGN(POINTER_ALIGN);
__setup_start = .;
--
2.20.1 (Apple Git-117)

View file

@ -1,64 +0,0 @@
From e632d56f0f5787204ef9b640d5f9153dcd4cb3de Mon Sep 17 00:00:00 2001
From: Roger Pau Monne <roger.pau@citrix.com>
Date: Thu, 27 Jun 2019 11:33:35 +0200
Subject: [PATCH 4/4] x86: check for multiboot{1, 2} header presence
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
After building the hypervisor binary. Note that the check is performed
by searching for the magic header value at the start of the binary.
Signed-off-by: Roger Pau Monné <roger.pau@citrix.com>
Acked-by: Jan Beulich <jbeulich@suse.com>
Acked-by: Andrew Cooper <andrew.cooper3@citrix.com>
---
.gitignore | 1 +
xen/arch/x86/Makefile | 10 ++++++++--
2 files changed, 9 insertions(+), 2 deletions(-)
diff --git a/.gitignore b/.gitignore
index a77cbff02c..8a19c8af04 100644
--- a/.gitignore
+++ b/.gitignore
@@ -278,6 +278,7 @@ tools/xentrace/xentrace
xen/.banner
xen/.config
xen/.config.old
+xen/.xen.elf32
xen/System.map
xen/arch/x86/asm-macros.i
xen/arch/x86/boot/mkelf32
diff --git a/xen/arch/x86/Makefile b/xen/arch/x86/Makefile
index 8a8d8f060f..5e3840084b 100644
--- a/xen/arch/x86/Makefile
+++ b/xen/arch/x86/Makefile
@@ -99,9 +99,15 @@ endif
syms-warn-dup-y := --warn-dup
syms-warn-dup-$(CONFIG_SUPPRESS_DUPLICATE_SYMBOL_WARNINGS) :=
+$(TARGET): TMP = $(@D)/.$(@F).elf32
$(TARGET): $(TARGET)-syms $(efi-y) boot/mkelf32
- ./boot/mkelf32 $(notes_phdrs) $(TARGET)-syms $(TARGET) $(XEN_IMG_OFFSET) \
+ ./boot/mkelf32 $(notes_phdrs) $(TARGET)-syms $(TMP) $(XEN_IMG_OFFSET) \
`$(NM) $(TARGET)-syms | sed -ne 's/^\([^ ]*\) . __2M_rwdata_end$$/0x\1/p'`
+ od -t x4 -N 8192 $(TMP) | grep 1badb002 > /dev/null || \
+ { echo "No Multiboot1 header found" >&2; false; }
+ od -t x4 -N 32768 $(TMP) | grep e85250d6 > /dev/null || \
+ { echo "No Multiboot2 header found" >&2; false; }
+ mv $(TMP) $(TARGET)
ALL_OBJS := $(BASEDIR)/arch/x86/boot/built_in.o $(BASEDIR)/arch/x86/efi/built_in.o $(ALL_OBJS)
@@ -249,7 +255,7 @@ efi/mkreloc: efi/mkreloc.c
clean::
rm -f asm-offsets.s *.lds boot/*.o boot/*~ boot/core boot/mkelf32
rm -f asm-macros.i $(BASEDIR)/include/asm-x86/asm-macros.*
- rm -f $(BASEDIR)/.xen-syms.[0-9]* boot/.*.d
+ rm -f $(BASEDIR)/.xen-syms.[0-9]* boot/.*.d $(BASEDIR)/.xen.elf32
rm -f $(BASEDIR)/.xen.efi.[0-9]* efi/*.efi efi/mkreloc
rm -f boot/cmdline.S boot/reloc.S boot/*.lnk boot/*.bin
rm -f note.o
--
2.20.1 (Apple Git-117)

View file

@ -76,6 +76,7 @@ include/xen/hvm/pvdrivers.h
include/xen/hvm/save.h
include/xen/io/9pfs.h
include/xen/io/blkif.h
include/xen/io/cameraif.h
include/xen/io/console.h
include/xen/io/displif.h
include/xen/io/fbif.h
@ -141,8 +142,8 @@ lib/libxencall.so.1
lib/libxencall.so.1.2
lib/libxenctrl.a
lib/libxenctrl.so
lib/libxenctrl.so.4.12
lib/libxenctrl.so.4.12.0
lib/libxenctrl.so.4.13
lib/libxenctrl.so.4.13.0
lib/libxendevicemodel.a
lib/libxendevicemodel.so
lib/libxendevicemodel.so.1
@ -156,24 +157,24 @@ lib/libxenforeignmemory.so
lib/libxenforeignmemory.so.1
lib/libxenforeignmemory.so.1.3
lib/libxenfsimage.so
lib/libxenfsimage.so.4.12
lib/libxenfsimage.so.4.12.0
lib/libxenfsimage.so.4.13
lib/libxenfsimage.so.4.13.0
lib/libxengnttab.a
lib/libxengnttab.so
lib/libxengnttab.so.1
lib/libxengnttab.so.1.2
lib/libxenguest.a
lib/libxenguest.so
lib/libxenguest.so.4.12
lib/libxenguest.so.4.12.0
lib/libxenguest.so.4.13
lib/libxenguest.so.4.13.0
lib/libxenlight.a
lib/libxenlight.so
lib/libxenlight.so.4.12
lib/libxenlight.so.4.12.0
lib/libxenlight.so.4.13
lib/libxenlight.so.4.13.0
lib/libxenstat.a
lib/libxenstat.so
lib/libxenstat.so.4.12
lib/libxenstat.so.4.12.0
lib/libxenstat.so.4.13
lib/libxenstat.so.4.13.0
lib/libxenstore.a
lib/libxenstore.so
lib/libxenstore.so.3.0
@ -188,46 +189,47 @@ lib/libxentoollog.so.1
lib/libxentoollog.so.1.0
lib/libxlutil.a
lib/libxlutil.so
lib/libxlutil.so.4.12
lib/libxlutil.so.4.12.0
lib/libxlutil.so.4.13
lib/libxlutil.so.4.13.0
%%PYTHON_SITELIBDIR%%/grub/ExtLinuxConf.py
%%PYTHON_SITELIBDIR%%/grub/ExtLinuxConf.pyc
%%PYTHON_SITELIBDIR%%/grub/GrubConf.py
%%PYTHON_SITELIBDIR%%/grub/GrubConf.pyc
%%PYTHON_SITELIBDIR%%/grub/LiloConf.py
%%PYTHON_SITELIBDIR%%/grub/LiloConf.pyc
%%PYTHON_SITELIBDIR%%/grub/__init__.py
%%PYTHON_SITELIBDIR%%/grub/__init__.pyc
%%PYTHON_SITELIBDIR%%/grub/__pycache__/ExtLinuxConf.cpython-37.pyc
%%PYTHON_SITELIBDIR%%/grub/__pycache__/GrubConf.cpython-37.pyc
%%PYTHON_SITELIBDIR%%/grub/__pycache__/LiloConf.cpython-37.pyc
%%PYTHON_SITELIBDIR%%/grub/__pycache__/__init__.cpython-37.pyc
%%PYTHON_SITELIBDIR%%/pygrub-0.6-py%%PYTHON_VER%%.egg-info
%%PYTHON_SITELIBDIR%%/xen-3.0-py%%PYTHON_VER%%.egg-info
%%PYTHON_SITELIBDIR%%/xen/__init__.py
%%PYTHON_SITELIBDIR%%/xen/__init__.pyc
%%PYTHON_SITELIBDIR%%/xen/__pycache__/__init__.cpython-37.pyc
%%PYTHON_SITELIBDIR%%/xen/lowlevel/__init__.py
%%PYTHON_SITELIBDIR%%/xen/lowlevel/__init__.pyc
%%PYTHON_SITELIBDIR%%/xen/lowlevel/__pycache__/__init__.cpython-37.pyc
%%PYTHON_SITELIBDIR%%/xen/lowlevel/xc.so
%%PYTHON_SITELIBDIR%%/xen/lowlevel/xs.so
%%PYTHON_SITELIBDIR%%/xen/migration/__init__.py
%%PYTHON_SITELIBDIR%%/xen/migration/__init__.pyc
%%PYTHON_SITELIBDIR%%/xen/migration/__pycache__/__init__.cpython-37.pyc
%%PYTHON_SITELIBDIR%%/xen/migration/__pycache__/legacy.cpython-37.pyc
%%PYTHON_SITELIBDIR%%/xen/migration/__pycache__/libxc.cpython-37.pyc
%%PYTHON_SITELIBDIR%%/xen/migration/__pycache__/libxl.cpython-37.pyc
%%PYTHON_SITELIBDIR%%/xen/migration/__pycache__/public.cpython-37.pyc
%%PYTHON_SITELIBDIR%%/xen/migration/__pycache__/tests.cpython-37.pyc
%%PYTHON_SITELIBDIR%%/xen/migration/__pycache__/verify.cpython-37.pyc
%%PYTHON_SITELIBDIR%%/xen/migration/__pycache__/xl.cpython-37.pyc
%%PYTHON_SITELIBDIR%%/xen/migration/legacy.py
%%PYTHON_SITELIBDIR%%/xen/migration/legacy.pyc
%%PYTHON_SITELIBDIR%%/xen/migration/libxc.py
%%PYTHON_SITELIBDIR%%/xen/migration/libxc.pyc
%%PYTHON_SITELIBDIR%%/xen/migration/libxl.py
%%PYTHON_SITELIBDIR%%/xen/migration/libxl.pyc
%%PYTHON_SITELIBDIR%%/xen/migration/public.py
%%PYTHON_SITELIBDIR%%/xen/migration/public.pyc
%%PYTHON_SITELIBDIR%%/xen/migration/tests.py
%%PYTHON_SITELIBDIR%%/xen/migration/tests.pyc
%%PYTHON_SITELIBDIR%%/xen/migration/verify.py
%%PYTHON_SITELIBDIR%%/xen/migration/verify.pyc
%%PYTHON_SITELIBDIR%%/xen/migration/xl.py
%%PYTHON_SITELIBDIR%%/xen/migration/xl.pyc
%%PYTHON_SITELIBDIR%%/xenfsimage.so
lib/xen/bin/convert-legacy-stream
lib/xen/bin/depriv-fd-checker
lib/xen/bin/libxl-save-helper
lib/xen/bin/lsevtchn
lib/xen/bin/pygrub
lib/xen/bin/qemu-edid
lib/xen/bin/qemu-img
lib/xen/bin/qemu-io
lib/xen/bin/qemu-nbd
@ -296,7 +298,7 @@ sbin/xen-kdd
sbin/xen-livepatch
sbin/xen-lowmemd
sbin/xen-mfndump
sbin/xen-tmem-list-parse
sbin/xen-ucode
sbin/xenbaked
sbin/xenconsoled
sbin/xencov
@ -338,6 +340,7 @@ sbin/xl
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/arm/include,public,hvm,save.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/arm/include,public,io,9pfs.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/arm/include,public,io,blkif.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/arm/include,public,io,cameraif.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/arm/include,public,io,console.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/arm/include,public,io,displif.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/arm/include,public,io,fbif.h.html
@ -409,6 +412,7 @@ sbin/xl
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/x86_32/include,public,io,9pfs.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/x86_32/include,public,io,blkif.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/x86_32/include,public,io,console.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/x86_32/include,public,io,cameraif.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/x86_32/include,public,io,displif.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/x86_32/include,public,io,fbif.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/x86_32/include,public,io,fsif.h.html
@ -477,6 +481,7 @@ sbin/xl
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/x86_64/include,public,hvm,save.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/x86_64/include,public,io,9pfs.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/x86_64/include,public,io,blkif.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/x86_64/include,public,io,cameraif.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/x86_64/include,public,io,console.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/x86_64/include,public,io,displif.h.html
%%PORTDOCS%%%%DOCSDIR%%/html/hypercall/x86_64/include,public,io,fbif.h.html
@ -588,7 +593,6 @@ share/qemu-xen/qemu/efi-vmxnet3.rom
share/qemu-xen/qemu/hppa-firmware.img
share/qemu-xen/qemu/keymaps/ar
share/qemu-xen/qemu/keymaps/bepo
share/qemu-xen/qemu/keymaps/common
share/qemu-xen/qemu/keymaps/cz
share/qemu-xen/qemu/keymaps/da
share/qemu-xen/qemu/keymaps/de
@ -611,9 +615,7 @@ share/qemu-xen/qemu/keymaps/ja
share/qemu-xen/qemu/keymaps/lt
share/qemu-xen/qemu/keymaps/lv
share/qemu-xen/qemu/keymaps/mk
share/qemu-xen/qemu/keymaps/modifiers
share/qemu-xen/qemu/keymaps/nl
share/qemu-xen/qemu/keymaps/nl-be
share/qemu-xen/qemu/keymaps/no
share/qemu-xen/qemu/keymaps/pl
share/qemu-xen/qemu/keymaps/pt
@ -640,8 +642,6 @@ share/qemu-xen/qemu/pxe-ne2k_pci.rom
share/qemu-xen/qemu/pxe-pcnet.rom
share/qemu-xen/qemu/pxe-rtl8139.rom
share/qemu-xen/qemu/pxe-virtio.rom
share/qemu-xen/qemu/qemu-icon.bmp
share/qemu-xen/qemu/qemu_logo_no_text.svg
share/qemu-xen/qemu/qemu_vga.ndrv
share/qemu-xen/qemu/s390-ccw.img
share/qemu-xen/qemu/s390-netboot.img
@ -658,6 +658,40 @@ share/qemu-xen/qemu/vgabios-stdvga.bin
share/qemu-xen/qemu/vgabios-virtio.bin
share/qemu-xen/qemu/vgabios-vmware.bin
share/qemu-xen/qemu/vgabios.bin
share/qemu-xen/applications/qemu.desktop
share/qemu-xen/icons/hicolor/128x128/apps/qemu.png
share/qemu-xen/icons/hicolor/16x16/apps/qemu.png
share/qemu-xen/icons/hicolor/24x24/apps/qemu.png
share/qemu-xen/icons/hicolor/256x256/apps/qemu.png
share/qemu-xen/icons/hicolor/32x32/apps/qemu.bmp
share/qemu-xen/icons/hicolor/32x32/apps/qemu.png
share/qemu-xen/icons/hicolor/48x48/apps/qemu.png
share/qemu-xen/icons/hicolor/512x512/apps/qemu.png
share/qemu-xen/icons/hicolor/64x64/apps/qemu.png
share/qemu-xen/icons/hicolor/scalable/apps/qemu.svg
share/qemu-xen/qemu/edk2-aarch64-code.fd
share/qemu-xen/qemu/edk2-arm-code.fd
share/qemu-xen/qemu/edk2-arm-vars.fd
share/qemu-xen/qemu/edk2-i386-code.fd
share/qemu-xen/qemu/edk2-i386-secure-code.fd
share/qemu-xen/qemu/edk2-i386-vars.fd
share/qemu-xen/qemu/edk2-licenses.txt
share/qemu-xen/qemu/edk2-x86_64-code.fd
share/qemu-xen/qemu/edk2-x86_64-secure-code.fd
share/qemu-xen/qemu/firmware/50-edk2-i386-secure.json
share/qemu-xen/qemu/firmware/50-edk2-x86_64-secure.json
share/qemu-xen/qemu/firmware/60-edk2-aarch64.json
share/qemu-xen/qemu/firmware/60-edk2-arm.json
share/qemu-xen/qemu/firmware/60-edk2-i386.json
share/qemu-xen/qemu/firmware/60-edk2-x86_64.json
share/qemu-xen/qemu/opensbi-riscv32-virt-fw_jump.bin
share/qemu-xen/qemu/opensbi-riscv64-sifive_u-fw_jump.bin
share/qemu-xen/qemu/opensbi-riscv64-virt-fw_jump.bin
share/qemu-xen/qemu/pvh.bin
share/qemu-xen/qemu/qemu-nsis.bmp
share/qemu-xen/qemu/vgabios-ati.bin
share/qemu-xen/qemu/vgabios-bochs-display.bin
share/qemu-xen/qemu/vgabios-ramfb.bin
@dir %%ETCDIR%%/auto
@dir /var/lib/xen/dump
@dir /var/lib/xen/xenpaging