Remove port.
It was repocopied from emulators/sdlmame-devel, but never updated. Spotted by: linimon
This commit is contained in:
parent
810fa3d78f
commit
a6bbc89abc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=270506
9 changed files with 0 additions and 503 deletions
|
@ -1,76 +0,0 @@
|
|||
# New ports collection makefile for: sdlmame
|
||||
# Date created: 2007-01-10
|
||||
# Whom: alepulver
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= sdlmame-devel
|
||||
PORTVERSION= 0.135u3
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= ftp://ftp.arcadebsd.org/pub/ArcadeBSD/ports/distfiles/ \
|
||||
http://rbelmont.mameworld.info/
|
||||
DISTNAME= sdlmame${PORTVERSION:S/.//}
|
||||
|
||||
MAINTAINER= elbarto@ArcadeBSD.org
|
||||
COMMENT= SDL port of the popular MAME (Multi Arcade Machine Emulator)
|
||||
|
||||
FETCH_ENV= HTTP_USER_AGENT=defined
|
||||
USE_ZIP= yes
|
||||
USE_XORG= xext xrender xinerama xi
|
||||
USE_GL= gl
|
||||
USE_GNOME?= gtk20 gconf2
|
||||
USE_GMAKE= yes
|
||||
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
|
||||
USE_SDL= sdl
|
||||
MAKEFILE= makefile
|
||||
ONLY_FOR_ARCHS= i386 amd64
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
OPTIONS= DEBUG "Build sdlmame debugger" off
|
||||
|
||||
IGNORE= outdated, use emulators/mame
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if !defined(WITH_DEBUG)
|
||||
USE_GNOME= #
|
||||
EXTRA_PATCHES+= ${FILESDIR}/sdl.mak.patch
|
||||
.endif
|
||||
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
.if ${ARCH} == "amd64"
|
||||
MAKE_ENV+= PTR64=1
|
||||
.endif
|
||||
.if ${ARCH} == "sparc64"
|
||||
BROKEN= Does not compile on sparc64
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s|ui.bdf|${DATADIR}/ui.bdf|g" ${WRKSRC}/src/emu/ui.c
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
|
||||
${MKDIR} ${PREFIX}/libexec/${PORTNAME}
|
||||
.for f in chdman ldresample ldverify testkeys unidasm
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/${PORTNAME}
|
||||
.endfor
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
|
||||
${CP} -R ${WRKSRC}/docs ${DOCSDIR}
|
||||
.endif
|
||||
${MKDIR} ${DATADIR}
|
||||
${CP} ${WRKSRC}/ui.bdf ${DATADIR}/
|
||||
${CP} -R ${WRKSRC}/keymaps ${DATADIR}/
|
||||
${MKDIR} ${EXAMPLESDIR}
|
||||
${CP} ${FILESDIR}/mame.ini ${EXAMPLESDIR}
|
||||
|
||||
post-install:
|
||||
@${ECHO_CMD}
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
@${ECHO_CMD}
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (sdlmame0135u3.zip) = e360aba6c81a1ec84035bf251c032b02
|
||||
SHA256 (sdlmame0135u3.zip) = 640ae16c6ab8443b183d7228a6903e7c81717b561eeacdf2e664d93a3f0af686
|
||||
SIZE (sdlmame0135u3.zip) = 18735041
|
|
@ -1,262 +0,0 @@
|
|||
<UNADORNED0>
|
||||
|
||||
#
|
||||
# CORE CONFIGURATION OPTIONS
|
||||
#
|
||||
readconfig 1
|
||||
|
||||
#
|
||||
# CORE SEARCH PATH OPTIONS
|
||||
#
|
||||
rompath $HOME/.mame-devel/roms
|
||||
samplepath $HOME/.mame-devel/samples
|
||||
artpath $HOME/.mame-devel/artwork
|
||||
ctrlrpath $HOME/.mame-devel/ctrlr
|
||||
inipath $HOME/.mame-devel;.;ini
|
||||
fontpath /usr/local/share/sdlmame-devel/
|
||||
cheatpath $HOME/.mame-devel/cheat
|
||||
crosshairpath $HOME/.mame-devel/crosshair
|
||||
|
||||
#
|
||||
# CORE OUTPUT DIRECTORY OPTIONS
|
||||
#
|
||||
cfg_directory $HOME/.mame-devel/cfg
|
||||
nvram_directory $HOME/.mame-devel/nvram
|
||||
memcard_directory $HOME/.mame-devel/memcard
|
||||
input_directory $HOME/.mame-devel/inp
|
||||
state_directory $HOME/.mame-devel/sta
|
||||
snapshot_directory $HOME/.mame-devel/snap
|
||||
diff_directory $HOME/.mame-devel/diff
|
||||
comment_directory $HOME/.mame-devel/comments
|
||||
|
||||
#
|
||||
# CORE STATE/PLAYBACK OPTIONS
|
||||
#
|
||||
state
|
||||
autosave 0
|
||||
playback
|
||||
record
|
||||
mngwrite
|
||||
aviwrite
|
||||
wavwrite
|
||||
snapname %g/%i
|
||||
snapsize auto
|
||||
snapview internal
|
||||
burnin 0
|
||||
|
||||
#
|
||||
# CORE PERFORMANCE OPTIONS
|
||||
#
|
||||
autoframeskip 0
|
||||
frameskip 0
|
||||
seconds_to_run 0
|
||||
throttle 1
|
||||
sleep 1
|
||||
speed 1.0
|
||||
refreshspeed 0
|
||||
|
||||
#
|
||||
# CORE ROTATION OPTIONS
|
||||
#
|
||||
rotate 1
|
||||
ror 0
|
||||
rol 0
|
||||
autoror 0
|
||||
autorol 0
|
||||
flipx 0
|
||||
flipy 0
|
||||
|
||||
#
|
||||
# CORE ARTWORK OPTIONS
|
||||
#
|
||||
artwork_crop 0
|
||||
use_backdrops 1
|
||||
use_overlays 1
|
||||
use_bezels 1
|
||||
|
||||
#
|
||||
# CORE SCREEN OPTIONS
|
||||
#
|
||||
brightness 1.0
|
||||
contrast 1.0
|
||||
gamma 1.0
|
||||
pause_brightness 0.65
|
||||
|
||||
#
|
||||
# CORE VECTOR OPTIONS
|
||||
#
|
||||
antialias 1
|
||||
beam 1.0
|
||||
flicker 0
|
||||
|
||||
#
|
||||
# CORE SOUND OPTIONS
|
||||
#
|
||||
sound 1
|
||||
samplerate 48000
|
||||
samples 1
|
||||
volume 0
|
||||
|
||||
#
|
||||
# CORE INPUT OPTIONS
|
||||
#
|
||||
coin_lockout 1
|
||||
ctrlr
|
||||
mouse 0
|
||||
joystick 1
|
||||
lightgun 0
|
||||
multikeyboard 0
|
||||
multimouse 0
|
||||
steadykey 0
|
||||
offscreen_reload 0
|
||||
joystick_map auto
|
||||
joystick_deadzone 0.3
|
||||
joystick_saturation 0.85
|
||||
|
||||
#
|
||||
# CORE INPUT AUTOMATIC ENABLE OPTIONS
|
||||
#
|
||||
paddle_device keyboard
|
||||
adstick_device keyboard
|
||||
pedal_device keyboard
|
||||
dial_device keyboard
|
||||
trackball_device keyboard
|
||||
lightgun_device keyboard
|
||||
positional_device keyboard
|
||||
mouse_device mouse
|
||||
|
||||
#
|
||||
# CORE DEBUGGING OPTIONS
|
||||
#
|
||||
log 0
|
||||
verbose 0
|
||||
update_in_pause 0
|
||||
debug 0
|
||||
debugscript
|
||||
|
||||
#
|
||||
# CORE MISC OPTIONS
|
||||
#
|
||||
bios
|
||||
cheat 0
|
||||
skip_gameinfo 0
|
||||
|
||||
#
|
||||
# DEBUGGING OPTIONS
|
||||
#
|
||||
oslog 0
|
||||
|
||||
#
|
||||
# PERFORMANCE OPTIONS
|
||||
#
|
||||
multithreading 0
|
||||
sdlvideofps 0
|
||||
|
||||
#
|
||||
# VIDEO OPTIONS
|
||||
#
|
||||
video soft
|
||||
numscreens 1
|
||||
window 0
|
||||
maximize 1
|
||||
keepaspect 1
|
||||
unevenstretch 1
|
||||
effect none
|
||||
centerh 1
|
||||
centerv 1
|
||||
waitvsync 0
|
||||
scalemode none
|
||||
|
||||
#
|
||||
# OpenGL-SPECIFIC OPTIONS
|
||||
#
|
||||
filter 1
|
||||
prescale 1
|
||||
gl_forcepow2texture 0
|
||||
gl_notexturerect 0
|
||||
gl_vbo 1
|
||||
gl_pbo 1
|
||||
gl_glsl 0
|
||||
gl_glsl_filter 1
|
||||
glsl_shader_mame0 none
|
||||
glsl_shader_mame1 none
|
||||
glsl_shader_mame2 none
|
||||
glsl_shader_mame3 none
|
||||
glsl_shader_mame4 none
|
||||
glsl_shader_mame5 none
|
||||
glsl_shader_mame6 none
|
||||
glsl_shader_mame7 none
|
||||
glsl_shader_mame8 none
|
||||
glsl_shader_mame9 none
|
||||
glsl_shader_screen0 none
|
||||
glsl_shader_screen1 none
|
||||
glsl_shader_screen2 none
|
||||
glsl_shader_screen3 none
|
||||
glsl_shader_screen4 none
|
||||
glsl_shader_screen5 none
|
||||
glsl_shader_screen6 none
|
||||
glsl_shader_screen7 none
|
||||
glsl_shader_screen8 none
|
||||
glsl_shader_screen9 none
|
||||
gl_glsl_vid_attr 1
|
||||
|
||||
#
|
||||
# PER-WINDOW VIDEO OPTIONS
|
||||
#
|
||||
screen auto
|
||||
aspect auto
|
||||
resolution auto
|
||||
view auto
|
||||
screen0 auto
|
||||
aspect0 auto
|
||||
resolution0 auto
|
||||
view0 auto
|
||||
screen1 auto
|
||||
aspect1 auto
|
||||
resolution1 auto
|
||||
view1 auto
|
||||
screen2 auto
|
||||
aspect2 auto
|
||||
resolution2 auto
|
||||
view2 auto
|
||||
screen3 auto
|
||||
aspect3 auto
|
||||
resolution3 auto
|
||||
view3 auto
|
||||
|
||||
#
|
||||
# FULL SCREEN OPTIONS
|
||||
#
|
||||
switchres 0
|
||||
useallheads 0
|
||||
|
||||
#
|
||||
# SOUND OPTIONS
|
||||
#
|
||||
audio_latency 3
|
||||
|
||||
#
|
||||
# SDL KEYBOARD MAPPING
|
||||
#
|
||||
keymap 0
|
||||
keymap_file keymap.dat
|
||||
|
||||
#
|
||||
# SDL JOYSTICK MAPPING
|
||||
#
|
||||
joy_idx1 auto
|
||||
joy_idx2 auto
|
||||
joy_idx3 auto
|
||||
joy_idx4 auto
|
||||
joy_idx5 auto
|
||||
joy_idx6 auto
|
||||
joy_idx7 auto
|
||||
joy_idx8 auto
|
||||
sixaxis 0
|
||||
|
||||
#
|
||||
# SDL LOWLEVEL DRIVER OPTIONS
|
||||
#
|
||||
videodriver auto
|
||||
audiodriver auto
|
||||
gl_lib auto
|
|
@ -1,67 +0,0 @@
|
|||
--- makefile.orig 2009-11-01 01:19:01.000000000 +0100
|
||||
+++ makefile 2009-11-01 01:21:41.000000000 +0100
|
||||
@@ -59,7 +59,7 @@
|
||||
ifeq ($(OSD),windows)
|
||||
TARGETOS = win32
|
||||
else
|
||||
-TARGETOS = unix
|
||||
+TARGETOS = freebsd
|
||||
endif
|
||||
endif
|
||||
|
||||
@@ -73,7 +73,7 @@
|
||||
# PREFIX =
|
||||
|
||||
# uncomment and specify suffix to be added to the name
|
||||
-# SUFFIX =
|
||||
+SUFFIX = -devel
|
||||
|
||||
|
||||
|
||||
@@ -197,8 +197,8 @@
|
||||
|
||||
# compiler, linker and utilities
|
||||
AR = @ar
|
||||
-CC = @gcc
|
||||
-LD = @gcc
|
||||
+CC := @$(CC)
|
||||
+LD = @$(CC)
|
||||
MD = -mkdir$(EXE)
|
||||
RM = @rm -f
|
||||
|
||||
@@ -227,7 +227,7 @@
|
||||
endif
|
||||
|
||||
# fullname is prefix+name+suffix+debugsuffix
|
||||
-FULLNAME = $(PREFIX)$(NAME)$(CPPSUFFIX)$(SUFFIX)$(DEBUGSUFFIX)
|
||||
+FULLNAME = sdl$(NAME)$(CPPSUFFIX)$(SUFFIX)$(DEBUGSUFFIX)
|
||||
|
||||
# add an EXE suffix to get the final emulator name
|
||||
EMULATOR = $(FULLNAME)$(EXE)
|
||||
@@ -338,7 +338,7 @@
|
||||
ifneq ($(OPTIMIZE),0)
|
||||
ifneq ($(TARGETOS),os2)
|
||||
ifndef IA64
|
||||
-CCOMFLAGS += -Werror -fno-strict-aliasing $(ARCHOPTS)
|
||||
+CCOMFLAGS += -fno-strict-aliasing $(ARCHOPTS)
|
||||
else
|
||||
endif
|
||||
else
|
||||
@@ -382,7 +382,7 @@
|
||||
-I$(SRC)/lib/util \
|
||||
-I$(SRC)/osd \
|
||||
-I$(SRC)/osd/$(OSD) \
|
||||
-
|
||||
+ -I$(LOCALBASE)/include \
|
||||
|
||||
|
||||
#-------------------------------------------------
|
||||
@@ -395,7 +395,7 @@
|
||||
ifneq ($(TARGETOS),macosx)
|
||||
ifneq ($(TARGETOS),os2)
|
||||
ifneq ($(TARGETOS),solaris)
|
||||
-LDFLAGS = -Wl,--warn-common
|
||||
+LDFLAGS = -Wl,--warn-common -L$(LOCALBASE)/lib
|
||||
endif
|
||||
endif
|
||||
endif
|
|
@ -1,11 +0,0 @@
|
|||
--- src/osd/sdl/sdlmain.c.orig 2009-11-01 01:22:48.000000000 +0100
|
||||
+++ src/osd/sdl/sdlmain.c 2009-11-01 01:23:26.000000000 +0100
|
||||
@@ -78,7 +78,7 @@
|
||||
#ifdef MESS
|
||||
#define INI_PATH "$HOME/.mess;.;ini"
|
||||
#else
|
||||
- #define INI_PATH "$HOME/.mame;.;ini"
|
||||
+ #define INI_PATH "$HOME/.mame-devel;.;ini"
|
||||
#endif // MESS
|
||||
#endif // MACOSX
|
||||
#endif // INI_PATH
|
|
@ -1,13 +0,0 @@
|
|||
==============================================================================
|
||||
|
||||
SDLMAME devel has been installed.
|
||||
|
||||
A example configuration file has been installed in "%%EXAMPLESDIR%%/mame.ini"
|
||||
Should you create a "~/.mame-devel" directory and place it here or
|
||||
launch "sdlmame-devel -createconfig" and place the mame.ini created instead.
|
||||
|
||||
If you have a non-qwerty keyboard, you should put in your mame.ini :
|
||||
keymap 1
|
||||
keymap_file %%DATADIR%%/keymaps/km-XX.txt
|
||||
|
||||
==============================================================================
|
|
@ -1,26 +0,0 @@
|
|||
--- src/osd/sdl/sdl.mak.orig 2009-10-25 16:43:25.000000000 +0100
|
||||
+++ src/osd/sdl/sdl.mak 2009-11-01 02:07:41.000000000 +0100
|
||||
@@ -142,6 +142,7 @@
|
||||
ifeq ($(TARGETOS),freebsd)
|
||||
TARGETOS = unix
|
||||
SYNC_IMPLEMENTATION = ntc
|
||||
+DEFS += -DNO_DEBUGGER
|
||||
endif
|
||||
|
||||
ifeq ($(TARGETOS),openbsd)
|
||||
@@ -288,10 +289,11 @@
|
||||
# the new debugger relies on GTK+ in addition to the base SDLMAME needs
|
||||
# Non-X11 builds can not use the debugger
|
||||
ifndef NO_X11
|
||||
-OSDCOREOBJS += $(SDLOBJ)/debugwin.o $(SDLOBJ)/dview.o $(SDLOBJ)/debug-sup.o $(SDLOBJ)/debug-intf.o
|
||||
-CFLAGS += `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gconf-2.0`
|
||||
-LIBS += `pkg-config --libs gtk+-2.0` `pkg-config --libs gconf-2.0`
|
||||
-CFLAGS += -DGTK_DISABLE_DEPRECATED
|
||||
+OSDCOREOBJS += $(SDLOBJ)/debugwin.o
|
||||
+#OSDCOREOBJS += $(SDLOBJ)/debugwin.o $(SDLOBJ)/dview.o $(SDLOBJ)/debug-sup.o $(SDLOBJ)/debug-intf.o
|
||||
+#CFLAGS += `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gconf-2.0`
|
||||
+#LIBS += `pkg-config --libs gtk+-2.0` `pkg-config --libs gconf-2.0`
|
||||
+#CFLAGS += -DGTK_DISABLE_DEPRECATED
|
||||
else
|
||||
OSDCOREOBJS += $(SDLOBJ)/debugwin.o
|
||||
endif # NO_X11
|
|
@ -1,17 +0,0 @@
|
|||
SDLMAME is a port of the popular MAME. There are a few principles that guide
|
||||
it's development:
|
||||
|
||||
1) Run on Linux/Unix, Mac OS X, and other SDL supported operating systems with
|
||||
as few changes as possible to the base Win32 code. This means we can track
|
||||
changes faster than larger more conventional ports such as MacMAME, and we
|
||||
also maintain what I call "Firefox compatibilty" where learning a major app
|
||||
only needs to be done once per application, and it then applies across many
|
||||
operating systems. If you can use the command-line Win32 MAME, you already
|
||||
know how to use SDLMAME on any platform you may encounter it on.
|
||||
|
||||
2) MAME developers are important. By keeping quickly up to date, we make it
|
||||
easy for people on non-Windows platforms to make and submit changes to the
|
||||
core MAME code, and we offer native implementations of MAME's multi-window
|
||||
GUI debugger on both Linux/Unix and Mac OS X.
|
||||
|
||||
WWW: http://rbelmont.mameworld.info/?page_id=163
|
|
@ -1,28 +0,0 @@
|
|||
bin/sdlmame-devel
|
||||
libexec/sdlmame-devel/chdman
|
||||
libexec/sdlmame-devel/ldverify
|
||||
libexec/sdlmame-devel/ldresample
|
||||
libexec/sdlmame-devel/testkeys
|
||||
libexec/sdlmame-devel/unidasm
|
||||
%%PORTDOCS%%%%DOCSDIR%%/SDLMAME.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/docs/license.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/docs/mame.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/docs/newvideo.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/docs/windows.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/docs/config.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/whatsnew.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/whatsnew_0135u3.txt
|
||||
%%DATADIR%%/ui.bdf
|
||||
%%DATADIR%%/keymaps/km-be.txt
|
||||
%%DATADIR%%/keymaps/km-ch.txt
|
||||
%%DATADIR%%/keymaps/km-de.txt
|
||||
%%DATADIR%%/keymaps/km-fr-OSX.txt
|
||||
%%DATADIR%%/keymaps/km-fr.txt
|
||||
%%DATADIR%%/keymaps/km_it.txt
|
||||
%%EXAMPLESDIR%%/mame.ini
|
||||
@dirrm %%DATADIR%%/keymaps/
|
||||
@dirrm %%DATADIR%%/
|
||||
@dirrm libexec/sdlmame-devel
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm %%EXAMPLESDIR%%
|
Loading…
Reference in a new issue