Add mrtparse 1.7, MRT format data parser.

This commit is contained in:
Olivier Cochard 2019-12-02 14:06:17 +00:00
parent 28372facfa
commit a6bf762b01
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=518848
5 changed files with 73 additions and 0 deletions

View file

@ -468,6 +468,7 @@
SUBDIR += mping
SUBDIR += mptsd
SUBDIR += mrouted
SUBDIR += mrtparse
SUBDIR += msend
SUBDIR += mtr
SUBDIR += mtr-nox11

38
net/mrtparse/Makefile Normal file
View file

@ -0,0 +1,38 @@
# $FreeBSD$
PORTNAME= mrtparse
PORTVERSION= 1.7
DISTVERSIONPREFIX= v
CATEGORIES= net python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= olivier@FreeBSD.org
COMMENT= MRT format data parser
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= python shebangfix
GH_ACCOUNT= t2mune
GH_PROJECT= ${PORTNAME}
NO_ARCH= yes
USE_GITHUB= yes
USE_PYTHON= autoplist distutils
SHEBANG_FILES= examples/print_all.py \
examples/mrt2bgpdump.py \
examples/mrt2exabgp.py \
examples/slice.py \
examples/summary.py
post-patch:
@${MV} ${WRKSRC}/examples/print_all.py ${WRKSRC}/examples/mrt_print_all
@${MV} ${WRKSRC}/examples/mrt2bgpdump.py ${WRKSRC}/examples/mrt2bgpdump
@${MV} ${WRKSRC}/examples/mrt2exabgp.py ${WRKSRC}/examples/mrt2exabgp
@${MV} ${WRKSRC}/examples/slice.py ${WRKSRC}/examples/mrt_slice
@${MV} ${WRKSRC}/examples/summary.py ${WRKSRC}/examples/mrt_summary
@${RM} ${WRKSRC}/examples/README.rst
.include <bsd.port.mk>

3
net/mrtparse/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1574355874
SHA256 (t2mune-mrtparse-v1.7_GH0.tar.gz) = 623188ed5fec504ae9e8af214b3d67073deb9e0d7fec474cbe6b4291e74afa78
SIZE (t2mune-mrtparse-v1.7_GH0.tar.gz) = 38322

View file

@ -0,0 +1,26 @@
--- setup.py.orig 2019-01-08 09:46:20 UTC
+++ setup.py
@@ -29,6 +29,7 @@ except ImportError:
import os
import sys
from codecs import open
+from glob import glob
import mrtparse
here = os.path.abspath(os.path.dirname(__file__))
@@ -67,14 +68,7 @@ try:
],
keywords='mrt bgp',
packages = ['mrtparse'],
- package_data={
- 'mrtparse': [
- 'examples/*.py',
- 'samples/bird*',
- 'samples/openbgpd*',
- 'samples/quagga*'
- ]
- },
+ scripts=glob('examples/*'),
zip_safe=False,
)
finally:

5
net/mrtparse/pkg-descr Normal file
View file

@ -0,0 +1,5 @@
Tool to read and analyze the MRT format data. The MRT format can be used to
export routing protocol messages, state changes, and routing information base
contents, and is defined in RFC6396.
WWW: https://github.com/t2mune/mrtparse