Add print/cups-fxlinuxprint, CUPS filter and PPD files for Fuji Xerox
printers ApeosPort-II and DocuCenter-II (DocuPrint) series.
This commit is contained in:
parent
2a58569cb2
commit
a6f1e190e5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=355448
8 changed files with 144 additions and 0 deletions
|
@ -33,6 +33,7 @@
|
|||
SUBDIR += cups-client
|
||||
SUBDIR += cups-cloud-print
|
||||
SUBDIR += cups-filters
|
||||
SUBDIR += cups-fxlinuxprint
|
||||
SUBDIR += cups-image
|
||||
SUBDIR += cups-pdf
|
||||
SUBDIR += cups-pk-helper
|
||||
|
|
24
print/cups-fxlinuxprint/Makefile
Normal file
24
print/cups-fxlinuxprint/Makefile
Normal file
|
@ -0,0 +1,24 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= fxlinuxprint
|
||||
PORTVERSION= 1.0.1
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= ftp://download.fujixerox.co.jp/pub/exe/apeosport/c4300series/
|
||||
PKGNAMEPREFIX= cups-
|
||||
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
|
||||
|
||||
MAINTAINER= hrs@FreeBSD.org
|
||||
COMMENT= Fuji Xerox Printer Driver
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client
|
||||
|
||||
USES= dos2unix
|
||||
DOS2UNIX_FILES= fxlinuxprint.ppd
|
||||
USE_GHOSTSCRIPT_RUN=yes
|
||||
GNU_CONFIGURE= yes
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
.include <bsd.port.mk>
|
2
print/cups-fxlinuxprint/distinfo
Normal file
2
print/cups-fxlinuxprint/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (fxlinuxprint-src-1.0.1.tar.gz) = 369ec48a0f5817a60f63c75b192ccb1d8c8cf30b1d4a16a74a4133242961e515
|
||||
SIZE (fxlinuxprint-src-1.0.1.tar.gz) = 85455
|
15
print/cups-fxlinuxprint/files/patch-Makefile.in
Normal file
15
print/cups-fxlinuxprint/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- Makefile.in.orig 2014-05-09 10:00:10.000000000 +0900
|
||||
+++ Makefile.in 2014-05-09 10:07:35.000000000 +0900
|
||||
@@ -166,9 +166,9 @@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
-cupsfilterdir = /usr/lib/cups/filter
|
||||
-cupsppddir = /usr/share/cups/model/FujiXerox/en
|
||||
-cupsmimedir = /etc/cups
|
||||
+cupsfilterdir = @libexecdir@/cups/filter
|
||||
+cupsppddir = @datadir@/cups/model/FujiXerox/en
|
||||
+cupsmimedir = @sysconfdir@/cups
|
||||
EXTRA_DIST = fxlinuxprint.ppd mimefx.types mimefx.convs
|
||||
cupsppd_DATA = fxlinuxprint.ppd
|
||||
cupsmime_DATA = mimefx.types mimefx.convs
|
20
print/cups-fxlinuxprint/files/patch-fxlinuxprint.c
Normal file
20
print/cups-fxlinuxprint/files/patch-fxlinuxprint.c
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- fxlinuxprint.c.orig 2006-03-06 15:19:54.000000000 +0900
|
||||
+++ fxlinuxprint.c 2014-05-09 10:28:36.000000000 +0900
|
||||
@@ -24,7 +24,7 @@
|
||||
#include <fcntl.h>
|
||||
#define __USE_XOPEN_EXTENDED
|
||||
#include <signal.h>
|
||||
-#include <wait.h>
|
||||
+#include <sys/wait.h>
|
||||
#include <unistd.h>
|
||||
#include <cups/cups.h>
|
||||
#include <cups/ppd.h>
|
||||
@@ -517,7 +517,7 @@
|
||||
if (opt->job_type == JOB_SECURITY) {
|
||||
strcat (pjl, PJLSetHoldType);
|
||||
if (opt->hold_key[0] != 0x00) {
|
||||
- if (Decode (opt->hold_key, decode_buff, &decode_len)) {
|
||||
+ if (Decode ((unsigned char *)opt->hold_key, (unsigned char *)decode_buff, &decode_len)) {
|
||||
decode_buff[decode_len] = 0;
|
||||
} else {
|
||||
strcpy (decode_buff, opt->hold_key);
|
58
print/cups-fxlinuxprint/files/patch-fxlinuxprint.ppd
Normal file
58
print/cups-fxlinuxprint/files/patch-fxlinuxprint.ppd
Normal file
|
@ -0,0 +1,58 @@
|
|||
--- fxlinuxprint.ppd.orig 2014-05-09 10:50:03.000000000 +0900
|
||||
+++ fxlinuxprint.ppd 2014-05-09 10:51:32.000000000 +0900
|
||||
@@ -24,15 +24,15 @@
|
||||
*LanguageEncoding: ISOLatin1
|
||||
*PCFileName: "FXLINUXPRINT.PPD"
|
||||
*Manufacturer: "FX"
|
||||
-*Product: "FX Printer Driver for Linux"
|
||||
+*Product: "(FX Printer Driver)"
|
||||
*cupsVersion: 1.1
|
||||
*cupsManualCopies: True
|
||||
*cupsModelNumber: 2
|
||||
*cupsFilter: "application/vnd.cups-pdfprintfx 0 pdftopjlfx"
|
||||
*cupsFilter: "application/vnd.cups-postscript 0 pstopdffx"
|
||||
-*ShortNickName: "FX Printer Driver for Linux"
|
||||
-*ModelName: "FX Printer Driver for Linux"
|
||||
-*NickName: "FX Printer Driver for Linux"
|
||||
+*ShortNickName: "FX Printer Driver"
|
||||
+*ModelName: "FX Printer Driver"
|
||||
+*NickName: "FX Printer Driver"
|
||||
*PSVersion: "(3010.000) 550"
|
||||
*PSVersion: "(3010.000) 651"
|
||||
*PSVersion: "(3010.000) 652"
|
||||
@@ -73,7 +73,7 @@
|
||||
*PageSize B5/B5 (182 x 257mm): "<</PageSize[516 729]/ImagingBBox null>>setpagedevice"
|
||||
*PageSize Letter/Letter (8.5 x 11"): "<</PageSize[612 792]/ImagingBBox null>>setpagedevice"
|
||||
*PageSize Legal/Legal (8.5 x 14"): "<</PageSize[612 1008]/ImagingBBox null>>setpagedevice"
|
||||
-*PageSize Ledger/Ledger (11 x 17"): "<</PageSize[792 1224]/ImagingBBox null>>setpagedevice"
|
||||
+*PageSize Tabloid/Tabloid (11 x 17"): "<</PageSize[792 1224]/ImagingBBox null>>setpagedevice"
|
||||
*CloseUI: *PageSize
|
||||
|
||||
*OpenUI *PageRegion: PickOne
|
||||
@@ -86,7 +86,7 @@
|
||||
*PageRegion B5/B5 (182 x 257mm): "<</PageSize[516 729]/ImagingBBox null>>setpagedevice"
|
||||
*PageRegion Letter/Letter (8.5 x 11"): "<</PageSize[612 792]/ImagingBBox null>>setpagedevice"
|
||||
*PageRegion Legal/Legal (8.5 x 14"): "<</PageSize[612 1008]/ImagingBBox null>>setpagedevice"
|
||||
-*PageRegion Ledger/Ledger (11 x 17"): "<</PageSize[792 1224]/ImagingBBox null>>setpagedevice"
|
||||
+*PageRegion Tabloid/Tabloid (11 x 17"): "<</PageSize[792 1224]/ImagingBBox null>>setpagedevice"
|
||||
*CloseUI: *PageRegion
|
||||
|
||||
*DefaultImageableArea: A4
|
||||
@@ -97,7 +97,7 @@
|
||||
*ImageableArea A5/A5 (148 x 210mm): "11.62 11.62 407.91 583.65 "
|
||||
*ImageableArea B5/B5 (182 x 257mm): "11.62 11.62 504.28 716.88 "
|
||||
*ImageableArea Legal/Legal (8.5 x 14"): "11.62 11.62 600.38 996.38 "
|
||||
-*ImageableArea Ledger/Ledger (11 x 17"): "11.62 11.62 780.38 1212.38 "
|
||||
+*ImageableArea Tabloid/Tabloid (11 x 17"): "11.62 11.62 780.38 1212.38 "
|
||||
|
||||
*DefaultPaperDimension: A4
|
||||
*PaperDimension Letter/Letter (8.5 x 11"): "612 792"
|
||||
@@ -107,7 +107,7 @@
|
||||
*PaperDimension A5/A5 (148 x 210mm): "419 595"
|
||||
*PaperDimension B5/B5 (182 x 257mm): "516 729"
|
||||
*PaperDimension Legal/Legal (8.5 x 14"): "612 1008"
|
||||
-*PaperDimension Ledger/Ledger (11 x 17"): "792 1224"
|
||||
+*PaperDimension Tabloid/Tabloid (11 x 17"): "792 1224"
|
||||
|
||||
*OpenUI *FXOutputMode/Print Mode: PickOne
|
||||
*OrderDependency: 10.0 AnySetup *FXOutputMode
|
12
print/cups-fxlinuxprint/pkg-descr
Normal file
12
print/cups-fxlinuxprint/pkg-descr
Normal file
|
@ -0,0 +1,12 @@
|
|||
CUPS filter and PPD file for the following Fuji Xerox printers:
|
||||
|
||||
- ApeosPort-II C7500 / C6500 / C5400
|
||||
- DocuCentre-II C7500 / C6500 / C5400
|
||||
- ApeosPort-II C4300 / C3300 / C2200
|
||||
- DocuCentre-II C4300 / C3300 / C2200
|
||||
- ApeosPort-II 7000 / 6000 / 5000
|
||||
- DocuCentre-II 7000 / 6000 / 5000
|
||||
- ApeosPort-II 4000 / 3000
|
||||
- DocuCentre-II 4000 / 3000
|
||||
|
||||
WWW: http://www.fujixerox.co.jp/download/apeosport/download/c4300series/linux_module.html
|
12
print/cups-fxlinuxprint/pkg-plist
Normal file
12
print/cups-fxlinuxprint/pkg-plist
Normal file
|
@ -0,0 +1,12 @@
|
|||
@comment $FreeBSD$
|
||||
etc/cups/mimefx.convs
|
||||
etc/cups/mimefx.types
|
||||
libexec/cups/filter/pdftopdffx
|
||||
libexec/cups/filter/pdftopjlfx
|
||||
libexec/cups/filter/pstopdffx
|
||||
share/cups/model/FujiXerox/en/fxlinuxprint.ppd
|
||||
@dirrmtry share/cups/model/FujiXerox/en
|
||||
@dirrmtry share/cups/model/FujiXerox
|
||||
@dirrmtry share/cups/model
|
||||
@dirrmtry share/cups
|
||||
@dirrmtry etc/cups
|
Loading…
Reference in a new issue